Page 7 of 8

Re: Networking with the PI is making me feel hopless

Posted: Thu Feb 28, 2013 12:06 am
by theimmc
Devon Mafia wrote:It doesnt crash when i ping 127.0.0.1

theres another odd thing about my PI, I have a usb battery with two outputs, one 0.6 amps the other 2amps, it does not matter which one I plug the PI in or which one I plug the screen into, just so long as they are both plugged in does the PI detect ethernet and keyboards etc!!
OK we've established that it's not ping itself that's the problem. But it could be that trying to send ping out on Ethernet draws just enough extra power to cause it to flake out.

But you said that you have ssh working properly? You're able to ssh from your Windows machine into your Raspberry Pi?

Also, are you saying that you must connect the Pi to a HDMI display before the Ethernet (and keyboard) becomes active? BTW without HDMI how do you know if the keyboard is working?

From all that, it sounds like either USB or the SMSC LAN9512 is not working unless HDMI is plugged in. I have no idea how this can happen though, sorry. Hopefully someone with more knowledge of the Pi's hardware can shed some light here.

Re: Networking with the PI is making me feel hopless

Posted: Thu Feb 28, 2013 12:25 am
by Devon Mafia
Ping for 127 does go on for ever n ever though!! just keeps churning out results without stopping

Its not hdmi its vid out, i can ssh in no probs, if i plug a keyboard in it wont detect, I suspect that A little bit of power is wasted because the PI auto detects a vid output, maybe when a curcuit is complet that wastes gone, but strangley enough it doesnt matter what gets 2 amps or what gets 0.6, so long as my PI has both :lol:

Re: Networking with the PI is making me feel hopless

Posted: Thu Feb 28, 2013 7:29 am
by rurwin
ping 127.0.0.1 does not go to the Ethernet though. It is looped-back in the software.

Re: Networking with the PI is making me feel hopless

Posted: Thu Feb 28, 2013 12:11 pm
by Devon Mafia
yeah I can ssh in, so the ethernet does work

Re: Networking with the PI is making me feel hopless

Posted: Thu Feb 28, 2013 12:38 pm
by rurwin
The solution that was suggested when I asked those that know, is that you get one of these: TP-Link TL-WA701ND 150Mbps Wireless N Access Point. Is there any chance of that happening?

Re: Networking with the PI is making me feel hopless

Posted: Thu Feb 28, 2013 3:01 pm
by Devon Mafia
Once I know that internet sharing isn't ever going to happen that will have to be the case, I know the little wirless dongles you mean, I will do that, its annoying though that this PI has to be special

Re: Networking with the PI is making me feel hopless

Posted: Thu Feb 28, 2013 3:19 pm
by rurwin
I think there are other people falling at this hurdle. I just wish I knew what it was.

Can you go through this procedure to turn off the Internet Connection Firewall on your Ethernet adapter.

Re: Networking with the PI is making me feel hopless

Posted: Thu Feb 28, 2013 3:27 pm
by abishur
If it makes you feel better, there are lots of people who fail at this hurdle when using another windows box. The issue revolves around Windows ICS being flaky at best. hmm... I wonder if there's a free non-windows ICS option for XP.

Re: Networking with the PI is making me feel hopless

Posted: Thu Feb 28, 2013 7:06 pm
by theimmc
There's nothing special about networking on the Pi, if anything is unusual, it is Window's Internet Connection Sharing.

Regarding ICS, I agree with rurwin that getting a NAT router is the least painful option. But that aside, you still have some strange issues. For example, I don't know why your HDMI needs to be connected before Ethernet and keyboard comes active.

Can you elaborate on what you mean by a crash on the Pi when you ping 10.0.0.1 from the Pi? Can you describe exactly what you see when you ping the Pi from Windows?

ping on Windows will terminate automatically after 4 pings. On Linux it goes on forever until you press ctrl-C. You can also run it with the -c option (e.g. ping -c 4 127.0.0.1 ) but ctrl-C has fewer keystrokes.

Re: Networking with the PI is making me feel hopless

Posted: Thu Feb 28, 2013 7:28 pm
by Devon Mafia
It freezes after the first line that comes up after you pype
ping //whatever//
im glad other poeple are suffering too :twisted:

I have ubuntu on a partition if theres an easy way to get that up and running, it could at least isolate a few problems

Re: Networking with the PI is making me feel hopless

Posted: Thu Feb 28, 2013 7:34 pm
by abishur
Devon Mafia wrote:It freezes after the first line that comes up after you pype
ping //whatever//
im glad other poeple are suffering too :twisted:

I have ubuntu on a partition if theres an easy way to get that up and running, it could at least isolate a few problems
ICS through ubuntu is amazingly simple. Install Firestarter and dhcp-server, it will walk you through it. VERY simple.

Re: Networking with the PI is making me feel hopless

Posted: Fri Mar 01, 2013 6:59 am
by theimmc
Devon Mafia wrote:It freezes after the first line that comes up after you pype
ping //whatever//
That's not a crash. Ping didn't get a response so it didn't print anything. If you hit ctrl-C, it will exit and tell you how many packets it transmitted, and 0 received, 100% packet loss etc.

For example :

Code: Select all

pi@raspberrypi ~ $ ping 9.9.9.9
PING 9.9.9.9 (9.9.9.9) 56(84) bytes of data.
^C         ( I hit ctrl-C here after a few seconds )
--- 9.9.9.9 ping statistics ---
3 packets transmitted, 0 received, 100% packet loss, time 1999ms
Can you confirm?

Re: Networking with the PI is making me feel hopless

Posted: Fri Mar 01, 2013 4:57 pm
by Devon Mafia
yeah thas right to 8.8.8.8 nine sent 0 recieved

Re: Networking with the PI is making me feel hopless

Posted: Fri Mar 01, 2013 4:59 pm
by Devon Mafia
hey if I ping 10.0.0.2 i get 0% packet loss, thats the number i ssh in

Re: Networking with the PI is making me feel hopless

Posted: Fri Mar 01, 2013 5:06 pm
by Devon Mafia
@rurwin, so create a bridge and see if theres turn of firewall options like you said in that place this time?

Re: Networking with the PI is making me feel hopless

Posted: Fri Mar 01, 2013 5:13 pm
by Devon Mafia
@rurwin, I wasnt able to bridge the connections, however in settings for ethernet i did find a box that says "select the services running on your network that internet users can use" theres also a tab next to that that says icmp

here I can also add a service

Re: Networking with the PI is making me feel hopless

Posted: Fri Mar 01, 2013 7:38 pm
by theimmc
Devon Mafia wrote:hey if I ping 10.0.0.2 i get 0% packet loss, thats the number i ssh in
Yeah, that is the IP address of eth0 on the Pi. You can confirm by typing : ifconfig eth0

You can ssh in from XP to Pi, but you can't ping XP from the Pi. That sounds like Windows Firewall blocking it to me. Let's confirm this by doing this :

1. ssh from XP into Pi
2. On Pi, type : netstat -an | grep 22 | grep tcp

You should see a bunch of lines of output, showing TCP connections (some established, some listening, possibly others. You should see a line that looks like :

tcp 0 0 10.0.0.2:22 10.0.0.1:65028 ESTABLISHED

(it won't look exactly like that, but what we're looking for here is the IP address of your Pi, and the IP address of XP where it is connecting from. 22 is the ssh port number)

Re: Networking with the PI is making me feel hopless

Posted: Fri Mar 01, 2013 10:08 pm
by Devon Mafia
Here tis;

What is this exactly? whats grep mean?

Code: Select all

tcp        0      0 0.0.0.0:22              0.0.0.0:*               LISTEN
tcp        0     32 10.0.0.2:22             10.0.0.1:1091           ESTABLISHED
tcp        0      0 10.0.0.2:22             10.0.0.1:1097           ESTABLISHED
Also my nameserver is 8.8.8.8 no one said if that waas right or not
Am i making it easy for security cracking types by giving all this up?

Re: Networking with the PI is making me feel hopless

Posted: Fri Mar 01, 2013 11:41 pm
by theimmc
Devon Mafia wrote:Here tis;

What is this exactly? whats grep mean?

Code: Select all

tcp        0      0 0.0.0.0:22              0.0.0.0:*               LISTEN
tcp        0     32 10.0.0.2:22             10.0.0.1:1091           ESTABLISHED
tcp        0      0 10.0.0.2:22             10.0.0.1:1097           ESTABLISHED
Also my nameserver is 8.8.8.8 no one said if that waas right or not
Am i making it easy for security cracking types by giving all this up?
No, nothing here compromises your security or even privacy. 8.8.8.8 is Google's DNS server, a safe value to use as long as you trust Google, and don't care if they know what domain names you're looking up.

As long as the IP addresses you're revealing are 10.x.x.x, 192.168.x.x (both local IP that has no meaning on the Internet), 127.0.0.1 (the loopback address for all machines) and 0.0.0.0 (which just mean "match any") there's nothing to worry about. I did not go too far back into your posts to see what other information you gave though - if you reveal your public IP address, those who can be bothered to do so can find out who is your ISP, what region you're located in, and if they're really inclined to do so, gives them a target to probe and attack.

grep is a search / filter utility in *nix systems. netstat shows a list of all network connections (established, listening, closing, etc.) - I asked you to restrict it to ssh only (grep 22 followed by grep tcp). I don't have my Pi here, and I don't recall if "netstat -t" works on Raspbian (assume it does, but you never know - I like to fall back to what's most basic in such situations).

We can see 2 connections from Windows (10.0.0.1) to Pi (10.0.0.2) and that the Pi is listening for new connections. So it looks like everything is OK as far as the Pi is concerned. You mentioned a tab with an option for enabling ICMP under Windows XP's ICS. Can you enable it? ping is an ICMP message (and traceroute depends on ICMP as well, incidentally).

Edit to add information about 8.8.8.8 : http://en.wikipedia.org/wiki/Google_Public_DNS - I suggest keeping it for now.

Re: Networking with the PI is making me feel hopless

Posted: Sat Mar 02, 2013 12:11 am
by Devon Mafia
Okay looks like progress of some kind!! Im having an IP conflict now and cant enable sharing :P

Re: Networking with the PI is making me feel hopless

Posted: Sat Mar 02, 2013 12:19 am
by Devon Mafia
I can now ping 192.168.0.1, I cant enable sharing on my wirless, of course I can enable it on the PI but the PI has no internet

Re: Networking with the PI is making me feel hopless

Posted: Sat Mar 02, 2013 12:25 am
by rurwin
theimmc wrote: You mentioned a tab with an option for enabling ICMP under Windows XP's ICS. Can you enable it? ping is an ICMP message (and traceroute depends on ICMP as well, incidentally).
Good call. Try that.

Re: Networking with the PI is making me feel hopless

Posted: Sat Mar 02, 2013 12:28 am
by theimmc
Devon Mafia wrote:Okay looks like progress of some kind!! Im having an IP conflict now and cant enable sharing :P
IP conflict reported by XP? What's the exact message, and when did it pop up? Any idea what caused this?

Are you pinging 192.168.0.1 from the Pi? Can you also ping 10.0.0.1?

Re: Networking with the PI is making me feel hopless

Posted: Sat Mar 02, 2013 12:34 am
by Devon Mafia
hang on I had the wrong thing in the wrong place, ignore that last anomaly, the exact error is one I have had before "Internet Connection Sharing cannot be enabled. A LAN connection is already configured with the IP address that is required for automatic IP"

the original problem :/

whats default gateway supposed to be in ethernet tcp/ip options (where you put your own input rather than get automaticaly) can I customize the ip dns settings for wirless so they dont conflict with what the PI needs??

this is proly nothing: When i go into firewall settings for wireless and I enable dns tick box with lots of other things in it, then if I enable sharing and get that error message, when i go back to this tock box, i find it unchecked again

Re: Networking with the PI is making me feel hopless

Posted: Sat Mar 02, 2013 1:16 am
by theimmc
I don't have an XP system to test on, but it sounds like you're back to the original issue, like you said.

According to Microsoft's document here, it will try to set your XP's ethernet interface's IP address to 192.168.0.1, but that address is already in use - by your router.

Networking with XP is making me feel hopeless :D