User avatar
dasimpson
Posts: 311
Joined: Fri Jun 29, 2012 2:17 pm

Re: Networking with the PI is making me feel hopless

Mon Feb 18, 2013 1:00 am

if you like me then your more windows based the linux based

User avatar
dasimpson
Posts: 311
Joined: Fri Jun 29, 2012 2:17 pm

Re: Networking with the PI is making me feel hopless

Mon Feb 18, 2013 1:01 am

my pi is in an old gameboy and have to use this way of connecting when im out and about so i can ftp media onto it as i use it as a portable media player
i also use the pi for pentesting

User avatar
Devon Mafia
Posts: 117
Joined: Thu Jan 10, 2013 2:16 pm

Re: Networking with the PI is making me feel hopless

Mon Feb 18, 2013 1:09 am

schmeh i will have to set up static stuff again :P

Here when i manually type in the ip etc what is the gateway supposed to be?

its blanc at the moment, you know, in wired connectiion settings

User avatar
dasimpson
Posts: 311
Joined: Fri Jun 29, 2012 2:17 pm

Re: Networking with the PI is making me feel hopless

Mon Feb 18, 2013 1:11 am

when you turn ics on ics should put an ip address there

User avatar
Devon Mafia
Posts: 117
Joined: Thu Jan 10, 2013 2:16 pm

Re: Networking with the PI is making me feel hopless

Mon Feb 18, 2013 1:12 am

i dont think it does

User avatar
dasimpson
Posts: 311
Joined: Fri Jun 29, 2012 2:17 pm

Re: Networking with the PI is making me feel hopless

Mon Feb 18, 2013 1:14 am

it does when i set mine up

User avatar
Devon Mafia
Posts: 117
Joined: Thu Jan 10, 2013 2:16 pm

Re: Networking with the PI is making me feel hopless

Tue Feb 26, 2013 6:22 pm

Hey i flashed the SD card, set the Pi to static but now the PC thinks the ethernet is unplugged when its not

User avatar
rurwin
Forum Moderator
Forum Moderator
Posts: 4258
Joined: Mon Jan 09, 2012 3:16 pm
Contact: Website

Re: Networking with the PI is making me feel hopless

Tue Feb 26, 2013 6:41 pm

On the Pi: ifconfig eth0

is it down or up?

User avatar
Devon Mafia
Posts: 117
Joined: Thu Jan 10, 2013 2:16 pm

Re: Networking with the PI is making me feel hopless

Tue Feb 26, 2013 6:50 pm

ahh right it keeps crashing, it appears to be a power thing
i can either have keyboardds or it can turn the ethernet on, i cant ssh in thogh despite following you instructions for the static ip address

User avatar
Devon Mafia
Posts: 117
Joined: Thu Jan 10, 2013 2:16 pm

Re: Networking with the PI is making me feel hopless

Tue Feb 26, 2013 6:52 pm

i think that maybe the pi hates me and wishes that i was dead?

User avatar
Devon Mafia
Posts: 117
Joined: Thu Jan 10, 2013 2:16 pm

Re: Networking with the PI is making me feel hopless

Tue Feb 26, 2013 7:01 pm

ethernet is on and off intermittently during startup

User avatar
Devon Mafia
Posts: 117
Joined: Thu Jan 10, 2013 2:16 pm

Re: Networking with the PI is making me feel hopless

Tue Feb 26, 2013 7:17 pm

so i cant tell you if eth0 is up cos i would need both a keyboard and a connetion and thats not going to happen

User avatar
Devon Mafia
Posts: 117
Joined: Thu Jan 10, 2013 2:16 pm

Re: Networking with the PI is making me feel hopless

Tue Feb 26, 2013 9:22 pm

OKAY I CAN SSH IN, BUT THE NET DOESN'T WORK STILL...what now??

It just needs more power now for some reason

User avatar
rurwin
Forum Moderator
Forum Moderator
Posts: 4258
Joined: Mon Jan 09, 2012 3:16 pm
Contact: Website

Re: Networking with the PI is making me feel hopless

Tue Feb 26, 2013 9:43 pm

traceroute and route again. New SD card; let's make sure it's how we expect.

theimmc
Posts: 53
Joined: Tue Feb 05, 2013 10:31 pm

Re: Networking with the PI is making me feel hopless

Tue Feb 26, 2013 11:06 pm

Static IP, able to ssh in, but Internet not working might be a routing or DNS issue. Is default gw set, and is resolve.conf entries correct?

User avatar
Devon Mafia
Posts: 117
Joined: Thu Jan 10, 2013 2:16 pm

Re: Networking with the PI is making me feel hopless

Wed Feb 27, 2013 5:59 pm

Here i think its identical to last time, strangely, this version of raspbian is a bit iffier, It wont detect the ethernet unless I plug the screen in as well, The Pi seems to not have enough power and if the supply is low (running of my comps usb) then it just turns off and on intermittently, if I dont plug the screen in, all those pretty lights bar the red one go out :/

Code: Select all

Last login: Sat Feb  9 03:58:24 2013 from 10.0.0.1
pi@raspberrypi ~ $ traceroute 192.168.8.100
traceroute to 192.168.8.100 (192.168.8.100), 30 hops max, 60 byte packets
 1  * * *
 2  * * *
 3  * * *
 4  * * *
 5  * * *
 6  * * *
 7  * * *
 8  * * *
 9  * * *
10  * * *
11  * * *
12  * * *
13  * * *
14  * * *
15  * * *
16  * * *
17  * * *
18  * * *
19  * * *
20  * * *
21  * * *
22  * * *
23  * * *
24  * * *
25  * * *
26  * * *
27  * * *
28  * * *
29  * * *
30  * * *
pi@raspberrypi ~ $ route
Kernel IP routing table
Destination     Gateway         Genmask         Flags Metric Ref    Use Iface
default         10.0.0.1        0.0.0.0         UG    0      0        0 eth0
10.0.0.0        *               255.255.255.0   U     0      0        0 eth0
pi@raspberrypi ~ $

User avatar
Devon Mafia
Posts: 117
Joined: Thu Jan 10, 2013 2:16 pm

Re: Networking with the PI is making me feel hopless

Wed Feb 27, 2013 6:02 pm

in sudo nano /etc/resolv.conf it says "name server 8.8.8.8" thas it

theimmc
Posts: 53
Joined: Tue Feb 05, 2013 10:31 pm

Re: Networking with the PI is making me feel hopless

Wed Feb 27, 2013 6:11 pm

Devon Mafia wrote:in sudo nano /etc/resolv.conf it says "name server 8.8.8.8" thas it
Does it have a space between name and server? There shouldn't be one.

Can you ping 8.8.8.8?

It looks like your default gateway is set to be 10.0.0.1. Can you ping it?

You mentioned that you're running it off your computer's USB port. What kind of operating system are you running on it? I'd like to get some network information off it to compare against your Pi.

Finally, do you have another USB power source you can use?

User avatar
Devon Mafia
Posts: 117
Joined: Thu Jan 10, 2013 2:16 pm

Re: Networking with the PI is making me feel hopless

Wed Feb 27, 2013 6:29 pm

yeah im using seperate one, im on a really bad version of xp
i say i think at the top there or one page back exactly what it is, im having trouble logging in now, its entirley temperemental

User avatar
Devon Mafia
Posts: 117
Joined: Thu Jan 10, 2013 2:16 pm

Re: Networking with the PI is making me feel hopless

Wed Feb 27, 2013 6:36 pm

thres no gap in 'nameserve' pining 10.0.0.1 or 8.8.8.8 seem to get stuck when i ping them, this happened when pinging things before i reset the sd card

Yeah if i ping something It crashes!
Last edited by Devon Mafia on Wed Feb 27, 2013 6:42 pm, edited 1 time in total.

User avatar
Devon Mafia
Posts: 117
Joined: Thu Jan 10, 2013 2:16 pm

Re: Networking with the PI is making me feel hopless

Wed Feb 27, 2013 6:41 pm

yeah if i ping anything I get a crash

theimmc
Posts: 53
Joined: Tue Feb 05, 2013 10:31 pm

Re: Networking with the PI is making me feel hopless

Wed Feb 27, 2013 9:47 pm

Devon Mafia wrote:Yeah if i ping something It crashes!
OK, that's a new one for me...

Even if you ping 127.0.0.1?

Regardless of any configuration issues (there might not be any), I think you may have some hardware issues, either insufficient power, incompatible SD card, or even bad Pi board. At this point, only thing I can suggest is find someone nearby with a working system, start swapping parts and testing?

User avatar
tonyhughes
Posts: 951
Joined: Wed Dec 26, 2012 3:46 am

Re: Networking with the PI is making me feel hopless

Wed Feb 27, 2013 9:56 pm

Power supply....


And check spelling on all your config changes, because you had incorrect spelling in a config report, and when a user queried it, you replied to say that you didn't have a space, and confirmed the word without the space, but your confirmation was spelt wrong too.

I'm not being picky, but computers are, and if you spell stuff wrong (lost characters, extraneous characters etc), then things will stop working as expected.

Did I read right you power the Pi from your computers USB?

I have done this successfully, BUT the spec for a USB port doesn't call for the right amount of power for a Pi, so chances are you need to look at using a different...

Power supply....

User avatar
Devon Mafia
Posts: 117
Joined: Thu Jan 10, 2013 2:16 pm

Re: Networking with the PI is making me feel hopless

Wed Feb 27, 2013 11:33 pm

It doesnt crash when i ping 127.0.0.1

theres another odd thing about my PI, I have a usb battery with two outputs, one 0.6 amps the other 2amps, it does not matter which one I plug the PI in or which one I plug the screen into, just so long as they are both plugged in does the PI detect ethernet and keyboards etc!!

User avatar
dasimpson
Posts: 311
Joined: Fri Jun 29, 2012 2:17 pm

Re: Networking with the PI is making me feel hopless

Thu Feb 28, 2013 12:02 am

the 2 amp side would be better for the pi that should power it easyerly

Return to “Networking and servers”