User avatar
Devon Mafia
Posts: 117
Joined: Thu Jan 10, 2013 2:16 pm

Networking with the PI is making me feel hopless

Tue Feb 05, 2013 9:18 pm

My P.C. has wirless internet connection from elsewhere in the house, I cant connect to my PI with ssh and then use the PI on the net from there, its not happening, i used to be able to ssh in now my adhcp server and mobax arnt working for some reason.

I have tried posting this problem a few times but I think I either I must not have articulated the problem well enough or no one knows the answer but likes to send links on how to click on the ics button in networking folder, I have done all the simple stuff tutorials cover, this is easy, i can google things but my problem remains weeks later.

I must also stress again I cannot get to my router physically, i cannot change anything that would have my housemates connection disrupted, I cannot flash my sd card (again) I cannot run the networking wizard it does not finish, I cannot enable ICS because the ethernet cable is using that same IP address, I am running XP, I should just be able to ssh into the PI and set things up from there after all ssh DID work, now i dont get any lease numbers :(

I have a wirless dongle for my PI, just its an old one and most likley needs drivers :/ I wouldnt know how to sey it up however when i finally do manage to ssh into my PI...

Im close to calling the PI Trash and chucking it...so sad.

User avatar
rurwin
Forum Moderator
Forum Moderator
Posts: 4258
Joined: Mon Jan 09, 2012 3:16 pm
Contact: Website

Re: Networking with the PI is making me feel hopless

Tue Feb 05, 2013 9:33 pm

I'm going to go through this from the beginning, very carefully, and we should be able to get you up and running.

Two questions:

Am I correct in thinking that your PC has a wired connection to the router? (or is it WiFi?)

What was the physical arrangement of cables and stuff when you had ssh working?

bblood
Posts: 42
Joined: Sat Sep 22, 2012 1:54 am

Re: Networking with the PI is making me feel hopless

Tue Feb 05, 2013 9:36 pm

Might be simplest to hook it to a tv with the RCA jack and use the keyboard from your pc to get it all set up....if you have internet on your pc you should be able to get the wifi dongle to work on the pi....it may not work unless you have a powered hub, though....i had trouble getting my wifi dongle to work along side a usb keyboard on my older rpi model b....anyway, once you have wifi up and running and openssh up and running at boot,you will be good to go....also, set a static ip on the pi so you can find it....

Then you can unplug it from the TV and keyboard and let it do its thing....

User avatar
abishur
Posts: 4477
Joined: Thu Jul 28, 2011 4:10 am
Location: USA
Contact: Website

Re: Networking with the PI is making me feel hopless

Tue Feb 05, 2013 9:51 pm

That's quite the limitations you're exacting, but let's see what we can do.

Why can't you physically get to the router? Is there a lack of spare ports, or is it located somewhere you literally cannot get to?

It is suspicious to me that you can't finish the networking wizard, but that's not really here nor there. can you post the contents of your /etc/network/interfaces file? and you ip settings on your xp box?
Dear forum: Play nice ;-)

User avatar
Devon Mafia
Posts: 117
Joined: Thu Jan 10, 2013 2:16 pm

Re: Networking with the PI is making me feel hopless

Tue Feb 05, 2013 9:54 pm

i am wireless, it was allways ethernet to pi, the only thing that has changed is i think the landlord has added a repeater from where im getting my wireless, im not connected to it, but i cant connect to my router through the ip address i would use to get in!

thanks for your help ive been wound up by this :)

User avatar
Devon Mafia
Posts: 117
Joined: Thu Jan 10, 2013 2:16 pm

Re: Networking with the PI is making me feel hopless

Tue Feb 05, 2013 9:56 pm

I cant get to the router because my landlord has it locked away and everyones using it, hes a technophobe so asking for anything will scare him, and i really wouldnt want to change anything for anyone else, i would be unpopular quickly.

I should be okay with the limititations as i have managed to ssh in and i am hooked to the net, it shud be possible

User avatar
Devon Mafia
Posts: 117
Joined: Thu Jan 10, 2013 2:16 pm

Re: Networking with the PI is making me feel hopless

Tue Feb 05, 2013 10:00 pm

another clue could be when i find that the ethernet connection icon in the bottom right in the tray has a yellow triangle and exclamation in it and i click repair...it gets stuck at 'renewing ip address'

User avatar
abishur
Posts: 4477
Joined: Thu Jul 28, 2011 4:10 am
Location: USA
Contact: Website

Re: Networking with the PI is making me feel hopless

Tue Feb 05, 2013 10:03 pm

ah, from your initial description it sounded like the pi was the wireless one and the computer was the one connected via ethernet.

One last question. Did you initially connect to you pi with internet connection sharing via XP?
Dear forum: Play nice ;-)

User avatar
rurwin
Forum Moderator
Forum Moderator
Posts: 4258
Joined: Mon Jan 09, 2012 3:16 pm
Contact: Website

Re: Networking with the PI is making me feel hopless

Tue Feb 05, 2013 10:11 pm

So ICS seems to be the solution, but there are obviously problems with that, one of which may be that the idiot software uses a fixed network address that might conflict with the WiFi network.

Please open a terminal window on the PC and give the following command:

Code: Select all

ipconfig /all > c:\ip.txt
Then post or attach the file c:\ip.txt here.

Edit: silly me, I put -a instead of /all. Too much Linux.

User avatar
rurwin
Forum Moderator
Forum Moderator
Posts: 4258
Joined: Mon Jan 09, 2012 3:16 pm
Contact: Website

Re: Networking with the PI is making me feel hopless

Tue Feb 05, 2013 10:27 pm

Devon Mafia wrote:another clue could be when i find that the ethernet connection icon in the bottom right in the tray has a yellow triangle and exclamation in it and i click repair...it gets stuck at 'renewing ip address'
Not a problem. In fact a rather encouraging sign. The Ethernet link shouldn't be able to "renew [its] ip address" because there is no DHCP server on that network.

User avatar
Devon Mafia
Posts: 117
Joined: Thu Jan 10, 2013 2:16 pm

Re: Networking with the PI is making me feel hopless

Tue Feb 05, 2013 10:38 pm

here



Windows IP Configuration



Host Name . . . . . . . . . . . . : Devonrevenge

Primary Dns Suffix . . . . . . . :

Node Type . . . . . . . . . . . . : Unknown

IP Routing Enabled. . . . . . . . : No

WINS Proxy Enabled. . . . . . . . : No



Ethernet adapter Wireless Network Connection:



Connection-specific DNS Suffix . :

Description . . . . . . . . . . . : 802.11b/g Mini Card Wireless Adapter

Physical Address. . . . . . . . . : 00-1D-92-C9-80-AF

Dhcp Enabled. . . . . . . . . . . : Yes

Autoconfiguration Enabled . . . . : Yes

IP Address. . . . . . . . . . . . : 192.168.0.16

Subnet Mask . . . . . . . . . . . : 255.255.255.0

Default Gateway . . . . . . . . . : 192.168.0.1

DHCP Server . . . . . . . . . . . : 192.168.0.1

DNS Servers . . . . . . . . . . . : 194.168.4.100

194.168.8.100

Lease Obtained. . . . . . . . . . : Tuesday, February 05, 2013 10:33:25 PM

Lease Expires . . . . . . . . . . : Tuesday, February 05, 2013 11:33:25 PM



Ethernet adapter Ethernet:



Media State . . . . . . . . . . . : Media disconnected

Description . . . . . . . . . . . : Realtek PCIe FE Family Controller

Physical Address. . . . . . . . . : 00-21-85-47-B2-C8

im looking to be good at linux soon :)

User avatar
dasimpson
Posts: 311
Joined: Fri Jun 29, 2012 2:17 pm

Re: Networking with the PI is making me feel hopless

Tue Feb 05, 2013 10:41 pm

ok have you told your computer to share the internet connection on the wireless
from that post the raspberry pi is not connected could you do it again with the rpi on and connected to lan

User avatar
rurwin
Forum Moderator
Forum Moderator
Posts: 4258
Joined: Mon Jan 09, 2012 3:16 pm
Contact: Website

Re: Networking with the PI is making me feel hopless

Tue Feb 05, 2013 11:08 pm

Nope. We have a problem.

XP Internet Connection Sharing only issues IP addresses in the range 192.168.0.x. But you are already using that address range to talk to the router. Result: it ain't gonna work. In fact ICS allocates 192.168.0.1 for the PC, and that's the address of the router.

I think the result will be that if you enable ICS, then you will be able to use ssh to the Pi, but even your PC will not be able to contact the Internet. Can you confirm that?
  1. Click Start, and then click Control Panel.
  2. Click Network and Internet Connections, Click Network Connections.
  3. Right-click the connection that you use to connect to the Internet. This will be the Wireless interface, not the Ethernet interface.
  4. Click Properties. Click the Advanced tab.
  5. Under Internet Connection Sharing, select the "Allow other network users to connect through this computer's Internet connection" check box.
  6. Click OK. You receive a message, Click Yes.
To disable it, just do exactly the same but uncheck "Allow other network users to connect through this computer's Internet connection"

Since you wont have Internet, you may want to print that out first.

Connect the PC and the Pi with an ethernet cable, Reboot or start both of them (I wouldn't trust the PC to reconfigure on the fly, although it might work).

Test SSH.
If it works, give it the command "ipconfig -a" and copy out the response to a notepad file.

Disable ICS, reboot again if necessary and come back and report, with the notepad file if you got that far.

User avatar
dasimpson
Posts: 311
Joined: Fri Jun 29, 2012 2:17 pm

Re: Networking with the PI is making me feel hopless

Tue Feb 05, 2013 11:13 pm

you can change the ip on the lan card to make it any range you wont

User avatar
dasimpson
Posts: 311
Joined: Fri Jun 29, 2012 2:17 pm

Re: Networking with the PI is making me feel hopless

Tue Feb 05, 2013 11:18 pm

when i use ics on my pc i have wireless 192.168.1.101
the lan card has set it self to 192.168.159.1
rpi is 192.168.159.256
rpi had no internet
i then set the dns ip for my service provider and the rpi got internet

User avatar
rurwin
Forum Moderator
Forum Moderator
Posts: 4258
Joined: Mon Jan 09, 2012 3:16 pm
Contact: Website

Re: Networking with the PI is making me feel hopless

Tue Feb 05, 2013 11:24 pm

Windows XP?

User avatar
dasimpson
Posts: 311
Joined: Fri Jun 29, 2012 2:17 pm

Re: Networking with the PI is making me feel hopless

Tue Feb 05, 2013 11:26 pm

windows xp windows 7 and windows 8 lol linux dident try

User avatar
rurwin
Forum Moderator
Forum Moderator
Posts: 4258
Joined: Mon Jan 09, 2012 3:16 pm
Contact: Website

Re: Networking with the PI is making me feel hopless

Tue Feb 05, 2013 11:29 pm

You can change the IP address of the LAN card, but you can not change the address that the Windows DHCP server is providing. The only way to give the Pi an IP address is by DHCP. Mr Mafia can only connect to the Pi with ssh, so he can not simply set a static IP address.

(If ssh works, there is a solution using static IP addresses, but it's try-once-get-it-wrong-and-tough-luck. I've put some feelers out; with any luck there's a registry hack that will change the DHCP server's address range.)

User avatar
dasimpson
Posts: 311
Joined: Fri Jun 29, 2012 2:17 pm

Re: Networking with the PI is making me feel hopless

Tue Feb 05, 2013 11:31 pm

changing the ip on the lan card that is connected to the rpi then restarting windows will change the dhcp address range
if that does not work then try this http://support.microsoft.com/kb/230148

User avatar
rurwin
Forum Moderator
Forum Moderator
Posts: 4258
Joined: Mon Jan 09, 2012 3:16 pm
Contact: Website

Re: Networking with the PI is making me feel hopless

Tue Feb 05, 2013 11:57 pm

Yeah. I've found that, but http://superuser.com/questions/280950/m ... on-sharing says it doesn't work. I'll try it tomorrow at work, where I've got an XP box. I don't want to give Devon Mafia a solution that I'm unsure of.

User avatar
dasimpson
Posts: 311
Joined: Fri Jun 29, 2012 2:17 pm

Re: Networking with the PI is making me feel hopless

Wed Feb 06, 2013 12:04 am

with windows it always seems to be hit or miss

User avatar
abishur
Posts: 4477
Joined: Thu Jul 28, 2011 4:10 am
Location: USA
Contact: Website

Re: Networking with the PI is making me feel hopless

Wed Feb 06, 2013 1:36 am

dasimpson wrote:with windows it always seems to be hit or miss
yeah, I remember I used firestarter on ubuntu fairly easily and very successfully, but that doesn't help the op out much ;-)
Dear forum: Play nice ;-)

User avatar
Devon Mafia
Posts: 117
Joined: Thu Jan 10, 2013 2:16 pm

Re: Networking with the PI is making me feel hopless

Wed Feb 06, 2013 2:17 pm

okay my comp outputs an error which says something like

"a LAN conection is allready configured with the ip address that is required for automatic ip addressing"

If they went through the trouble of writing that error how come they never created a simple fix for that bug?

User avatar
rurwin
Forum Moderator
Forum Moderator
Posts: 4258
Joined: Mon Jan 09, 2012 3:16 pm
Contact: Website

Re: Networking with the PI is making me feel hopless

Wed Feb 06, 2013 2:32 pm

That's not Microsoft's worst error message along those lines.

OK you'll need to set a static IP address on the laptop WiFi adapter before enabling connection sharing.

See steps 6-9 here.
You only need to alter the IP address. Make it 192.168.1.1, and the netmask 255.255.255.0

When you've finished testing everything, just set it back to "Obtain an IP address automatically".

By the way, I've tested this on an XP box now. I'll do some more tonight, but right now I can say:
1. You should find the Pi at 192.168.0.6. (If not that then start at 192.168.0.2 and work upwards.)
2. The registry fix for changing the address range doesn't work; there are no such registry keys. I've not given up on that, quite, and there are other options yet.

User avatar
Devon Mafia
Posts: 117
Joined: Thu Jan 10, 2013 2:16 pm

Re: Networking with the PI is making me feel hopless

Wed Feb 06, 2013 2:49 pm

I still get that error message,

Return to “Networking and servers”