Posts: 2
Joined: Tue Jan 01, 2013 8:34 am

samba share

Sat Jan 19, 2013 7:51 pm

Hello everybody

I was hoping somebody could help me with my little file sharing issue.

I have the raspberry pi, model B, 512MB with Wheezy with an external usb HD hooked up to it. I used the instructions from to set it up and the drive maps up correctly after reboot and the files showed and were accessible to everybody on the network (until I just messed it up :( )

While it worked everybody could read the files, but nobody could write to the disk. Not the pi, not the windows machine on the home network, not the windows machine accessing over the internet and not the linux mint machine on the home network.

If I unplug the external drive from the raspberry pi and connects it to my linux mint box, I can write and edit files on the drive with no issues, but not when it is plugged into the raspberry pi.

I did use this hd to backup my files on the linux mint to upgrade from Maya to Nadia and only after that was finished I added the files I wanted to share on the network and outside of the network on the drive and hocked it up on the raspberry pi. Could that have created some issue?

This is my samba configuration:
path = /home/public/etc/
read only = no
create mask = 0777
directory mask = 0777
guest ok = yes

So to resume I had the problem of being able to see the drive, but not write to it. Then I went and did some changes in samba, tested and changed back and now the windows machine on the home network can access it but the on the linux mint I get "Could not display "smb://raspberrypi/public. The file is of an unknown type." :(

Posts: 2
Joined: Tue Jan 01, 2013 8:34 am

Re: samba share

Sun Jan 20, 2013 10:48 am

After rebooting the linux mint box I am able to access the files on the Raspberry pi again, but still not able to write to it, from any linux or windows machine.
Any ideas?

Posts: 28
Joined: Sun Oct 02, 2011 5:36 am
Location: Traverse City, MI USA
Contact: Website

Re: samba share

Mon Jan 21, 2013 5:53 pm

Sounds like a permission issue to me. What are the permissions set to on the folder?
Ben Hanna
Ducky Pond

Return to “Networking and servers”