lairdrob
Posts: 1
Joined: Tue Jan 15, 2013 11:45 pm

lighttpd with mime and auth

Wed Jan 16, 2013 12:03 am

Hello,

I was wondering of someone could help me with my lighttpd.conf setup.

Code: Select all

server.modules = (
	"mod_access",
	"mod_alias",
	"mod_auth",
	"mod_compress",
 	"mod_redirect",
#       "mod_rewrite",
)

auth.debug = 2
auth.backend = "plain"
auth.backend.plain.userfile = "/home/pi/.lighttpdpassword"


auth.require = ( "/DIR1/" => (
"method" => "basic",
"realm" => "Password protected area",
"require" => "valid-user"
),
"/DIR2/" => (
"method" => "basic",
"realm" => "Password protected area",
"require" => "valid-user"
),
"/DIR3/" => (
"method" => "basic",
"realm" => "Password protected area",
"require" => "valid-user"
)
)


server.document-root        = "/var/www"
server.upload-dirs          = ( "/var/cache/lighttpd/uploads" )
server.errorlog             = "/var/log/lighttpd/error.log"
server.pid-file             = "/var/run/lighttpd.pid"
server.username             = "www-data"
server.groupname            = "www-data"
server.port                 = 80



index-file.names            = ( "index.php", "index.html", "index.lighttpd.html" )
url.access-deny             = ( "~", ".inc" )
static-file.exclude-extensions = ( ".php", ".pl", ".fcgi" )

compress.cache-dir          = "/var/cache/lighttpd/compress/"
compress.filetype           = ( "application/javascript", "text/css", "text/html", "text/plain" )

# default listening port for IPv6 falls back to the IPv4 port
include_shell "/usr/share/lighttpd/use-ipv6.pl " + server.port
include_shell "/usr/share/lighttpd/create-mime.assign.pl"
include_shell "/usr/share/lighttpd/include-conf-enabled.pl"
I'm running a single website from my raspberry pi with some password protected directories. Everything works fine until user try and download one of the .mobi files that are within the protected area. I think I've tracked the issue down to the MIME type - you'll see from the config that I've tried to address this.... but it doesn't work. Users get an error on mobile devices when trying to download the .mobi files - when I disable the password protection - everything works great.

So at the moment I can only seem to have one or the other....

Any ideas as to what I am doing wrong?

Thanks in advance,

lairdrob

DirtyJerz
Posts: 1
Joined: Thu Jan 24, 2013 2:31 am

Re: lighttpd with mime and auth

Thu Jan 24, 2013 2:35 am

I'm assuming you are using Android, as I get the same problem. The problem is android download manager doesn't authenticate. This has been a huge problem for many years on android and one that Google has yet to address. The workaround is to use an alternate browser (firefox/opera) with its own integrated download manager. (Chrome does NOT work)

src: http://code.google.com/p/android/issues/detail?id=1353

Return to “Networking and servers”