Page 1 of 1

apache2-mpm-itk is missing from 10 buster?

Posted: Thu Apr 30, 2020 5:41 am
by whiteshepherd
I would like to install apache2-mpm-itk so I can run my vhosts as different users for security.

However when I use: sudo apt-get install apache2-mpm-itk
I get:

Reading package lists... Done
Building dependency tree
Reading state information... Done
Package apache2-mpm-itk is not available, but is referred to by another package.
This may mean that the package is missing, has been obsoleted, or
is only available from another source

E: Package 'apache2-mpm-itk' has no installation candidate

I am using a Pi 4P with Raspbian GNU/Linux 10 (buster)

So question is how might I install this module so I can run my vhosts as different users? Is there a repository with the missing software?

Thank you for any help. :)

Re: apache2-mpm-itk is missing from 10 buster?

Posted: Thu Apr 30, 2020 8:06 am
by DougieLawson
It wasn't in Stretch either because it's not needed.

Re: apache2-mpm-itk is missing from 10 buster?

Posted: Fri May 01, 2020 4:08 am
by whiteshepherd
Well years ago I had issues with hackers breaking into the server. I chrooted and set individual users on my vhosts. That combined with ACL I never had another break in and they tried plenty.

So is there another way to set individual users to vhosts then? What's the reason for not needing it?


Note: I ended up compiling it from source and adding it to Apache2. However is there is a good reason not to have it vs letting a end user decide I'm still curious.

Re: apache2-mpm-itk is missing from 10 buster?

Posted: Fri May 01, 2020 6:08 pm
by AMarat
try
apt-get install libapache2-mpm-itk