gregp
Posts: 25
Joined: Wed Aug 29, 2012 2:23 pm

DynDns error

Thu Dec 06, 2012 5:26 pm

HI have set up a Dyndns.org address as this is the only account my router supports. I have a D-Link DSR-2640R.

I have an apache2 server running and I can see it when I type the IP address into my browser.

However when I type gregpi.dyndns.org into my browser I get my router home page and not my apache page. I have forwarded port 80 and added my dyndns account settings to the router settings.

Can someone please help me with where I am going wrong as I have been trying to get this to work for days.

Thanks,
Greg

User avatar
Keschy
Posts: 21
Joined: Sat Aug 18, 2012 9:30 pm
Location: Mainz / Germany
Contact: Website

Re: DynDns error

Fri Dec 07, 2012 8:47 am

Hi,

you have to assign the dyndns-service to your pi and not to your router.
Just forward Port 80 on your router and install the tool "ddclient" in your raspberry pi

Code: Select all

sudo apt-get update
sudo apt-get install ddclient
then follow the instrcutions and you're good to go :)

Edit: http://derkev.in/108/raspberry-pi-dyndn ... -ddclient/
You can follow the image-instructions at the bottom
My Webpage: http://derkev.in

gregp
Posts: 25
Joined: Wed Aug 29, 2012 2:23 pm

Re: DynDns error

Fri Dec 07, 2012 9:25 am

Thanks for the help. I have tried all of that and still can't seem to get it to work.

Here is what I have done:
Setup ddclient on my pi
- select service provider (http://www.dyndns.org)
- entered my username and password
- as I have a dlinkdns and dyndns address I selected my dyndns.org address
- Selected Yes when asked to run ddclient on PPP connect
- Changed run_daemon to true in /etc/default/ddclient
- restarted ddclient

Then on my dlink router I have the following setup"
- Port forward port 80 to the local IP address of my pi, this is static
ACTIVE PORT FORWARDING
Private IP Protocol Type Public Start Port Public End Port Connection
192.168.1.6 TCP 80 80 PVC0
- Under DNS setup I have the following
DDNS CONFIGURATION
Enable Dynamic DNS = true:
Server Address: - DynDNS.org(Free)
Host Name: ****.dyndns.org
Username: my dyndns.org username
Password: my dyndns,org password
Verify Password:
Then when I go to ****.dyndns.org in my browser (chrome) all I get is the admin page for my router

If I enter my pi's local IP address into my browser I see my apache website.

I'm sure there is something small that I am missing but just can't seem to find it.

User avatar
jojopi
Posts: 3079
Joined: Tue Oct 11, 2011 8:38 pm

Re: DynDns error

Fri Dec 07, 2012 9:36 am

gregp wrote:Then when I go to ****.dyndns.org in my browser (chrome) all I get is the admin page for my router
If you are testing from inside the LAN this is quite normal. Most routers cannot simulate port forwarding when the client is on the wrong interface. It is unlikely, I hope, that your router is presenting its admin page to everyone on the internet.

gregp
Posts: 25
Joined: Wed Aug 29, 2012 2:23 pm

Re: DynDns error

Fri Dec 07, 2012 10:01 am

I am now seeing my gregpi.dyndns.org webpage in my browser (internal network) but when I asked a friend to check all he gets is an timeout.

So as far as I can see my router admin page can not be viewed by everyone. :)

I am running an apache2 server on port 80 and port 80 is forwarded to my pi's local IP address

Any more help?

User avatar
Keschy
Posts: 21
Joined: Sat Aug 18, 2012 9:30 pm
Location: Mainz / Germany
Contact: Website

Re: DynDns error

Fri Dec 07, 2012 10:32 am

you can check your webpage with an external IP with a webproxy (like hidemyass.com)

did you try your setup without the port-forwarding?
some routers are weird ;)
My Webpage: http://derkev.in

User avatar
Dweeber
Posts: 606
Joined: Fri Aug 17, 2012 3:35 am
Location: Mesa, AZ
Contact: Website

Re: DynDns error

Fri Dec 07, 2012 10:42 am

Possible that your ISP blocks port 80 which would block you use of a web server from your connection??
Dweeber A.K.A. Kevin...
My RPI Info Pages including Current Setup - http://rpi.tnet.com

User avatar
Keschy
Posts: 21
Joined: Sat Aug 18, 2012 9:30 pm
Location: Mainz / Germany
Contact: Website

Re: DynDns error

Fri Dec 07, 2012 11:28 am

i don't think any isp would block port 80 O_o
My Webpage: http://derkev.in

gregp
Posts: 25
Joined: Wed Aug 29, 2012 2:23 pm

Re: DynDns error

Fri Dec 07, 2012 12:11 pm

I have tried setting apache to load with port 8080 and then opened that port on my router as well. I then went to gregpi.dyndns.org:8080 and got the same error.

I am with TalkTalk. Will try check if they block port 80

Thanks

User avatar
azeam
Posts: 194
Joined: Fri Oct 26, 2012 11:13 pm
Contact: Website

Re: DynDns error

Fri Dec 07, 2012 12:28 pm

Try to connect (via an external proxy) to your external IP and not the dyndns address to see if the problem is with the DDNS or the port forwarding. Another useful tool is http://canyouseeme.org/ where you can check open ports.

gregp
Posts: 25
Joined: Wed Aug 29, 2012 2:23 pm

Re: DynDns error

Fri Dec 07, 2012 12:43 pm

I closed port 80 on my router and then went to http://canyouseeme.org/ and tested it. According to the website port 80 is still open. ??????

I then tried to access my dyndns address with hotspot shield enabled and it worked. No still not 100% sure if my setup works but will have to wait to test it when I am out of my home wlan.

Thanks.

User avatar
Dweeber
Posts: 606
Joined: Fri Aug 17, 2012 3:35 am
Location: Mesa, AZ
Contact: Website

Re: DynDns error

Fri Dec 07, 2012 3:16 pm

Keschy wrote:i don't think any isp would block port 80 O_o
You would be wrong.. many block port 25 as well.

http://m.cox.com/residential/middlegeor ... 0000000000
Dweeber A.K.A. Kevin...
My RPI Info Pages including Current Setup - http://rpi.tnet.com

Return to “Networking and servers”