Page 1 of 1

pi 3 access point with webservers

Posted: Tue Oct 16, 2018 1:49 pm
by superbogel
Hi,

I tried setting up the pi to be an offline access point using this :

https://www.raspberrypi.org/documentati ... s-point.md

and also I already have my webserver installed and running well on the pi itself, with the static html, but when I try to connect to the pi access point, I cant get the webserver to work on any of my laptop..

tried hitting the direct ip, and it directs to raspberrypi.local but err_name_resolved,.

what am I missing?

Re: pi 3 access point with webservers

Posted: Tue Oct 16, 2018 1:56 pm
by SurferTim
Which webserver software are you using?

Re: pi 3 access point with webservers

Posted: Tue Oct 16, 2018 5:42 pm
by superbogel
apache2 and mysql setup

Re: pi 3 access point with webservers

Posted: Tue Oct 16, 2018 6:10 pm
by SurferTim
I installed apache2 and the NAT AP as per the docs, and mine works.

http://192.168.4.1

Re: pi 3 access point with webservers

Posted: Wed Oct 17, 2018 12:55 am
by superbogel
did you install the bridge methods?

Re: pi 3 access point with webservers

Posted: Wed Oct 17, 2018 10:07 am
by hippy
Can you ping the Pi from your laptops, and vice-versa ?

It's difficult to say if the Pi isn't exposing itself properly or the laptops simply aren't seeing what is exposed.

Re: pi 3 access point with webservers

Posted: Wed Oct 17, 2018 11:55 am
by SurferTim
superbogel wrote:
Wed Oct 17, 2018 12:55 am
did you install the bridge methods?
No. I used the NAT setup. Did you use the bridge? How did you set your network settings?

Edit: Tried with the bridge setup, and it works also. I assigned the static IP in /etc/dhcpcd.conf.

Code: Select all

denyinterfaces wlan0 eth0

interface br0
static ip_address=192.168.1.240/24
static routers=192.168.1.1
static domain_name_servers=8.8.8.8

Re: pi 3 access point with webservers

Posted: Thu Oct 18, 2018 12:43 am
by superbogel
hippy wrote:
Wed Oct 17, 2018 10:07 am
Can you ping the Pi from your laptops, and vice-versa ?

It's difficult to say if the Pi isn't exposing itself properly or the laptops simply aren't seeing what is exposed.
I can ping and ssh, but I cant access the webserver

Re: pi 3 access point with webservers

Posted: Thu Oct 18, 2018 12:44 am
by superbogel
SurferTim wrote:
Wed Oct 17, 2018 11:55 am
superbogel wrote:
Wed Oct 17, 2018 12:55 am
did you install the bridge methods?
No. I used the NAT setup. Did you use the bridge? How did you set your network settings?

Edit: Tried with the bridge setup, and it works also. I assigned the static IP in /etc/dhcpcd.conf.

Code: Select all

denyinterfaces wlan0 eth0

interface br0
static ip_address=192.168.1.240/24
static routers=192.168.1.1
static domain_name_servers=8.8.8.8
I used the bridge method from the access point tutorials but not assigning IP like what you pasted.. I use the 192.168.4.1 ip range

Re: pi 3 access point with webservers

Posted: Thu Oct 18, 2018 1:03 am
by SurferTim
If you are going to assign a static IP to a bridge, it must be within the localnet, not already used by another device, and outside the dhcp range.