a-tibi
Posts: 13
Joined: Sun Jun 24, 2018 12:01 pm

Wifi stopped working

Thu Oct 11, 2018 5:35 pm

Dear Community,

The raspberry pi 3 b+ was running correctly, with wifi configuration.
Now when plug network cable the connection will work, however wifi connection stopped working, and when the system booting it hangs with set of “waiting up” messages, then continue but without wifi connection!
٢٠١٨١٠١١_٢١٠٩٣٣.jpg
٢٠١٨١٠١١_٢١٠٩٣٣.jpg (171.1 KiB) Viewed 277 times
And the contents of /etc/network/interfaces:

Code: Select all

# interfaces(5) file used by ifup(8) and ifdown(8)

# Please note that this file is written to be used with dhcpcd
# For static IP, consult /etc/dhcpcd.conf and 'man dhcpcd.conf'

# Include files from /etc/network/interfaces.d:
source-directory /etc/network/interfaces.d

allow-hotplug wlan0
iface wlan0 inet manual
wpa-roam /etc/wpa_supplicant/wpa_supplicant.conf
iface default inet dhcp
Can you help me to solve this problem.

a-tibi
Posts: 13
Joined: Sun Jun 24, 2018 12:01 pm

Re: Wifi stopped working

Thu Oct 11, 2018 7:36 pm

Here when I plug network cable: I can see that both ethernet and wifi have ip address, subnet. however when I unplug the network cable. the connection lost (wifi doesnt make the connection)!
Untitled.png
Untitled.png (156.21 KiB) Viewed 261 times

a-tibi
Posts: 13
Joined: Sun Jun 24, 2018 12:01 pm

Re: Wifi stopped working

Fri Oct 12, 2018 2:42 am

Please do you have any advises to solve this problem ?

postiejohn
Posts: 15
Joined: Sun Oct 29, 2017 10:11 am

Re: Wifi stopped working

Sat Oct 13, 2018 3:43 pm

When booted with cable connected then removed after boot, what are the ping times on the wifi

ie

ping 192.168.0.1

(oops in your case you probably need to use 192.168.1.1 - just use ping -b 192.168.1.255 instead)

leave it for a while to see if there are values over about 10 - which may mean wifi interference problems.

SurferTim
Posts: 1764
Joined: Sat Sep 14, 2013 9:27 am
Location: Miramar Beach, Florida

Re: Wifi stopped working

Sat Oct 13, 2018 4:02 pm

If you are using a RPi3B+, you must be running Stretch version. If so, you shouldn't have any additional entries in /etc/network/interfaces. Any static network settings should be done in /etc/dhcpcd.conf.

Return to “Networking and servers”