edwardzion
Posts: 5
Joined: Sat Jul 14, 2018 2:30 pm

SSH not working in new raspbian-first-time-install

Sat Jul 14, 2018 2:50 pm

Hey guys, Yesterday my pi was working well. I was using my pi via ssh in my laptop. This morning I tried to connect but there was an error(connection timeout). So, what I did was took a new SD card and installed a fresh version of raspbian onto it. I enabled ssh in by adding a file named ssh with no extensions. But, the problem still persists. I tried fixing it again and again. I also connected the pi to a screen to check if ssh was enabled and it was already enabled. It was bugging me all day :x . It seems like a hardware issue :oops: . I need to use ssh for a school project and I can't carry around a screen. Any fixes? :idea: ? :?:

pcmanbob
Posts: 4364
Joined: Fri May 31, 2013 9:28 pm
Location: Mansfield UK

Re: SSH not working in new raspbian-first-time-install

Sat Jul 14, 2018 3:12 pm

Hi.

Are you sure you are using the correct IP address to connect to your pi.

while you have the screen /keyboard attached to the pi check its IP address.
Remember we want information.......................no information no help
The use of crystal balls & mind reading is not supported

User avatar
HawaiianPi
Posts: 2784
Joined: Mon Apr 08, 2013 4:53 am
Location: Aloha, Oregon USA

Re: SSH not working in new raspbian-first-time-install

Sat Jul 14, 2018 5:19 pm

Which model Pi?

How are you connecting the Pi to a network?
How did you find your Pi's IP address?
And is your laptop on the same network?

Or are you trying to connect in a different way (like Pi Zero USB Gadget mode or direct Ethernet)?

I have tested the latest version of Raspbian Lite on my Pi0W and it worked as expected. I just added the ssh file and a pre-configured wpa_supplicant.conf to the "boot" partition of a freshly imaged card and booted it up. The Pi0W connected to my router with SSH enabled, and I was able to SSH in after finding the correct IP in my router's client table.
My mind is like a browser. 27 tabs are open, 9 aren't responding,
lots of pop-ups...and where is that annoying music coming from?

edwardzion
Posts: 5
Joined: Sat Jul 14, 2018 2:30 pm

Re: SSH not working in new raspbian-first-time-install

Sun Jul 15, 2018 8:03 am

HawaiianPi wrote:
Sat Jul 14, 2018 5:19 pm
Which model Pi?

How are you connecting the Pi to a network?
How did you find your Pi's IP address?
And is your laptop on the same network?

Or are you trying to connect in a different way (like Pi Zero USB Gadget mode or direct Ethernet)?

I have tested the latest version of Raspbian Lite on my Pi0W and it worked as expected. I just added the ssh file and a pre-configured wpa_supplicant.conf to the "boot" partition of a freshly imaged card and booted it up. The Pi0W connected to my router with SSH enabled, and I was able to SSH in after finding the correct IP in my router's client table.
I am using Raspberry pi 3 B+. I found my pi's IP address using advance IP scanner. I am trying to connect via putty and my laptop is on the same network. The pi is directly connected to my laptop via Ethernet. "raspberrypi.mshome.net" was shown as a dead network.

User avatar
DougieLawson
Posts: 33827
Joined: Sun Jun 16, 2013 11:19 pm
Location: Basingstoke, UK
Contact: Website

Re: SSH not working in new raspbian-first-time-install

Sun Jul 15, 2018 8:08 am

Have you enabled ssh?

Create a /boot/ssh file (sudo touch /boot/ssh or sudo touch /boot/ssh.txt) then reboot. Or use sudo systemctl enable ssh; sudo systemctl start ssh.
Microprocessor, Raspberry Pi & Arduino Hacker
Mainframe database troubleshooter
MQTT Evangelist
Twitter: @DougieLawson

2012-18: 1B*5, 2B*2, B+, A+, Z, ZW, 3Bs*3, 3B+

Any DMs sent on Twitter will be answered next month.

edwardzion
Posts: 5
Joined: Sat Jul 14, 2018 2:30 pm

Re: SSH not working in new raspbian-first-time-install

Sun Jul 15, 2018 8:21 am

DougieLawson wrote:
Sun Jul 15, 2018 8:08 am
Have you enabled ssh?

Create a /boot/ssh file (sudo touch /boot/ssh or sudo touch /boot/ssh.txt) then reboot. Or use sudo systemctl enable ssh; sudo systemctl start ssh.
Yes Sir. I enabled ssh. Yet I am not able to connect.

pcmanbob
Posts: 4364
Joined: Fri May 31, 2013 9:28 pm
Location: Mansfield UK

Re: SSH not working in new raspbian-first-time-install

Sun Jul 15, 2018 8:51 am

Did you check your are using the correct IP in your attempt to connect to the pi ?

Can you ping the pi from your pc ?
Remember we want information.......................no information no help
The use of crystal balls & mind reading is not supported

edwardzion
Posts: 5
Joined: Sat Jul 14, 2018 2:30 pm

Re: SSH not working in new raspbian-first-time-install

Sun Jul 15, 2018 9:18 am

pcmanbob wrote:
Sun Jul 15, 2018 8:51 am
Did you check your are using the correct IP in your attempt to connect to the pi ?

Can you ping the pi from your pc ?
I am using the correct IP.

PhatFil
Posts: 453
Joined: Thu Apr 13, 2017 3:55 pm

Re: SSH not working in new raspbian-first-time-install

Sun Jul 15, 2018 11:03 am

straw clutching time,
have you tried disabling any firewall s/w on your client computer before attempting a connection ? a careless dismissal of a message box could have resulted in a blocking rule??

what client tool are you attempting to connect with? how is it configured? a quick check of my Putty terminal reminded me ssh traffic is expected over port 22..

edwardzion
Posts: 5
Joined: Sat Jul 14, 2018 2:30 pm

Re: SSH not working in new raspbian-first-time-install

Sun Jul 15, 2018 2:04 pm

PhatFil wrote:
Sun Jul 15, 2018 11:03 am
straw clutching time,
have you tried disabling any firewall s/w on your client computer before attempting a connection ? a careless dismissal of a message box could have resulted in a blocking rule??

what client tool are you attempting to connect with? how is it configured? a quick check of my Putty terminal reminded me ssh traffic is expected over port 22..
I tried disabling the firewall and it worked!! Thank you very much. Your help is appreciated :D :D :D

PhatFil
Posts: 453
Joined: Thu Apr 13, 2017 3:55 pm

Re: SSH not working in new raspbian-first-time-install

Sun Jul 15, 2018 6:49 pm

edwardzion wrote:
Sun Jul 15, 2018 2:04 pm
PhatFil wrote:
Sun Jul 15, 2018 11:03 am
straw clutching time,
have you tried disabling any firewall s/w on your client computer before attempting a connection ? a careless dismissal of a message box could have resulted in a blocking rule??

what client tool are you attempting to connect with? how is it configured? a quick check of my Putty terminal reminded me ssh traffic is expected over port 22..
I tried disabling the firewall and it worked!! Thank you very much. Your help is appreciated :D :D :D
Ha it was bound to work sometime.... now to correct the rule blocking access..

Return to “Networking and servers”

Who is online

Users browsing this forum: No registered users and 9 guests