pister
Posts: 7
Joined: Thu Jun 21, 2018 5:24 pm

PiVPN/OpenVPN won't work/connect

Thu Jun 21, 2018 5:54 pm

Hi guys,
I'm having trouble with PiVPN/OpenVPN it is running on noobs the app starts up but the client won't connect, according to the pi everything is fine.

When I run:

Code: Select all

sudo service openvpn status
it outputs:
● openvpn.service - OpenVPN service
Loaded: loaded (/lib/systemd/system/openvpn.service; enabled; vendor preset:
Active: active (exited) since Thu 2018-06-21 18:28:10 BST; 20s ago
Process: 430 ExecStart=/bin/true (code=exited, status=0/SUCCESS)
Main PID: 430 (code=exited, status=0/SUCCESS)
CGroup: /system.slice/openvpn.service

Jun 21 18:28:10 raspberrypi systemd[1]: Starting OpenVPN service...
Jun 21 18:28:10 raspberrypi systemd[1]: Started OpenVPN service.
It only works when I reinstall it and until I reboot it.

When I try to connect with the client the client outputs:
Thu Jun 21 18:29:20 2018 OpenVPN 2.4.6 x86_64-w64-mingw32 [SSL (OpenSSL)] [LZO] [LZ4] [PKCS11] [AEAD] built on Apr 26 2018
Thu Jun 21 18:29:20 2018 Windows version 6.2 (Windows 8 or greater) 64bit
Thu Jun 21 18:29:20 2018 library versions: OpenSSL 1.1.0h 27 Mar 2018, LZO 2.10
Thu Jun 21 18:29:20 2018 MANAGEMENT: TCP Socket listening on [AF_INET]127.0.0.1:25340
Thu Jun 21 18:29:20 2018 Need hold release from management interface, waiting...
Thu Jun 21 18:29:20 2018 MANAGEMENT: Client connected from [AF_INET]127.0.0.1:25340
Thu Jun 21 18:29:21 2018 MANAGEMENT: CMD 'state on'
Thu Jun 21 18:29:21 2018 MANAGEMENT: CMD 'log all on'
Thu Jun 21 18:29:21 2018 MANAGEMENT: CMD 'echo all on'
Thu Jun 21 18:29:21 2018 MANAGEMENT: CMD 'bytecount 5'
Thu Jun 21 18:29:21 2018 MANAGEMENT: CMD 'hold off'
Thu Jun 21 18:29:21 2018 MANAGEMENT: CMD 'hold release'
Thu Jun 21 18:29:21 2018 Outgoing Control Channel Encryption: Cipher 'AES-256-CTR' initialized with 256 bit key
Thu Jun 21 18:29:21 2018 Outgoing Control Channel Encryption: Using 256 bit message hash 'SHA256' for HMAC authentication
Thu Jun 21 18:29:21 2018 Incoming Control Channel Encryption: Cipher 'AES-256-CTR' initialized with 256 bit key
Thu Jun 21 18:29:21 2018 Incoming Control Channel Encryption: Using 256 bit message hash 'SHA256' for HMAC authentication
Thu Jun 21 18:29:21 2018 TCP/UDP: Preserving recently used remote address: [AF_INET]90.254.86.63:1194
Thu Jun 21 18:29:21 2018 Socket Buffers: R=[65536->65536] S=[65536->65536]
Thu Jun 21 18:29:21 2018 UDP link local: (not bound)
Thu Jun 21 18:29:21 2018 UDP link remote: [AF_INET]90.254.86.63:1194
Thu Jun 21 18:29:21 2018 MANAGEMENT: >STATE:1529602161,WAIT,,,,,,
Thu Jun 21 18:30:21 2018 TLS Error: TLS key negotiation failed to occur within 60 seconds (check your network connectivity)
Thu Jun 21 18:30:21 2018 TLS Error: TLS handshake failed
Thu Jun 21 18:30:21 2018 SIGUSR1[soft,tls-error] received, process restarting
Thu Jun 21 18:30:21 2018 MANAGEMENT: >STATE:1529602221,RECONNECTING,tls-error,,,,,
Thu Jun 21 18:30:21 2018 Restart pause, 5 second(s)
Thu Jun 21 18:30:26 2018 TCP/UDP: Preserving recently used remote address: [AF_INET]90.254.86.63:1194
Thu Jun 21 18:30:26 2018 Socket Buffers: R=[65536->65536] S=[65536->65536]
Thu Jun 21 18:30:26 2018 UDP link local: (not bound)
Thu Jun 21 18:30:26 2018 UDP link remote: [AF_INET]90.254.86.63:1194
Thu Jun 21 18:30:26 2018 MANAGEMENT: >STATE:1529602226,WAIT,,,,,,
It repeats this over and over again until I disconnect.

I have port forwarded to correct ports already and allowed exposed host.

Please help and thanks in advance

epoch1970
Posts: 1768
Joined: Thu May 05, 2016 9:33 am
Location: Paris, France

Re: PiVPN/OpenVPN won't work/connect

Fri Jun 22, 2018 2:06 pm

pister wrote:
Thu Jun 21, 2018 5:54 pm
It only works when I reinstall it and until I reboot it.
I don't know how NOOBS works, but under Raspbian, you should edit /etc/default/openvpn to get it to start at boot time.
"S'il n'y a pas de solution, c'est qu'il n'y a pas de problème." Les Shadoks, J. Rouxel

pister
Posts: 7
Joined: Thu Jun 21, 2018 5:24 pm

Thanks

Fri Jun 22, 2018 3:35 pm

Thanks it worked!!!!!!!!!!!!!!!!!! :D :D :D :D :D

Return to “Networking and servers”

Who is online

Users browsing this forum: McLion, wanstreet and 12 guests