Jarrod
Posts: 16
Joined: Sat Sep 02, 2017 5:57 am

Re: Configuring dhcpcd in Raspbian Stretch

Thu Sep 07, 2017 3:14 pm

ShiftPlusOne wrote:
Thu Sep 07, 2017 2:48 pm
Actually, just checked the wpa_supplicant hook for dhcpcd, and it will try to load a wpa_supplicant.conf file named /etc/wpa_supplicant/wpa_supplicant-"$interface".conf first. So, you can configure everything without switching to ifupdown.
Nice. Very useful info to have for this issue, and in general!

SurferTim
Posts: 1769
Joined: Sat Sep 14, 2013 9:27 am
Location: Miramar Beach, Florida

Re: Configuring dhcpcd in Raspbian Stretch

Thu Sep 07, 2017 3:23 pm

You are correct. Stretch does not load anything but wpa_supplicant.conf.

I do not have a second wifi device to check, but I can set network in the wpa_supplicant.conf file, and the AP on wlan0 still boots.

Somebody else will need to test whether wlan1 will connect to the AP in wpa_supplicant.conf.

SurferTim
Posts: 1769
Joined: Sat Sep 14, 2013 9:27 am
Location: Miramar Beach, Florida

Re: Configuring dhcpcd in Raspbian Stretch

Thu Sep 07, 2017 4:48 pm

OK, I lied. I have a usb wifi device that works. Thanks to ShiftPlusOne for the dhcpcd hook tip.

You must name the wpa_supplicant files a specific name or it won't work.
For wlan0 = /etc/wpa_supplicant/wpa_supplicant-wlan0.conf
For wlan1 = /etc/wpa_supplicant/wpa_supplicant-wlan1.conf

There is one caveat. My usb wifi comes up as wlan0 if I boot with it plugged in. The onboard device ends up wlan1.

If I wait until the RPi is booted up, they have the correct device names.

That is as far as I have gotten. I'll test with my dhcpcd.conf and hostapd.conf files changed later.

User avatar
chrisoh
Posts: 217
Joined: Sun Dec 06, 2015 8:50 pm
Location: Essex, UK

Re: Configuring dhcpcd in Raspbian Stretch

Thu Sep 07, 2017 7:09 pm

SurferTim wrote:
Thu Sep 07, 2017 4:48 pm
OK, I lied. I have a usb wifi device that works. Thanks to ShiftPlusOne for the dhcpcd hook tip.

You must name the wpa_supplicant files a specific name or it won't work.
For wlan0 = /etc/wpa_supplicant/wpa_supplicant-wlan0.conf
For wlan1 = /etc/wpa_supplicant/wpa_supplicant-wlan1.conf

There is one caveat. My usb wifi comes up as wlan0 if I boot with it plugged in. The onboard device ends up wlan1.

If I wait until the RPi is booted up, they have the correct device names.

That is as far as I have gotten. I'll test with my dhcpcd.conf and hostapd.conf files changed later.
Just bookmarking this post so can catchup the replies. Am planning on updating two APs over the weekend and this is appears quite an insightful nugget in bidding Jessie farewell.
Raspberry Pi 3 model B Idle @ 250mA
  • HDMI +200mA
  • Minecraft 1.9 Server +100mA
  • 2.4Ghz dongle +20mA

SurferTim
Posts: 1769
Joined: Sat Sep 14, 2013 9:27 am
Location: Miramar Beach, Florida

Re: Configuring dhcpcd in Raspbian Stretch

Thu Sep 07, 2017 9:28 pm

I found the answer. That is why the funny interface names. I removed
net.ifnames=0
from /boot/cmdline.txt, and now all works with both wifi devices,

The onboard wifi shows as wlan0, and the usb wifi device shows as wlx00026f439211.

countxerox
Posts: 17
Joined: Fri Sep 08, 2017 4:06 pm

Re: Configuring dhcpcd in Raspbian Stretch

Fri Sep 08, 2017 5:06 pm

I got my pi zero w access point kind of working by following this post .. so thanks, I was really struggling until I found that. No internet but I don't need that yet anyway.

i set it up headlessly (by copying SSH and wpa_supplicant.conf to the card on a PC). Then I installed hostapd and dnsmasq and copied the conf files from the above post. To run the access point I comment out the network credentials in wpa_supplicant.conf, reboot, then use /usr/sbin/hostapd -B /etc/hostapd/hostapd.conf to start it up.

A few things are still apprehending me ...

When the access point is up and running and I do hostname -I, the IP is different to the static IP defined in dhcpcd.conf? I expected the static IP defined in dhcpcd.conf would be the access point IP?

When I connect the client it's IP isn't any of those defined in dnsmasq.conf? I thought the idea was to define a range of IP's in dnsmasq,conf and the IP issued to the client would be one of them?

If I connect to the access point on the PC and do ipconfig /all, I don't see any details of the access point, default gateway is blank. I was expecting the see the access point IP, where do find the IP of the access point I'm connected to?

It seems to be working so should I try to all fix this before setting a websockets server or carry on anyway?

SurferTim
Posts: 1769
Joined: Sat Sep 14, 2013 9:27 am
Location: Miramar Beach, Florida

Re: Configuring dhcpcd in Raspbian Stretch

Fri Sep 08, 2017 5:28 pm

My hostname is showing the correct IP address. It also issues the correct network settings to the clients.

How do you plan on connecting a ZeroW to the internet?

Maybe you should post the contents of:
/etc/dnsmasq.conf
/etc/dhcpcd.conf
/etc/network/interfaces
/etc/wpa_supplicanr/wpa_supplicant.conf

countxerox
Posts: 17
Joined: Fri Sep 08, 2017 4:06 pm

Re: Configuring dhcpcd in Raspbian Stretch

Fri Sep 08, 2017 6:30 pm

I haven't planned on using the internet, I'm using the AP so I can connect to the pi wirelessly when I'm out of range of my home wifi.

/etc/dnsmasq.conf

Code: Select all

interface=wlan0
domain-needed
bogus-priv
dhcp-range=192.168.4.8,192.168.4.250,12h
/etc/dhcpcd.conf

Code: Select all

# Example static IP configuration:
interface wlan0
static ip_address=192.168.4.1/24
static routers=192.168.4.1
static domain_name_servers=8.8.8.8
/etc/network/interfaces

Code: Select all

# interfaces(5) file used by ifup(8) and ifdown(8)

# Please note that this file is written to be used with dhcpcd
# For static IP, consult /etc/dhcpcd.conf and 'man dhcpcd.conf'

# Include files from /etc/network/interfaces.d:
source-directory /etc/network/interfaces.d
/etc/wpa_supplicant/wpa_supplicant.conf

Code: Select all

country=GB
ctrl_interface=DIR=/var/run/wpa_supplicant GROUP=netdev
update_config=1

#network={
# ssid="?"
# scan_ssid=1
# psk="?"
# key_mgmt=WPA-PSK
#}

Jarrod
Posts: 16
Joined: Sat Sep 02, 2017 5:57 am

Re: Configuring dhcpcd in Raspbian Stretch

Fri Sep 08, 2017 6:59 pm

When the access point is up and running and I do hostname -I, the IP is different to the static IP defined in dhcpcd.conf? I expected the static IP defined in dhcpcd.conf would be the access point IP?
I saw something similar, when I did things in the opposite direction:
1. Boot PiZW into access point mode with wlan0 static ip of 192.168.3.14 defined in dhcpcd.conf.
2. Connect my mac to the AP and connect a VNC client to PiZW via its multicast DNS address <hostname.local>
3. Use the desktop wifi tool to modify wpa_supplicant.conf and connect PiZW to the internet.
4. VNC client disconnects. PiZW is connected to the internet on a 10.0.0.x subnet run by my wifi router.
5. Connect Mac to the 10.0.0.x network, reconnect VNC client to PiZW with its multicast DNS address.
6. ifconfig on PiZW shows wlan0 is still at 192.168.3.14.

I suspect we have uncovered a bug.
Last edited by Jarrod on Sat Sep 09, 2017 12:17 am, edited 1 time in total.

SurferTim
Posts: 1769
Joined: Sat Sep 14, 2013 9:27 am
Location: Miramar Beach, Florida

Re: Configuring dhcpcd in Raspbian Stretch

Fri Sep 08, 2017 7:29 pm

Jarrod wrote:
Fri Sep 08, 2017 6:59 pm
When the access point is up and running and I do hostname -I, the IP is different to the static IP defined in dhcpcd.conf? I expected the static IP defined in dhcpcd.conf would be the access point IP?
I saw something similar, when I did things in the opposite direction:
1. Boot PiZW into access point mode with wlan0 static ip of 192.168.3.14 defined in dhcpcd.conf.
2. Connect my mac to the AP and connect a VNC client to PiZW via its multicast DNS address <hostname.local>
3. Use the desktop wifi tool to modify wpa_supplicant.conf and connect PiZW to the internet.
4. VNC client disconnects. PiZW is connected to the internet on a 10.0.0.x subnet run by my wifi router.
5. Connect Mac to the 10.0.0.x network, reconnect VNC client to PiZW with its multicast DNS address.
5. ifconfig on PiZW shows wlan0 is still at 192.168.3.14.

I suspect we have uncovered a bug.
As soon as you do #3, your AP stops. The clients are disconnected, causing #4.

Jarrod
Posts: 16
Joined: Sat Sep 02, 2017 5:57 am

Re: Configuring dhcpcd in Raspbian Stretch

Fri Sep 08, 2017 7:36 pm

I know that!

#5-#6 is the bug.
Last edited by Jarrod on Sat Sep 09, 2017 12:17 am, edited 1 time in total.

SurferTim
Posts: 1769
Joined: Sat Sep 14, 2013 9:27 am
Location: Miramar Beach, Florida

Re: Configuring dhcpcd in Raspbian Stretch

Fri Sep 08, 2017 7:41 pm

I just tried it. You are correct. The wifi interface connects to the wifi router and maintains the static IP, but I can't navigate anywhere with my browser on the RPi. Why? Because the static settings don't have the correct localnet or gateway to access the internet.

Jarrod
Posts: 16
Joined: Sat Sep 02, 2017 5:57 am

Re: Configuring dhcpcd in Raspbian Stretch

Fri Sep 08, 2017 8:21 pm

Correct. "Connect PiZW to the internet" was a poor choice of words. That's what I was attempting to do when I saw the strange IP issue. But you're right the Pi did not have a gateway or DNS.

It was however accessible on the 10.0.0.255 LAN despite some parts of the OS thinking it was still at 192.168.3.14. That's the weird part I'm trying to convey!

SurferTim
Posts: 1769
Joined: Sat Sep 14, 2013 9:27 am
Location: Miramar Beach, Florida

Re: Configuring dhcpcd in Raspbian Stretch

Fri Sep 08, 2017 8:57 pm

I tried a test with two RPi3s. Both connected to the same wifi, but one was not on the same localnet as the other.

The RPi with the correct localnet reported that it resolved the hostname.local, but the "destination host was unreachable".

I also tried with a bogus hostname.local, and it responded with "could not resolve hostname".

Jarrod
Posts: 16
Joined: Sat Sep 02, 2017 5:57 am

Re: Configuring dhcpcd in Raspbian Stretch

Sat Sep 09, 2017 1:12 am

This is what I see - Mac and Pi connected to same Wifi but dhcpcd on Pi is configured in different network. Mac (10.0.0.146) can resolve Pi.local ip correctly (192.168.3.14) but cannot ping/ssh to Pi. HOWEVER, previously connected VNC session on Mac (originally created when both Mac and Pi were on 192.168.3 network) is working fine with both machines now on different networks. Reproducible and I wouldn't believe it if I weren't looking at it with my own two eyes. Black magic as far as I'm concerned. Reproducible though. After thinking about it more I suppose it doesn't have to be anything to do with the Pi network stack - could just as easily be my router or RealVNC or the Mac. Feels like something has latched on to the hardware ethernet address of the Pi or the Mac and continues communicating even though the network has changed out from under it.

We are way OT now, sorry :-|

boshue
Posts: 2
Joined: Thu Sep 14, 2017 6:49 am

Re: Configuring dhcpcd in Raspbian Stretch

Thu Sep 14, 2017 7:03 am

Raspbian version 2017-09-07

in file /etc/wpa_supplicant/wpa_supplicant.conf

wlan0 does not work if set country=KO <-- wifi region
but setting country=GB works fine!

I solved my problem now!
Is it Bug?

DirkS
Posts: 9847
Joined: Tue Jun 19, 2012 9:46 pm
Location: Essex, UK

Re: Configuring dhcpcd in Raspbian Stretch

Thu Sep 14, 2017 5:16 pm

boshue wrote:
Thu Sep 14, 2017 7:03 am
wlan0 does not work if set country=KO <-- wifi region
but setting country=GB works fine!
AFAICT there is no wifi region 'KO'
Which country are you in? Use the Raspberry Pi config utility (or raspi-config) to set the correct country / region

BTW If you're in South Korea then the code is 'KR'
(it's the standard ISO ALPHA-2 country code; list available at http://www.nationsonline.org/oneworld/c ... e_list.htm )

Oddnoun
Posts: 1
Joined: Wed Sep 20, 2017 1:31 pm

Re: Configuring dhcpcd in Raspbian Stretch

Wed Sep 20, 2017 1:40 pm

SurferTim wrote:
Wed Aug 30, 2017 1:34 pm
I have my RPi3 working as an AP with one caveat. The dnsmasq service will not start on boot.
Edit: Fixed boot problem. See new /etc/dnsmasq.conf below.

DO NOT MODIFY /etc/network/interfaces FILE!

My /etc/dhcpcd.conf addition:

Code: Select all

interface wlan0
static ip_address=192.168.4.1/24
static routers=192.168.4.1
static domain_name_servers=8.8.8.8
My /etc/dnsmasq.conf file

Code: Select all

interface=wlan0
domain-needed
bogus-priv
dhcp-range=192.168.4.8,192.168.4.250,12h
My /etc/hostapd/hostapd.conf file

Code: Select all

interface=wlan0
driver=nl80211
ssid=RPiNet
hw_mode=g
channel=7
wmm_enabled=0
macaddr_acl=0
auth_algs=1
ignore_broadcast_ssid=0
wpa=2
wpa_passphrase=mypassphrase
wpa_key_mgmt=WPA-PSK
wpa_pairwise=TKIP
rsn_pairwise=CCMP
Edit /etc/default/hostapd and change this:

Code: Select all

DAEMON_CONF="/etc/hostapd/hostapd.conf"
The next section is required only if you are wanting to access the internet through the ethernet connection.

Edit /etc/sysctl.conf and uncomment

Code: Select all

net.ipv4.ip_forward=1
My iptables rules. Replace ethX with your ethernet interface name from ifconfig.

Code: Select all

sudo iptables -t nat -A  POSTROUTING -o ethX -j MASQUERADE
sudo iptables -A FORWARD -i ethX -o wlan0 -m state --state RELATED,ESTABLISHED -j ACCEPT
sudo iptables -A FORWARD -i wlan0 -o ethX -j ACCEPT
Edit: Changed masquerade to MASQUERADE.

Using this post I was able to get the AP setup on the Pi Zero W and I am able to SSH and VNC into the device over wireless.

The next step will be to get the other WIFI dongle to connect to whatever network I may need to provide the Pi Zero W with internet access and, ultimate goal if possible, to provide internet access to devices connecting to the Pi Zero W.

I have tried the wpa_supplicant-wlan1.conf but it does not work and I see wlan1:Not associated in the gui.

Any guidance or assistance would be appreciated and if you need screenshots or outputs from files I will be more than happy to provide any and all information.

Thank you for your time and assistance.

Adam

SurferTim
Posts: 1769
Joined: Sat Sep 14, 2013 9:27 am
Location: Miramar Beach, Florida

Re: Configuring dhcpcd in Raspbian Stretch

Wed Sep 20, 2017 8:56 pm

I have the mac based interface names enabled. This is what I use in /etc/wpa_supplicant/wpa_supplicant-wlx00026f439211.conf

Code: Select all

country=US
ctrl_interface=DIR=/var/run/wpa_supplicant GROUP=netdev
update_config=1

network={
	ssid="MySSID"
	psk="MyPassPhrase"
}
To use mac based interface names in Stretch

Code: Select all

sudo mv /etc/systemd/network/99-default.link /home/pi/
reboot

Edit /etc/sysctl.conf and uncomment

Code: Select all

net.ipv4.ip_forward=1
To access the internet through your wlx..., you must masquerade all output. Replace my wlx... with yours from ifconfig.

Code: Select all

sudo iptables -t nat -A  POSTROUTING -o wlx00026f439211 -j MASQUERADE

matthewrowberry
Posts: 1
Joined: Sun Sep 24, 2017 11:29 pm

Re: Configuring dhcpcd in Raspbian Stretch

Mon Sep 25, 2017 1:04 am

I did everything that surfertim said but my wlan0 seems to not be working. when I enter ifconfig it shows up but if I do

Code: Select all

Sudo ifup wlan0
It responds with

Code: Select all

ifup: unknown interface wlan0
Thanks in advance for any help with this issue!

boshue
Posts: 2
Joined: Thu Sep 14, 2017 6:49 am

Re: Configuring dhcpcd in Raspbian Stretch

Mon Sep 25, 2017 1:58 am

DirkS wrote:
Thu Sep 14, 2017 5:16 pm
boshue wrote:
Thu Sep 14, 2017 7:03 am
wlan0 does not work if set country=KO <-- wifi region
but setting country=GB works fine!
AFAICT there is no wifi region 'KO'
Which country are you in? Use the Raspberry Pi config utility (or raspi-config) to set the correct country / region

BTW If you're in South Korea then the code is 'KR'
(it's the standard ISO ALPHA-2 country code; list available at http://www.nationsonline.org/oneworld/c ... e_list.htm )
Sorry it's my mistake.
'KR' is right.

Again if set WiFi region set to 'KR' wifi device on Raspberry Pi3 board does not work.
It is just information. Thanks DirkS!

SurferTim
Posts: 1769
Joined: Sat Sep 14, 2013 9:27 am
Location: Miramar Beach, Florida

Re: Configuring dhcpcd in Raspbian Stretch

Mon Sep 25, 2017 10:21 am

@mathewrowberry: ifup and ifdown no longer work with Stretch.

Code: Select all

sudo ip link set wlan0 up
sudo ip link set wlan0 down

algerino77
Posts: 1
Joined: Sun Oct 29, 2017 5:49 pm

Re: Configuring dhcpcd in Raspbian Stretch

Sun Oct 29, 2017 6:16 pm

Hello everyone, sorry for my english, I will try to do my best !

I set up a Wi-Fi spot on my Raspberry Pi 3 Model B, OS RASPBIAN STRETCH WITH DESKTOP.
and it's work fine ! Thank you for your help !

First :

Code: Select all

sudo apt-get update
sudo apt-get dist-upgrade
sudo rpi-update

Here are my configuration files :


My /etc/dnsmasq.conf

Code: Select all

interface=wlan0
domain-needed
bogus-priv
dhcp-range=192.168.10.101,192.168.10.110,12h

My /etc/dhcpcd.conf

Code: Select all

interface wlan0
static ip_address=192.168.10.2/24

My /etc/network/interfaces

Code: Select all

# interfaces(5) file used by ifup(8) and ifdown(8)

# Please note that this file is written to be used with dhcpcd
# For static IP, consult /etc/dhcpcd.conf and 'man dhcpcd.conf'

# Include files from /etc/network/interfaces.d:
source-directory /etc/network/interfaces.d

My /etc/wpa_supplicant/wpa_supplicant.conf

Code: Select all

country=FR
ctrl_interface=DIR=/var/run/wpa_supplicant GROUP=netdev
update_config=1

My /etc/hostapd/hostapd.conf

Code: Select all

interface=wlan0
driver=nl80211
ssid=Wifi_TEST
hw_mode=g
channel=7
wmm_enabled=0
macaddr_acl=0
auth_algs=1
ignore_broadcast_ssid=0
wpa=2
wpa_passphrase=test
wpa_key_mgmt=WPA-PSK
wpa_pairwise=TKIP
rsn_pairwise=CCMP

My /etc/default/hostapd (Edit line)

Code: Select all

DAEMON_CONF="/etc/hostapd/hostapd.conf"

My /etc/sysctl.conf (Edit line)

Code: Select all

net.ipv4.ip_forward=1

My iptable rules

Code: Select all

sudo iptables -t nat -A  POSTROUTING -o ethX -j MASQUERADE
sudo iptables -A FORWARD -i ethX -o wlan0 -m state --state RELATED,ESTABLISHED -j ACCEPT
sudo iptables -A FORWARD -i wlan0 -o ethX -j ACCEPT

To save iptables rules after a reboot, install this package

Code: Select all

sudo apt-get install iptables-persistent

after you can save current iptables with this command

Code: Select all

sudo service iptables save

To show current iptables, enter this command line

Code: Select all

sudo iptable -L

Thanks again !

antpoli
Posts: 24
Joined: Fri Aug 28, 2015 8:13 am
Location: Pomezia - Italy

Re: Configuring dhcpcd in Raspbian Stretch

Thu Nov 02, 2017 11:16 am

Hi,
following guidelines from SurferTim, I was (ALMOST) able to setup the AP on pi3 running stretch lite.
I have two physical WiFi, one is the integrated one and one is on USB with dual frequency (e.g. 2GHz and 5GHz). First WiFi to connect to home lan or office lan (both will have a lan 192.168.1.x/24), second WiFi to act as Access Point stand-alone (creating a la 10.0.1.x/24).
Resuilt is that pi3 sends out the ssid at 5GHz (as per my settings) but no IP is setted on it and is not able to dhcping to clients.

Below the config files (wlan0 refers to integrated wlan, wlan1 to USB one to act as AP)

/etc/network/interfaces

Code: Select all

source-directory /etc/network/interfaces.d

auto lo
iface lo inet loopback

auto eth0
allow-hotplug eth0
iface eth0 inet manual

auto wlan0
allow-hotplug wlan0
iface wlan0 inet manual
   wpa-conf /etc/wpa_supplicant/wpa_supplicant-wlan0.conf

auto wlan1
allow-hotplug wlan1
iface wlan1 inet manual
#   wpa-conf /etc/wpa_supplicant/wpa_supplicant-wlan1.conf

/etc/wpa_supplicant/wpa_supplicant-wlan0.conf

Code: Select all

country=IT
ctrl_interface=DIR=/var/run/wpa_supplicant GROUP=netdev
update_config=1
network={
	ssid="Office"
	scan_ssid=1
	psk=officepsk
	proto=RSN
	key_mgmt=WPA-PSK
	pairwise=CCMP
	auth_alg=OPEN
        priority=90
}
network={
        ssid="home"
        psk=homepsk
        proto=RSN
        key_mgmt=WPA-PSK
        pairwise=CCMP
        auth_alg=OPEN
        priority=1
}

/etc/dnsmasq.conf

Code: Select all

domain-needed
bogus-priv

server=8.8.8.8

interface=wlan1
listen-address=10.0.1.1

bind-interfaces

dhcp-range=10.0.1.100,10.0.1.200,48h


/etc/dhcpcd.conf

Code: Select all

# Inform the DHCP server of our hostname for DDNS.
hostname

# Persist interface configuration when dhcpcd exits.
persistent

# Rapid commit support.
# Safe to enable by default because it requires the equivalent option set
# on the server to actually work.
option rapid_commit

# A list of options to request from the DHCP server.
option domain_name_servers, domain_name, domain_search, host_name
option classless_static_routes
# Most distributions have NTP support.
option ntp_servers
# Respect the network MTU. This is applied to DHCP routes.
option interface_mtu

# A ServerID is required by RFC2131.
require dhcp_server_identifier

# Generate Stable Private IPv6 Addresses instead of hardware based ones
slaac private

# Uncomment for wlan1 acting as Access Point
denyinterfaces wlan1

# Static IP configuration for eth0 when connected to home lan
interface eth0
static ip_address=192.168.2.100/24
static routers=192.168.2.1
static domain_name_servers=192.168.2.1 8.8.8.8
static domain_search=

# Static IP interface for wlan1 acting as Access Point
interface wlan1
static ip_address=10.0.1.1/24
static routers=10.0.1.1
static domanin_name_servers=10.0.1.1 8.8.8.8
static domain_search=

/etc/defaults/hostapd

Code: Select all

DAEMON_CONF="/etc/hostapd/hostapd.conf"

Any hint/help is welcome.

SurferTim
Posts: 1769
Joined: Sat Sep 14, 2013 9:27 am
Location: Miramar Beach, Florida

Re: Configuring dhcpcd in Raspbian Stretch

Thu Nov 02, 2017 11:33 am

Insure your psk is in double quotes. It won't associate otherwise.

Code: Select all

psk="MyPassphrase"
If you don't use double quotes, you must convert your ssid/passphrase to HEX.
http://jorisvr.nl/wpapsk.html

All I use in /etc/dnsmasq.conf is this.

Code: Select all

interface=wlan1
dhcp-range=10.0.1.100,10.0.1.200,48h
And I put nothing in /etc/network/interfaces.

So you didn't really follow my guidelines.

Return to “Networking and servers”