Tony-d
Posts: 57
Joined: Mon Jun 02, 2014 11:54 pm

word-press help on the pi

Sun Aug 14, 2016 6:54 pm

Hi guys!
I have installed word press as per this lesion, and it seems to be working.

https://www.raspberrypi.org/learning/la ... wordpress/

My problem is that i can not see the web page inside my network, even if i try and access it from the pi's browser. The home page loads after about 3 min, when I try and load the login page it times out. Others outside my network tell me it is displaying OK.
I do have a fixed IP address and and a domain name, Tonyd.org Please note I have put it back to a static HTML page until I can get this worked out. I am new to this so i will probably. over explain this. I can tell you that the problem stated when I changed the database and site ulrs under the general settings tap from the local Ip address to my domain name. I have run three complete builds on three new SD cards. I have tried two computers, Chrome & Firefox. The CPU usage is around 2% I can ping the server with about a 2ms response. I even tried it on a PI 3. The only difference is that the CPU usage was lower! LOL. Anyone? I'm lost on this one.
Last edited by Tony-d on Mon Aug 15, 2016 11:11 pm, edited 1 time in total.

frafrichile
Posts: 42
Joined: Wed Mar 05, 2014 3:11 pm

Re: word-press help on the pi

Sun Aug 14, 2016 8:39 pm

You need to set up a port forwarding on your router.
then you have to set up your domain to go to your public address
check mine out http://73.176.127.164/

I am running into an issue where the template does not load for outsiders.

Tony-d
Posts: 57
Joined: Mon Jun 02, 2014 11:54 pm

Re: word-press help on the pi

Sun Aug 14, 2016 8:55 pm

i'm don't understand that, i have a static ip and the outside world can see www.tonyd.org when i am running html under apache2, it only gets lost when i try and set up word press.
thanks

frafrichile
Posts: 42
Joined: Wed Mar 05, 2014 3:11 pm

Re: word-press help on the pi

Mon Aug 15, 2016 1:09 pm

I can see your website . And the template loads.

Tony-d
Posts: 57
Joined: Mon Jun 02, 2014 11:54 pm

Re: word-press help on the pi

Mon Aug 15, 2016 1:56 pm

I have the page up now but from inside my network
like 3 min and when i try and log in it just times out. i can ping the pi and get a 2 ms reply, the cpu usage on the pi is at about 2%
and i have tried from to pc's and Firefox and chrome.
I am lost

Tony-d
Posts: 57
Joined: Mon Jun 02, 2014 11:54 pm

Re: word-press help on the pi

Mon Aug 15, 2016 2:52 pm

ok, where i am now. the web page displays very slow for me inside my network 4 min load. when i hit the login tab she times out. i have tried two pc's and chrome and Firefox. i also reloaded the system on a new class 10 sd card. as of right now i am running out of ideas. never give up never surrender! Thanks

frafrichile
Posts: 42
Joined: Wed Mar 05, 2014 3:11 pm

Re: word-press help on the pi

Mon Aug 15, 2016 3:04 pm

Tony-d wrote:ok, where i am now. the web page displays very slow for me inside my network 4 min load. when i hit the login tab she times out. i have tried two pc's and chrome and Firefox. i also reloaded the system on a new class 10 sd card. as of right now i am running out of ideas. never give up never surrender! Thanks
Yours is working better than mine.
I can see the theme on your website as well as the wp-admin page.
You should be good to go.

Mine, still having issues :( !

Tony-d
Posts: 57
Joined: Mon Jun 02, 2014 11:54 pm

Re: word-press help on the pi

Mon Aug 15, 2016 5:03 pm

As I said mine is not working from inside my network.
If anyone has a clue where to look please let me know.
thanks

frafrichile
Posts: 42
Joined: Wed Mar 05, 2014 3:11 pm

Re: word-press help on the pi

Mon Aug 15, 2016 6:42 pm

Tony-d wrote:As I said mine is not working from inside my network.
If anyone has a clue where to look please let me know.
thanks
from inside your network it should be easy.
just type your local ip address on your browser. 192.168.0.20
or enable SSH and use Putty to connect to your raspberry pi

Tony-d
Posts: 57
Joined: Mon Jun 02, 2014 11:54 pm

Re: word-press help on the pi

Mon Aug 15, 2016 6:48 pm

i understand that! That is the problem, in fact i get the same problem when i try to access the page from the pi itself.
i can ping the serve with under a 2ms response and the CPU usage is at about 2%

frafrichile
Posts: 42
Joined: Wed Mar 05, 2014 3:11 pm

Re: word-press help on the pi

Mon Aug 15, 2016 8:04 pm

can you attach a screenshot?
Do you have SSH enable on the PI?

Tony-d
Posts: 57
Joined: Mon Jun 02, 2014 11:54 pm

Re: word-press help on the pi

Mon Aug 15, 2016 9:25 pm

What the hell do you want a screen shoot of?
A page time out?
Last edited by Tony-d on Mon Aug 15, 2016 9:27 pm, edited 1 time in total.

Tony-d
Posts: 57
Joined: Mon Jun 02, 2014 11:54 pm

Re: word-press help on the pi

Mon Aug 15, 2016 9:26 pm

Of what a page time out? Why?

frafrichile
Posts: 42
Joined: Wed Mar 05, 2014 3:11 pm

Re: word-press help on the pi

Tue Aug 16, 2016 3:27 am

use the screen recorded app and upload a video to youtube.
I can't understand what you are doing wrong.

Tony-d
Posts: 57
Joined: Mon Jun 02, 2014 11:54 pm

Re: word-press help on the pi

Tue Aug 16, 2016 4:21 am

please stop replying to my post i don't wish to be rude but posting a video of a page time out would be an outstanding wast of time.
I thank you for trying to help but please stop now.

Tony-d
Posts: 57
Joined: Mon Jun 02, 2014 11:54 pm

Re: word-press help on the pi

Tue Aug 16, 2016 5:00 am

I have found and fixed the problem! Any first year nerd should have spotted this in seconds.
I must be getting senile! I had to adjust the DNS lookup on my local router. It was set by the phone Co. to
www.tonyd.org so you can imagine what this did! Son of a gun. Never give up never surrender!
It hit me as I was trying to sleep listing to cost to cost Am.

Return to “Networking and servers”