HamRadio AX.25 packet on RaspBerry


7 posts
by f6bvp » Tue Jul 24, 2012 8:53 pm
I succeeded the compilation of a dedicated Raspbian 3.1.9+ kernel with packet radio modules (6pack, kiss, Rose, NetRom).
I followed instructions given in Debian paragraph of http://elinux.org/RPi_Kernel_Compilation
I then installed a ROSE node switch FPAC on my RPi.
Node will soon be available through ssh.
Compilation took the whole night but it did not hurt as I was sleeping !
Now I will install a co located F6FBB BBS.
At the same time lighttpd is running a web page advertizing RPi at
http://f6bvp.org:8080
I need some help to build a deb package including kernel binary image and AX.25 modules in order to help other hams interested by this project.

73 de Bernard, f6bvp
Posts: 9
Joined: Fri Jun 22, 2012 9:22 pm
by another_mikey » Tue Jul 31, 2012 12:15 am
I am looking to try hosting a DXCluster using the Pi and am very interested in what you might have found out regarding the process for adding many of the modules and recompiling. I will need the Ax25 support for sure - not sure about the ROSE stuff though - I don't think I have any need of that.

Only other concern will be for getting a RS-232 port working. I will likely try a USB to serial adapter as a simple solution and then go towards using one of the dedicated serial ports (with level conversion) if I need to.

Anyway, wanted to post to find out if you were going to make any builds of the kernel available with AX25 installed or if you had any other advice before I embark on trying to rebuild it myself.

is there a way to do it with a cross compiler under Windows & as I am assuming the long duration must have meant you compiled things natively on the Pi itself?

ML/KE0MF
Posts: 3
Joined: Sun Jul 22, 2012 6:18 pm
by g8bpq » Sat Aug 04, 2012 8:11 am
Hi,

The bootc kernels include all the ax.25 modules, so i suggest you use them rather than building your own kernel. There is a build for raspian posted somewhere on the site.

I have a node working, running NETROM over the Ethernet port using the BPQEther driver, and KISS using the serial port. You have to stop the system using the port, both for kernel messages and a getty.

I have just about completed a TNC that will plug into the expansion header. The prototype is a modified TNC-X, but I hope to produce a customised board. The idea is to talk to the PI over i2c, so more than one TNC can be connected (it will have a stackable header)..

73, John G8BPQ
Posts: 2
Joined: Sat Aug 04, 2012 8:03 am
by k4gbb » Fri Sep 14, 2012 6:42 pm
I have set up two Raspberries. Both running FPAC (ROSE) and Net Rom.
Both are supporting a RMS Gate. We are having some trouble setting up the VA site to run with a TNC-X. The FTDI drivers appear to be problematic.

You can find a script to install ax25 on the Raspberrian Wheezy image dated 8/16/2012.
on my Raspberry RMS Gate web sitehtml://k4gbb.no-ip.info/docs/Raspberry.html.

The secret seems to be finding a solid PSU and USB hub.

73
<<Charley>>
k4gbb
The Grass may be greener on the other side of the fence, but it still has to be mowed.
User avatar
Posts: 50
Joined: Sun Aug 12, 2012 5:33 am
Location: Dunnellon, FL USA - EL88tx
by k4gbb » Sun Sep 16, 2012 10:20 pm
Recent modifications of the FTDI driver used the TNC-X have resulted in a stable working environment.
The original FTDI USB driver would nether send or receive. The updated driver from FTDI's web site was installed and the USB port was operational. Our choice of HUBs was unfortunate. There was a problem connecting the TNC thru the USB3 hub. It had an issue regarding communicating to the the RPi the connection of USB2 devices. Therefore the TNC-X was never recognized.

Connecting the TNC directly to the RPI was the only way to make it work. Later, a borrowed HUB was substituted and allowed the TNC to be powered externally.

While this updated USB driver made the Ax.25 port work it made the RPi somewhat unstable. It would run for hours and lock-up. The 8000 interrupts thread http://www.raspberrypi.org/phpBB3/viewtopic.php?p=156720#p156720 shows more work being done on the FTDI USB driver. The work by gsh seems to have solved the problem.

You will find instructions and documentation for installing a TNC-X using the USB interface at http://k4gbb.no-ip.info/docs/Raspberry.html

73
<<Charley>>
k4gbb
The Grass may be greener on the other side of the fence, but it still has to be mowed.
User avatar
Posts: 50
Joined: Sun Aug 12, 2012 5:33 am
Location: Dunnellon, FL USA - EL88tx
by abqden » Sat Apr 18, 2015 12:10 am
I'm trying to learn more about networking and AX25, so I've recently pressed a Raspberry Pi into service and am having a lot of fun getting my education. I've run into a curious thing, though, that has me stumped. To start with, I set up two vhf stations in the same room using 30-year-old legacy tnc's.

I could originate a connection from either tnc with the other and chat back and forth. Then I replaced one of the legacy tnc's with a Raspberry Pi and a "Pi-Tnc" and linux AX25. I can still originate a connection from the other tnc, and the other tnc reports it successfully connected. It gives me a split screen to chat with. But my AX25 machine just sits there at the prompt. I can look at the raw data and see the AX25 machine sends out packets indicating that it also thinks it successfully connected.

At this point I'm just to new to the complexities of AX25 to troubleshoot effectively. Is anyone familiar enough with the Raspberry Pi version of AX25 to know how I get it to open a chat console window? I loaded AX25 on the Raspberry Pi using the handy "Instax25.new" script provided by Charles Schuman (K4GBB), and when I ran into this problem I tried the pre-built image "RPi-3.12.22.AX.25-July-1.img" put together by F6BVP.

When F6BVP's image did the same thing it made me realize I probably have a configuration issue, and I can put all the AX25 images I want on the Rpi and it won't solve the problem because the real problem isn't the software. The real problem is that I don't know what I'm doing!

So to sum up, regardless of which AX25 image I use, I can use the "call" program to make outbound connections, but inbound connections are not displayed even though the Rpi is actively participating in the connection. I have a feeling the solution is a simple matter of matching up the right items in the right configuration files, but right now I haven't a clue.

Dennis ki5ik
Posts: 1
Joined: Sat Apr 18, 2015 12:04 am
by g8bpq » Sat Apr 18, 2015 7:25 am
Dennis,
With the Linux Kernal ax.25 an incoming call has to be routed to an application using ax25d (configured with ax25d.conf). This tells the system what program to run when a call arrives. There are lots of packet applications, but I'n not aware of a simple terminal that can be used for terminal-to-terminal chat.

LinBPQ is an alternative to the Kernal ax.25 stack. It is a fairly complex node package, but I've produced a guide to configure it as a simple packet terminal for the TNC-PI. See

https://sites.google.com/site/bpq32wiki ... s-terminal

for details. Note if you use this, you shouldn't run kissattach or axlisten.

73, John G8BPQ
Posts: 2
Joined: Sat Aug 04, 2012 8:03 am