Barracuda Drive - file server

36 posts   Page 2 of 2   1, 2
by RTL » Fri Jan 25, 2013 2:47 pm
NOTE: BarracudaDrive has changed its name to FuguHub!

BTW, I use xdm on Raspberry Pi and Xming on a PC to remote control my Raspberry Pi. This works much better than VNC.

Check out this tutorial:

You can scroll down to the line where you see "apt-get install xdm" since you already have a working Raspberry Pi. You do not need to install x11-apps.

From my PC, I run Xming as follows:
"C:\Program Files (x86)\Xming\Xming.exe" :1 -query -clipboard -screen 0 1680x1024 is my Raspberry Pi IP address. You need to change this and also the screen size if you have a smaller screen.

You can also use Xming outside your local network by using the MxTunnel:
Last edited by RTL on Sat Jan 07, 2017 8:38 pm, edited 1 time in total.
User avatar
Posts: 30
Joined: Tue Jan 15, 2013 6:05 pm
Location: California
by CarsnGadgets » Fri Jan 25, 2013 3:11 pm
Thank you.
do, or do not, there is no try!
Posts: 25
Joined: Sun Jan 06, 2013 5:34 pm
Location: Dorset UK
by Wonders1991 » Fri Jan 25, 2013 6:56 pm
This is in fact a subject of my recent interest :D

I was planning to post something that asked how to run a script at REBOOT, not on BOOT.

After searching and searching, I got to the etc/init.d/rc.local file. I thought it managed the files that are executed at boot, but I think it manages the files that are executed at "start", "restart", "reload" and "force-reload" because that's what the case...esac sentence decides at the file rc.local.

I tried to change the conditions to start|restart but it didn't work on reboot, still only at boot.

Any help? :)
Posts: 1
Joined: Fri Jan 25, 2013 6:34 pm
by RTL » Fri Jan 25, 2013 8:39 pm
I do not think there is a difference between boot and reboot, but I am not a Linux guru.

You should put a question in the programming section if you need help with the scripts.
User avatar
Posts: 30
Joined: Tue Jan 15, 2013 6:05 pm
Location: California
by CarsnGadgets » Sat Jan 26, 2013 4:54 pm
I have found a way to run the command sudo /etc/init.d/bdd start on log in to the user pi, which solves the problem of bd not loading on reboot for me.

To launch a command automatically on login, put the command into a file named
.bashrc in the user directory (for example /home/pi)

sudo nano .bashrc and add the command sudo /etc/init.d/bdd start to the end of the file and then save and exit the file.

I don't get any errors in the startup log that I can see and can only assume as you say that it may be another service that I have running that is conflicting, but the above seems to get around the problem.

and I found a guide to getting vnc started on boot as well:

Start tightvnc on boot:

There's no point in having VNC if you have to go to the Pi, login and start the server manually. So let's start it on bootup before the login prompt.

Create a new file in the init.d directory:
sudo nano /etc/init.d/tightvncserver

Enter the following details:

# /etc/init.d/tightvncserver
case "$1" in
su $VNCUSER -c '/usr/bin/tightvncserver :1'
echo "Starting TightVNC Server for $VNCUSER "
pkill Xtightvnc
echo "TightVNC Server stopped"
echo "Usage: /etc/init.d/tightvncserver {start|stop}"
exit 1
exit 0

Give the script executable permission:
sudo chmod 755 /etc/init.d/tightvncserver

We can now start or stop the service manually:
sudo /etc/init.d/tightvncserver start
sudo /etc/init.d/tightvncserver stop

But let's make Tight VNC Server start every time the Raspberry Pi starts up:
sudo update-rc.d tightvncserver defaults

Power off the Raspberry Pi.
Make sure it's connected to the network and power back on.
You can now connect across the network using the VNC Viewer!

hopefully this helps some one else :0)
do, or do not, there is no try!
Posts: 25
Joined: Sun Jan 06, 2013 5:34 pm
Location: Dorset UK
by RTL » Wed Jan 30, 2013 10:44 pm
I would focus on finding out the conflict you have that prevents the BD script from starting BD at startup rather than adding the BD startup script to your .bashrc.

Also, let me know how it works out for you using the Raspberry Pi as a NAS. I have heard through the grapevine that the Raspberry Pi has some issues with the USB, but these are just rumors.

Have you heard about the SheevaPlug?

The SheevaPlug, also an ARM device, is similar in speed to the Raspberry Pi and about the same size. The web site is powered by a SheevaPlug. You can see that the site runs BarracudaDrive by attempting to access the file server:

All web pages are generated dynamically by BarracudaDrive and the whole site runs off an 8Gbyte SD card. The SheevaPlug, which hosts multiple domains, has been using the same SD card for 5 years. The SheevaPlug has been fairly solid, although the power supply has failed twice.

Here's some info on the SheevaPlug:
User avatar
Posts: 30
Joined: Tue Jan 15, 2013 6:05 pm
Location: California
by CarsnGadgets » Thu Jan 31, 2013 12:23 pm

Yeah, I have tried to find the conflict but I cannot see any errors in the startup info that shows during boot? I dont know where else to look?

one though that occurred to me was that maybe it was because I installed bd from the Pi store, and not via the other method listed on your website, would that make any difference?

I have tightvnc installed, ssh enabled, wifi enabled and smb, that's about it, so I cant think of anything that would conflict with bd on boot?

This work around isn't ideal, I know, but it does the job, so unless I can find a way to get it working properly I am happy enough with it the way I have it.

I dont have the time at the moment to consider starting again with a fresh raspbian image.

Thank You for your help and advice.
do, or do not, there is no try!
Posts: 25
Joined: Sun Jan 06, 2013 5:34 pm
Location: Dorset UK
by fred-on-the-pi » Thu Oct 31, 2013 8:04 am
may i segest that you do on the sever itself or use this
netdrive is a windows network drive mounter.
had no troble at all trying to accses.
you just need to be root or someone with accses to main folders.
try this one. i given gests the accses to the bit torrents interface.
ip address is
the gest accses is
Posts: 1
Joined: Thu Oct 31, 2013 7:51 am
by Patch » Wed Aug 06, 2014 5:47 am
I also found that bdd was not running after cold start or reboot.

I ran this command update-rc.d bdd defaults and now BarracudaDrive consistently auto starts on boot.
Posts: 1
Joined: Wed Aug 06, 2014 5:38 am
by LocoMJ » Fri Sep 18, 2015 10:50 am
This weekend, I'm going to install barracuda drive on a raspberry pi 2. May the performance be similar to an apache web server in an intel centrino 1.4ghz from 2004? This PC has three webpages based in wordpress+mysql and it's the local file server at home.I would like to replace it to save some money and energy.

RTL, does Barracuda support mysql databases?

Posts: 1
Joined: Fri Sep 18, 2015 10:41 am
Location: Spain
by RTL » Sat Jan 07, 2017 8:36 pm
BarracudaDrive has changed its name to FuguHub!
User avatar
Posts: 30
Joined: Tue Jan 15, 2013 6:05 pm
Location: California