Curtis669
Posts: 2
Joined: Fri Oct 12, 2012 8:27 pm

Re: HowTo - Mumble server

Sun Oct 14, 2012 12:42 am

I've configured booth but how do I connect with superuser through the windows client?

Edit: Ok I finally did it, it's as easy as login typing "superuser" as user and the superuser password.

Sorry for my clumsiness and thanks

Jadez
Posts: 3
Joined: Fri Sep 28, 2012 2:21 am

Re: HowTo - Mumble server

Mon Oct 15, 2012 2:21 am

Can anyone explain how you got mumble-server to run and are you using raspbian or another distro such as Arch?

I have tried to install the server and when running it I get the following error:
/usr/sbin/murmurd: symbol lookup error: /usr/sbin/murmurd: undefined symbol: _ZN 11IceInternal6upCastEPN3Ice12CommunicatorE

I brought this up in another thread and there was mention of a bug that had not been fixed yet. I have tried to remove, update and re-install but always get the same error.

freemanbubu
Posts: 111
Joined: Sun Jun 17, 2012 11:12 am

Re: HowTo - Mumble server

Mon Oct 15, 2012 12:04 pm

hi,

I use Raspbian, and just install via

Code: Select all

apt-get install mumble-server
and

Code: Select all

pdkg-reconfigure mumble-server
I install it 3 times (2 on rapsbian, 1 in fisrt raspi image avalaible), it works each time...

benusch
Posts: 3
Joined: Tue Oct 16, 2012 2:44 pm

Re: HowTo - Mumble server

Tue Oct 16, 2012 2:50 pm

Hi,

i have a problem to connect my windows pc to the raspi mumble server.
I installed the mumble-server, forward the ports on my router and made a certificate on the mumble client but i get the following error:

error:1408F10B:SSL routines:SSL3_GET_RECORD:wrong version number.

The versions of the server and the client match.
I tried install some TSL/SSL packages on the raspi.

Got anyone an idea what i made wrong?

Thank you

freemanbubu
Posts: 111
Joined: Sun Jun 17, 2012 11:12 am

Re: HowTo - Mumble server

Fri Oct 19, 2012 7:55 pm

I just do a fresh install on 09/2012 raspbian image, it works great.

I don't understand your ssl error :(

Piminiuser
Posts: 73
Joined: Wed May 30, 2012 1:15 pm

Re: HowTo - Mumble server

Mon Nov 05, 2012 5:24 pm

Installed and it works well. I am a mumble noob, so i need to figure out how it works :)

benusch
Posts: 3
Joined: Tue Oct 16, 2012 2:44 pm

Re: HowTo - Mumble server

Sat Nov 10, 2012 7:31 pm

SSL problem solved. I installed the new raspian image and it works fine.

PHoSawyer
Posts: 3
Joined: Mon Jul 02, 2012 6:57 am

Re: HowTo - Mumble server

Mon Dec 17, 2012 7:46 pm

so ive got it up and running fine. But i cannot connect through my router remotely. If i use a VPN to get onto my network I can connect through that but not through a port forward. Correct port is being forwarded, am I missing anything?

Obviously want my friends to be able to connect without VPN's

freemanbubu
Posts: 111
Joined: Sun Jun 17, 2012 11:12 am

Re: HowTo - Mumble server

Mon Dec 17, 2012 10:21 pm

You forward both TCP & UDP protocols ?

PHoSawyer
Posts: 3
Joined: Mon Jul 02, 2012 6:57 am

Re: HowTo - Mumble server

Mon Dec 17, 2012 11:37 pm

yeh i did both just in case then i read it uses both

PHoSawyer
Posts: 3
Joined: Mon Jul 02, 2012 6:57 am

Re: HowTo - Mumble server

Wed Dec 19, 2012 8:14 pm

I have noticed that when I can get it to connect that it uses ports other than the one listed, its obviously using high rang dynamic ports which is annoying. Im going to try and activate UPNP on my router to see if that will auto port-forward the correct ports

Dr1zzle
Posts: 2
Joined: Sat Dec 29, 2012 12:58 pm

Re: HowTo - Mumble server

Sat Dec 29, 2012 1:06 pm

Hi,

This post is very interesting as it is the closest thing I could find to my issue. Please excuse me as I am a new user to linux.

I have installed the server application using the commands in the original post and it seemed to complete, but I have not been able to locate the program to run afterwards.

Appologies if this seems a stupid question.

freemanbubu
Posts: 111
Joined: Sun Jun 17, 2012 11:12 am

Re: HowTo - Mumble server

Mon Dec 31, 2012 8:40 am

Hi

to PHoSawyer:
Did you configure your /etc/mumble-server.ini ? you can set the port you want to use.
Don't forget to restart service after any change.

to Dr1zzle
try this command:

Code: Select all

pi@raspberrypi ~ $ ps aux | grep murmur
You should see in output:

Code: Select all

108       2156  0.0  2.2  92128  4220 ?        Sl   Dec20   0:45 /usr/sbin/murmurd -ini /etc/mumble-server.ini
This means your server is running fine.
If not, run this command:

Code: Select all

pi@raspberrypi ~ $ sudo service mumble-server start
then check the server is running with the first command.

You can now connect to your server from another computer with the mumble client...

Dazz
Posts: 2
Joined: Sun Nov 25, 2012 5:22 pm

Re: HowTo - Mumble server

Tue Jan 01, 2013 3:00 pm

Hello all,

Sorry RPI noob.

I have the mumble server running ok, I connect fine with another user who connects from WLAN, we speak but we don't hear anything ?

I have installed the mumble-django ok, how do I connect to it ?

Thanks

freemanbubu
Posts: 111
Joined: Sun Jun 17, 2012 11:12 am

Re: HowTo - Mumble server

Wed Jan 02, 2013 9:46 am

hi,

hearing issues are from your mumble client, not the server.

to connect to mumble-django, you have to configure correctly your web server (website root, access rights, ...)

Dazz
Posts: 2
Joined: Sun Nov 25, 2012 5:22 pm

Re: HowTo - Mumble server

Wed Jan 02, 2013 4:20 pm

Ok thanks for the info, I will take a look.

Lonewolff
Posts: 143
Joined: Fri Dec 28, 2012 11:13 pm

Re: HowTo - Mumble server

Mon Jan 07, 2013 8:59 pm

Am I right that you can't host your own Mumble server (on your own equipment)? The server is hosted by Mumble themselves, elsewhere?
Loving my peice of the Pi

freemanbubu
Posts: 111
Joined: Sun Jun 17, 2012 11:12 am

Re: HowTo - Mumble server

Tue Jan 08, 2013 9:23 am

This topic explain how to configure a mumble server on your own equipement.

You can use public servers or rent one, but you can also configure yours (private or public)

Lonewolff
Posts: 143
Joined: Fri Dec 28, 2012 11:13 pm

Re: HowTo - Mumble server

Tue Jan 08, 2013 9:33 am

All good 8-)

Initially, looking at the Mumble site, it appeared you had to use their own servers. But, I have since found the packages to install the server on your own devices.
Loving my peice of the Pi

Joatmon
Posts: 4
Joined: Sat Jan 26, 2013 2:09 am
Location: UK

Re: HowTo - Mumble server

Sun Jan 27, 2013 10:00 pm

CLATU!...VERATA!...*coughmumble*

Now that I've successfully necro'd this thread, I'd like to ask a question. :D

I've got the mumble server up and running, but users audio keeps cutting out and users not on the LAN tend to lose connection. Is there anything I can do to resolve this?

I've tried lowering the bitrate of the server to 16000, but that didn't help.
If I ping the RPi repeatedly while the server is in use I see 5% packet loss (0% when just one user is logged in talking to himself, the wall or his pet rock).

eyeball114
Posts: 1
Joined: Tue Mar 19, 2013 12:45 am

Re: HowTo - Mumble server

Tue Mar 19, 2013 12:49 am

I've got mumble installed on my rpi. The server ran fine for days empty(hadn't given out the info yet).
3 people logged on and a few minutes later the server crashed. You could log back into the server but it would take signifigently longer to do so. When you did eventually connect the server was empty besides 'Root' at the top. It didn't even show a username. Same results when logging in with super user. I can't seem to find anything on line for a fix. Wondering if anyone here has ran into this.

I am new to linux so would there be a way to remove all mumble software from the rpi through putty and maybe start over?

patmur2010
Posts: 7
Joined: Fri Jul 20, 2012 11:14 pm

Re: HowTo - Mumble server

Fri Aug 15, 2014 9:55 pm

I have successfully built a mumble server on my Rpi (original :D ) but I am unable to connect remotely. Obviously this is the entire point. I have a linksys e-3000 router and have the default mumble port forwarded for "both."

I have charter internet. I can connect perfectly through my home router but I cannot find the server remotely.

What am I missing?

Patmur2010

freemanbubu
Posts: 111
Joined: Sun Jun 17, 2012 11:12 am

Re: HowTo - Mumble server

Mon Aug 18, 2014 12:49 pm

Hi,

You try to connect to mumble remotly from another location (not home) ?

With my ex provider, loopback were not allowed : I try to configure mumble for days and access from my public IP always fail.... when I try from different IP, it works....

Maybe your provider block loopbak requests ....

matthewpipie
Posts: 1
Joined: Mon Aug 18, 2014 8:32 pm

Re: HowTo - Mumble server

Mon Aug 18, 2014 8:35 pm

I need help with it. After I do the thing where the blue-settings thing pops up, or if i try to start the server by other means, it says:
"[warn] Not starting Mumble VoIP Server mumble-server, disabled via /etc/default/mumble-server . . . (warning)."

Please respond quickly, I need a mumble server ASAP!

User avatar
Djinny
Posts: 122
Joined: Sat Jul 05, 2014 12:21 am
Contact: Website

Re: HowTo - Mumble server

Wed Sep 24, 2014 9:22 pm

Using Raspbian, can someone tell me what to do to make a shortcut to start the mumble server and another to stop it?

I want to just have desktop shortcuts for the two, since my Pi was intended for other stuff, not just mumble. Thank you
My RPi needs a fan, heat will leech into the battery, so people saying I don't need a fan, don't understand how Li-Po batteries are affected by high temps. Cool pi = cool battery.
I would very much so like to see a Pi2/Pi3 Zero, power and size.

Return to “Networking and servers”

Who is online

Users browsing this forum: IanS and 11 guests