Pijim
Posts: 4
Joined: Fri Jan 03, 2020 8:46 am

Net Bios vs LLMNR issues?

Thu Jun 17, 2021 2:29 pm

I have just bought a compact router (https://www.tp-link.com/uk/home-network ... l-wr902ac/) for a project I am doing that needs a small wifi network for a Pi4 and a number of Zeros to be able to communicate. I can connect them all to the network, but if I try and use VNC to connect between them it won't let me, nor does it seem that the remote GPIO system works. I can connect to them all from a windows 10 laptop connected to the network which also has VNC installed. I have tried using both hostnames and ip addresses to do the connection. Is it something to do with the fact that the router potentially doesn't support Net-Bios? Is there something I could install on the Pi's to get around this?

drgeoff
Posts: 12064
Joined: Wed Jan 25, 2012 6:39 pm

Re: Net Bios vs LLMNR issues?

Thu Jun 17, 2021 2:38 pm

Can you ping between the RPis?
Quis custodiet ipsos custodes?

User avatar
thagrol
Posts: 5257
Joined: Fri Jan 13, 2012 4:41 pm
Location: Darkest Somerset, UK
Contact: Website

Re: Net Bios vs LLMNR issues?

Thu Jun 17, 2021 3:13 pm

Pijim wrote:
Thu Jun 17, 2021 2:29 pm
I have tried using both hostnames and ip addresses to do the connection. Is it something to do with the fact that the router potentially doesn't support Net-Bios? Is there something I could install on the Pi's to get around this?
Unlikely. Netbios is pretty much a dead protocol these days. Using IP addresses bypasses it anyway.

You describe the device as a router. That implies it has two sides with NAT between them. Which side of the NAT/firewall the respective devices are could be a factor.

Another possibility if some dievices are WiFI and some are wired is a routing issues between wired and WiFi networks.
I'm a volunteer. Take me for granted or abuse my support and I will walk away

All advice given is based on my experience. it worked for me, it may not work for you.
Need help? https://github.com/thagrol/Guides

Pijim
Posts: 4
Joined: Fri Jan 03, 2020 8:46 am

Re: Net Bios vs LLMNR issues?

Fri Jun 18, 2021 5:40 am

Thanks for that, I'll have a go at pinging them and see what happens.

All the pi's are on the same "side" of the router, connected to a wifi network, no cables.

I'd hoped to be able to get them working with hostnames instead of ip addresses as I also end up moving them between two wifi networks. One works with hostnames quite happily, but can't recreate it with the smaller more mobile wifi adapter.

User avatar
thagrol
Posts: 5257
Joined: Fri Jan 13, 2012 4:41 pm
Location: Darkest Somerset, UK
Contact: Website

Re: Net Bios vs LLMNR issues?

Fri Jun 18, 2021 10:55 am

Might be a DNS/DHCP issue.

Have you tried hostname.local?
I'm a volunteer. Take me for granted or abuse my support and I will walk away

All advice given is based on my experience. it worked for me, it may not work for you.
Need help? https://github.com/thagrol/Guides

Return to “Networking and servers”