Darkyere
Posts: 12
Joined: Fri Oct 09, 2015 9:56 am

Need help to make an hostapd AP on an RPI2 Raspbian Stretch

Thu Jul 19, 2018 7:27 pm

Hi all.
I am trying to setup my raspberry pi 2 as a hotspot.

I have tried for a total of a week to get it to work but i dont seem to get it working and i was hoping i could get some help.

I can see my RPI2 AP so it should be up and running one should think but.
My problem is as Android or Linux cant even connect.
As Windows i connect but with wrong ip configuration and no internet.

I use wlan0 as my internet connection and wlan1 as my hostapd Acces-Point

I Use Raspbian stretch and kernel 4.14.52-v7+

I use two Edimax EW-7811-Un dongle's one for wifi and one for Acces-Point

I do not want to use bridge as a way to get it to work.

Running

Code: Select all

iw list | grep AP

tells me both dongles can do AP

Here is what i have tried so far.

Code: Select all

apt-get update

apt-get install hostapd

# Configure hostapd

Code: Select all

nano /etc/default/hostapd

DAEMON_CONF="/etc/hostapd/hostapd.conf"

# The settings in use are

Code: Select all

nano /etc/hostapd/hostapd.conf

interface=wlan1			# the interface used by the AP
hw_mode=g				# g simply means 2.4GHz band
channel=12				# the channel to use
country_code=DK			# the country code
ieee80211n=1			# 802.11n support
wmm_enabled=1			# QoS support

macaddr_acl=0			# Accept all MAC addresses
ignore_broadcast_ssid=0	# Require clients to know the network name

ssid=somename			# the name of the AP
auth_algs=1				# 1=wpa, 2=wep, 3=both
wpa=2					# WPA2 only
wpa_key_mgmt=WPA-PSK  
rsn_pairwise=CCMP
wpa_passphrase=somepassword

# Start and enable hostapd

Code: Select all

systemctl start hostapd

systemctl enable hostapd

# Configure wlan1

Code: Select all

nano /etc/dhcpcd.conf

interface wlan1
static ip_address=192.168.10.1/24
denyinterfaces wlan1

# Install and Configure dnsmasq

Code: Select all

apt-get install dnsmasq

# i have tried setting the settings in

Code: Select all

/etc/dnsmasq.conf

# I have tried these different seetings first

interface=wlan1
dhcp-range=wlan1,192.168.10.10,192.168.10.200,255.255.255.0,2h 
dhcp-option=3,192.168.10.1	# our router 
dhcp-option=6,192.168.10.1	# our DNS Server 
dhcp-authoritative			# force clients to grab a new IP

# Then

interface=wlan1									# Use interface wlan1  
listen-address=192.168.10.1						# Explicitly specify the address to listen on  
bind-interfaces									# Bind to the interface to make sure we aren't sending things elsewhere  
server=192.168.1.1								# Forward DNS requests to my own router
domain-needed									# Don't forward short names  
bogus-priv										# Never forward addresses in the non-routed address spaces.  
dhcp-range=192.168.10.50,192.168.10.150,12h 	# Assign IP addresses

# And at the moment

interface=wlan1
no-dhcp-interface=wlan0
dhcp-range=192.168.10.1,192.168.10.200,255.255.255.0,24h

# I have allso tried with udhcpd
# I ofcouse stopped and disabled dnsmasq
# Then rebooted

Code: Select all

apt-get install udhcpd

nano /etc/udhcpd.conf

start           192.168.10.20   #default: 192.168.0.20
end             192.168.10.254  #default: 192.168.0.254

interface       wlan1           #default: eth0

opt     dns     192.168.1.1
option  subnet  255.255.255.0
opt     router  192.168.10.1
opt     wins    192.168.10.10
option  domain  local
option  lease   864000          # 10 days of seconds

# i have enabled ipv4 forwarding in

Code: Select all

nano /etc/sysctl.conf

# removed the # so it looks like

net.ipv4.ip_forward=1

# I have allso tried different iptables like

Code: Select all

route add -net 192.168.10.0 netmask 255.255.255.0 gw 192.168.1.1
iptables --table nat --append POSTROUTING --out-interface wlan0 -j MASQUERADE
iptables --append FORWARD --in-interface wlan1 -j ACCEPT

# Or

Code: Select all

iptables -t nat -A POSTROUTING -o wlan1 -j MASQUERADE
iptables -A FORWARD -i wlan0 -o wlan1 -m state --state RELATED,ESTABLISHED -j ACCEPT
iptables -A FORWARD -i wlan1 -o wlan0 -j ACCEPT

----

But i dont believe its got anything to do with iptables.
As Android or Linux it wont even connect.

When i connect from Windows (dnsmasq or udhcpd) and run ipconfig i get

Code: Select all

Wireles LAN adapter WI-FI:

	Connection-specific DNS Suffix			:
	link-local IPv6 Address				:	fe00:6c78:23eb:668a:676d%5
	Autoconfiguration IPv4 Address		:	169.254.103.109
	Default Gateway						:

# Which gives me enough info to know that i aint getting the right IP from hostapd/dnsmasq/udhcpd

# So i really cant figure out where the problem is since i have tried both dnsmasq and udhcpd.
# The info i get on the net doesnt seem to relate to my problem.

Hope anyone can help and best regards,
Darkyere

epoch1970
Posts: 2019
Joined: Thu May 05, 2016 9:33 am
Location: Paris, France

Re: Need help to make an hostapd AP on an RPI2 Raspbian Stretch

Thu Jul 19, 2018 8:46 pm

Valiant effort I think, and it looks like you must have come very close to a fully working system at some times.

What would you think of removing your current configs, and apply the official how-to, from the top of the page down to the divider (stop a where where it says bridge).

That would give you what you want. The only thing you'll need to remember when reading the how-to is to replace:
- wlan0 with wlan1 (your AP interface)
- eth0 with wlan0 (your LAN link)

Else debugging your current install is certainly possible, but I feel it would take longer.

In any case:
- Currently your dhcp server doesn't seem to work; I don't know how udhcpd works, but dnsmasq fails to start when you use "bind-interfaces".
- You don't need to add a route in the Pi, it already has all the info it needs: .10.x is via wlan1, everything else is via wlan0.
- You can check that hostapd works by specifying (with windows it will be the easiest I guess) a static IP config in the client. Something like IP: 192.168.10.2, netmask 255.255.255.0, network 192.168.10.0, gateway 192.168.10.1, dns 8.8.8.8 (to keep dnsmasq out of the picture)
If you get to the wifi network, hostapd is ok. If you get to the internet, routing/iptables in the Pi is ok.
"S'il n'y a pas de solution, c'est qu'il n'y a pas de problème." Les Shadoks, J. Rouxel

SurferTim
Posts: 1753
Joined: Sat Sep 14, 2013 9:27 am
Location: Miramar Beach, Florida

Re: Need help to make an hostapd AP on an RPI2 Raspbian Stretch

Fri Jul 20, 2018 11:39 am

I had problems getting hostapd service to run with wlan1 as the AP. I had to use wlan0 for the AP. I used this to change the interface names.
Create file /etc/udev/rules.d/72-static-name.rules

Code: Select all

ACTION=="add", SUBSYSTEM=="net", DRIVERS=="?*",
ATTR{address}=="00:c0:ca:96:d8:8b", KERNEL=="w*",NAME="wlan0"

ACTION=="add", SUBSYSTEM=="net", DRIVERS=="?*",
ATTR{address}=="b8:27:eb:1e:56:52", KERNEL=="w*",NAME="wlan1"
Change the mac addresses to set your AP interface as wlan0.
Reboot.

User avatar
DougieLawson
Posts: 33850
Joined: Sun Jun 16, 2013 11:19 pm
Location: Basingstoke, UK
Contact: Website

Re: Need help to make an hostapd AP on an RPI2 Raspbian Stretch

Fri Jul 20, 2018 2:04 pm

That's the problem that "predictable network names" was trying to solve.

That would build wlx00c0ca96d88b & wlxb827eb1e5652 with no mucking about with udev rules needed. Move a dongle from one RPi to another and the wlx???????? name moves with it.

That allows me to use a single /etc/dhcpcd.conf file on every Raspberry.
Microprocessor, Raspberry Pi & Arduino Hacker
Mainframe database troubleshooter
MQTT Evangelist
Twitter: @DougieLawson

2012-18: 1B*5, 2B*2, B+, A+, Z, ZW, 3Bs*3, 3B+

Any DMs sent on Twitter will be answered next month.

Darkyere
Posts: 12
Joined: Fri Oct 09, 2015 9:56 am

Re: Need help to make an hostapd AP on an RPI2 Raspbian Stretch

Sat Jul 21, 2018 9:34 am

Hi all and Thank you for your responses.
I Wasn't home yesterday so i couldn't test even though i saw the messages on my phone.

I first tried SurferTim to use the official configuration The official how-to answer and it seems like i am getting closer.
It connects windows instantly and gives the right IP address.
But there is no internet and after about 30-60 sec it fallback to giving me

Code: Select all

Wireless LAN adapter WI-FI:

	Connection-specific DNS Suffix			:
	link-local IPv6 Address				:	fe00:6c78:23eb:668a:676d%5
	Autoconfiguration IPv4 Address		:	169.254.103.109
	Default Gateway						:       

I then tried the second answer from SurferTim (Ty you for posting again)

And changed my wlan0 to wlan1 and wlan1 to wlan0.
I ofcurse allso changed the settings in

Code: Select all

nano /etc/dhcpcd.conf
nano /etc/dnsmasq.conf
nano /etc/hostapd/hostapd.conf
mv /etc/wpa_supplicant/wpa_supplicant-wlan0.conf /etc/wpa_supplicant/wpa_supplicant-wlan1.conf

But with the same result i connect to my AP and get the right IP with no internet and 30-60 sec later it falls back to the wrong ip configuration.

I dont know if it's needed but im gonna attach some systemctl status **^** this time

Code: Select all

systemctl status dhcpcd

● dhcpcd.service - dhcpcd on all interfaces
   Loaded: loaded (/lib/systemd/system/dhcpcd.service; enabled; vendor preset: enabled)
   Active: active (running) since Sat 2018-07-21 11:08:04 CEST; 17min ago
  Process: 418 ExecStart=/usr/lib/dhcpcd5/dhcpcd -q -b (code=exited, status=0/SUCCESS)
 Main PID: 435 (dhcpcd)
   CGroup: /system.slice/dhcpcd.service
           ├─435 /sbin/dhcpcd -q -b
           └─600 wpa_supplicant -B -c/etc/wpa_supplicant/wpa_supplicant-wlan1.conf -iwlan1 -Dnl80211,wext

Jul 21 11:08:08 raspberrypi dhcpcd[435]: wlan1: soliciting a DHCP lease
Jul 21 11:08:09 raspberrypi dhcpcd[435]: wlan1: offered 192.168.1.64 from 192.168.1.1
Jul 21 11:08:09 raspberrypi dhcpcd[435]: wlan1: probing address 192.168.1.64/24
Jul 21 11:08:11 raspberrypi dhcpcd[435]: wlan0: using static address 192.168.10.1/24
Jul 21 11:08:11 raspberrypi dhcpcd[435]: wlan0: adding route to 192.168.10.0/24
Jul 21 11:08:14 raspberrypi dhcpcd[435]: wlan1: leased 192.168.1.64 for 86400 seconds
Jul 21 11:08:14 raspberrypi dhcpcd[435]: wlan1: adding route to 192.168.1.0/24
Jul 21 11:08:14 raspberrypi dhcpcd[435]: wlan1: adding default route via 192.168.1.1
Jul 21 11:08:20 raspberrypi dhcpcd[435]: wlan0: no IPv6 Routers available
Jul 21 11:08:20 raspberrypi dhcpcd[435]: wlan1: no IPv6 Routers available

Code: Select all

systemctl status dnsmasq


● dnsmasq.service - dnsmasq - A lightweight DHCP and caching DNS server
   Loaded: loaded (/lib/systemd/system/dnsmasq.service; enabled; vendor preset: enabled)
   Active: active (running) since Sat 2018-07-21 11:08:07 CEST; 18min ago
  Process: 658 ExecStartPost=/etc/init.d/dnsmasq systemd-start-resolvconf (code=exited, status=0/SUCCESS)
  Process: 565 ExecStart=/etc/init.d/dnsmasq systemd-exec (code=exited, status=0/SUCCESS)
  Process: 504 ExecStartPre=/usr/sbin/dnsmasq --test (code=exited, status=0/SUCCESS)
 Main PID: 642 (dnsmasq)
   CGroup: /system.slice/dnsmasq.service
           └─642 /usr/sbin/dnsmasq -x /run/dnsmasq/dnsmasq.pid -u dnsmasq -r /run/dnsmasq/resolv.conf -7 /etc/dnsmasq

Jul 21 11:08:06 raspberrypi dnsmasq[642]: compile time options: IPv6 GNU-getopt DBus i18n IDN DHCP DHCPv6 no-Lua TFTP
Jul 21 11:08:06 raspberrypi dnsmasq[642]: warning: interface wlan0 does not currently exist
Jul 21 11:08:06 raspberrypi dnsmasq-dhcp[642]: DHCP, IP range 192.168.10.2 -- 192.168.10.200, lease time 1d
Jul 21 11:08:06 raspberrypi dnsmasq[642]: read /etc/hosts - 5 addresses
Jul 21 11:08:07 raspberrypi dnsmasq[642]: no servers found in /run/dnsmasq/resolv.conf, will retry
Jul 21 11:08:07 raspberrypi dnsmasq[658]: Too few arguments.
Jul 21 11:08:07 raspberrypi dnsmasq[658]: Too few arguments.
Jul 21 11:08:07 raspberrypi systemd[1]: Started dnsmasq - A lightweight DHCP and caching DNS server.
Jul 21 11:08:14 raspberrypi dnsmasq[642]: reading /run/dnsmasq/resolv.conf
Jul 21 11:08:14 raspberrypi dnsmasq[642]: using nameserver 192.168.1.1#53

Code: Select all

systemctl status hostapd

● hostapd.service - LSB: Advanced IEEE 802.11 management daemon
   Loaded: loaded (/etc/init.d/hostapd; generated; vendor preset: enabled)
   Active: active (running) since Sat 2018-07-21 11:08:07 CEST; 19min ago
     Docs: man:systemd-sysv-generator(8)
  Process: 495 ExecStart=/etc/init.d/hostapd start (code=exited, status=0/SUCCESS)
   CGroup: /system.slice/hostapd.service
           └─702 /usr/sbin/hostapd -B -P /run/hostapd.pid /etc/hostapd/hostapd.conf

Jul 21 11:08:07 raspberrypi hostapd[495]: Starting advanced IEEE 802.11 management: hostapd.
Jul 21 11:08:07 raspberrypi systemd[1]: Started LSB: Advanced IEEE 802.11 management daemon.
Jul 21 11:13:35 raspberrypi hostapd[702]: wlan0: STA 00:22:fa:8d:e8:4c IEEE 802.11: associated
Jul 21 11:13:36 raspberrypi hostapd[702]: wlan0: STA 00:22:fa:8d:e8:4c RADIUS: starting accounting session 5B52F7F7-0
Jul 21 11:13:36 raspberrypi hostapd[702]: wlan0: STA 00:22:fa:8d:e8:4c WPA: pairwise key handshake completed (RSN)
Jul 21 11:13:56 raspberrypi hostapd[702]: wlan0: STA 00:22:fa:8d:e8:4c IEEE 802.11: disassociated
Jul 21 11:15:23 raspberrypi hostapd[702]: wlan0: STA 00:22:fa:8d:e8:4c IEEE 802.11: associated
Jul 21 11:15:23 raspberrypi hostapd[702]: wlan0: STA 00:22:fa:8d:e8:4c RADIUS: starting accounting session 5B52F7F7-0
Jul 21 11:15:23 raspberrypi hostapd[702]: wlan0: STA 00:22:fa:8d:e8:4c WPA: pairwise key handshake completed (RSN)
Jul 21 11:21:20 raspberrypi hostapd[702]: wlan0: STA 00:22:fa:8d:e8:4c WPA: group key handshake completed (RSN)

I hope it can help put some light on the subject.

SurferTim
Posts: 1753
Joined: Sat Sep 14, 2013 9:27 am
Location: Miramar Beach, Florida

Re: Need help to make an hostapd AP on an RPI2 Raspbian Stretch

Sat Jul 21, 2018 12:42 pm

Did you add this to your entry in dhcpcd.conf?

Code: Select all

interface wlan0
    static ip_address=192.168.10.1/24
    nohook wpa_supplicant
Note the new addition of the nohook line.


SurferTim
Posts: 1753
Joined: Sat Sep 14, 2013 9:27 am
Location: Miramar Beach, Florida

Re: Need help to make an hostapd AP on an RPI2 Raspbian Stretch

Sat Jul 21, 2018 1:29 pm

Your post shows hostapd service is working. You have a client

Code: Select all

Jul 21 11:13:35 raspberrypi hostapd[702]: wlan0: STA 00:22:fa:8d:e8:4c IEEE 802.11: associated
I would suspect either your masquerade or dns isn't working. Is your internet access totally unavailable, or just by domain name?

Edit: Check the status of dnsmasq after the client connects. It should show the IP it issued. If not, you have a problem.
Also check ifconfig to insure wlan0 still has the correct IP assignment.

Darkyere
Posts: 12
Joined: Fri Oct 09, 2015 9:56 am

Re: Need help to make an hostapd AP on an RPI2 Raspbian Stretch

Sat Jul 21, 2018 4:47 pm

The internet was totally inaccessible. I tried both Firefox and CMD ping 8.8.8.8

But i didn't know how to set a static IP on windows like u mentioned so i googled it just know.

And after setting

IP address: 192.168.1.8
Subnet mask: 255.255.255.0
Default gateway: 192.168.10.1

Preferred DNS server: 8.8.8.8

I can connect and got an internet connection.

If i set a static IP for Android i can allso connect and get internet there.

Know i need to know how to make these settings in either dnsmasq or dhcpcd since i dont know where such configuration would belong to.

Yet again thank you for the help. It seems like im getting there :D

SurferTim
Posts: 1753
Joined: Sat Sep 14, 2013 9:27 am
Location: Miramar Beach, Florida

Re: Need help to make an hostapd AP on an RPI2 Raspbian Stretch

Sat Jul 21, 2018 5:32 pm

Darkyere wrote:
Sat Jul 21, 2018 4:47 pm
And after setting

IP address: 192.168.1.8
Subnet mask: 255.255.255.0
Default gateway: 192.168.10.1

Preferred DNS server: 8.8.8.8
Those network settings should cause the gateway to be unreachable. The gateway should be in the same localnet as the IP (192.168.1.x).

Darkyere
Posts: 12
Joined: Fri Oct 09, 2015 9:56 am

Re: Need help to make an hostapd AP on an RPI2 Raspbian Stretch

Sat Jul 21, 2018 5:40 pm

Sry mispelled it

And after setting

IP address: 192.168.10.8
Subnet mask: 255.255.255.0
Default gateway: 192.168.10.1

Preferred DNS server: 8.8.8.8

SurferTim
Posts: 1753
Joined: Sat Sep 14, 2013 9:27 am
Location: Miramar Beach, Florida

Re: Need help to make an hostapd AP on an RPI2 Raspbian Stretch

Sat Jul 21, 2018 7:11 pm

That is a good sign. It would appear the dns server (or servers) may be malfunctioning. If you remove the static settings, does the dnsmasq service show a dhcp request?

Code: Select all

sudo service dnsmasq status
It should show a dhcp request on wlan0.

Edit: The reason I used a plural (servers) above is in all my years of troubleshooting networks, I have on occasion found more than one dhcp server on a localnet. The way I find them is disable the dhcp service on the known dhcp server, then request a dhcp renewal on the client. If the client gets a dhcp offer or ack, there is a second server.

Code: Select all

sudo service dnsmasq stop

Darkyere
Posts: 12
Joined: Fri Oct 09, 2015 9:56 am

Re: Need help to make an hostapd AP on an RPI2 Raspbian Stretch

Mon Jul 23, 2018 5:48 pm

It seems like i dont get a DHCP request on dnsmasq

I connected and hostapd accepts the connection this is the output of dnsmasq after that

Code: Select all

 systemctl status dnsmasq
● dnsmasq.service - dnsmasq - A lightweight DHCP and caching DNS server
   Loaded: loaded (/lib/systemd/system/dnsmasq.service; enabled; vendor preset: enabled)
   Active: active (running) since Mon 2018-07-23 03:02:59 CEST; 16h ago
  Process: 644 ExecStartPost=/etc/init.d/dnsmasq systemd-start-resolvconf (code=exited, status=0/SUCCESS)
  Process: 542 ExecStart=/etc/init.d/dnsmasq systemd-exec (code=exited, status=0/SUCCESS)
  Process: 487 ExecStartPre=/usr/sbin/dnsmasq --test (code=exited, status=0/SUCCESS)
 Main PID: 638 (dnsmasq)
   CGroup: /system.slice/dnsmasq.service
           └─638 /usr/sbin/dnsmasq -x /run/dnsmasq/dnsmasq.pid -u dnsmasq -r /run/dnsmasq/resolv.conf -7 /etc/dnsmasq

Jul 23 03:02:58 raspberrypi dnsmasq[638]: compile time options: IPv6 GNU-getopt DBus i18n IDN DHCP DHCPv6 no-Lua TFTP
Jul 23 03:02:58 raspberrypi dnsmasq[638]: warning: interface wlan0 does not currently exist
Jul 23 03:02:58 raspberrypi dnsmasq-dhcp[638]: DHCP, IP range 192.168.10.2 -- 192.168.10.200, lease time 1d
Jul 23 03:02:59 raspberrypi dnsmasq[638]: read /etc/hosts - 5 addresses
Jul 23 03:02:59 raspberrypi dnsmasq[638]: no servers found in /run/dnsmasq/resolv.conf, will retry
Jul 23 03:02:59 raspberrypi dnsmasq[644]: Too few arguments.
Jul 23 03:02:59 raspberrypi dnsmasq[644]: Too few arguments.
Jul 23 03:02:59 raspberrypi systemd[1]: Started dnsmasq - A lightweight DHCP and caching DNS server.
Jul 23 03:03:07 raspberrypi dnsmasq[638]: reading /run/dnsmasq/resolv.conf
Jul 23 03:03:07 raspberrypi dnsmasq[638]: using nameserver 192.168.1.1#53

I then connected without static IP and then tried to connect and it failed.
I thought it was because of

Code: Select all

Jul 23 03:02:58 raspberrypi dnsmasq[638]: warning: interface wlan0 does not currently exist

So i tried

Code: Select all

systemctl restart dnsmasq

Then reconnected without static IP with the same result no DHCP request.

Code: Select all

systemctl status dnsmasq
● dnsmasq.service - dnsmasq - A lightweight DHCP and caching DNS server
   Loaded: loaded (/lib/systemd/system/dnsmasq.service; enabled; vendor preset: enabled)
   Active: active (running) since Mon 2018-07-23 19:31:34 CEST; 2s ago
  Process: 17672 ExecStop=/etc/init.d/dnsmasq systemd-stop-resolvconf (code=exited, status=0/SUCCESS)
  Process: 17734 ExecStartPost=/etc/init.d/dnsmasq systemd-start-resolvconf (code=exited, status=0/SUCCESS)
  Process: 17724 ExecStart=/etc/init.d/dnsmasq systemd-exec (code=exited, status=0/SUCCESS)
  Process: 17722 ExecStartPre=/usr/sbin/dnsmasq --test (code=exited, status=0/SUCCESS)
 Main PID: 17733 (dnsmasq)
   CGroup: /system.slice/dnsmasq.service
           └─17733 /usr/sbin/dnsmasq -x /run/dnsmasq/dnsmasq.pid -u dnsmasq -r /run/dnsmasq/resolv.conf -7 /etc/dnsma

Jul 23 19:31:34 raspberrypi systemd[1]: Starting dnsmasq - A lightweight DHCP and caching DNS server...
Jul 23 19:31:34 raspberrypi dnsmasq[17722]: dnsmasq: syntax check OK.
Jul 23 19:31:34 raspberrypi dnsmasq[17733]: started, version 2.76 cachesize 150
Jul 23 19:31:34 raspberrypi dnsmasq[17733]: compile time options: IPv6 GNU-getopt DBus i18n IDN DHCP DHCPv6 no-Lua TF
Jul 23 19:31:34 raspberrypi dnsmasq-dhcp[17733]: DHCP, IP range 192.168.10.2 -- 192.168.10.200, lease time 1d
Jul 23 19:31:34 raspberrypi dnsmasq[17733]: reading /run/dnsmasq/resolv.conf
Jul 23 19:31:34 raspberrypi dnsmasq[17733]: using nameserver 192.168.1.1#53
Jul 23 19:31:34 raspberrypi dnsmasq[17733]: read /etc/hosts - 5 addresses
Jul 23 19:31:34 raspberrypi dnsmasq[17734]: Too few arguments.
Jul 23 19:31:34 raspberrypi systemd[1]: Started dnsmasq - A lightweight DHCP and caching DNS server.

When i stopped dnsmasq and reconneted i still dont get an internet connection or the right IP but i connect fine to hostapd.

Do you know where to go from here ?

EDIT:
I tried installing hostapd on another PI to se what it pulled in and i got

Code: Select all

The following additional packages will be installed:
  libnl-route-3-200
The following NEW packages will be installed:
  hostapd libnl-route-3-200

Can this have anything to do with it ?

Darkyere
Posts: 12
Joined: Fri Oct 09, 2015 9:56 am

Re: Need help to make an hostapd AP on an RPI2 Raspbian Stretch

Thu Jul 26, 2018 10:39 am

I think i finally figured it out.
The missing link or what wasnt written anywhere else.

The DHCP port wasnt open all i did was running the command

Code: Select all

ufw allow 67

And know i get IP and Internet connection.
Extremly slow but internet nonetheless.

I think my problem is solved thank you for your time SurferTim ill return if it was only a momentarely fix.

Return to “Networking and servers”

Who is online

Users browsing this forum: No registered users and 9 guests