tiptongrange
Posts: 5
Joined: Wed May 23, 2018 2:51 am

PiVPN ignoring DNS servers - how to change

Sun May 27, 2018 12:53 am

I have PiVPN installed on Raspbian Stretch, I'm able to login and connect to it from my laptop, but not able to reach outside websites. I get the following warning messages in the OpenVPN log file. I assume that there is a parameter to set the DNS servers manually that I did not set. How do I change this?


2018-05-26 20:03:17 PUSH: Received control message: 'PUSH_REPLY,dhcp-option DNS 8.8.8.8,dhcp-option DNS 8.8.4.4,block-outside-dns,redirect-gateway def1,route-gateway 10.8.0.1,topology subnet,ping 10,ping-restart 120,ifconfig 10.8.0.2 255.255.255.0,peer-id 1,cipher AES-256-GCM'
2018-05-26 20:03:17 Options error: Unrecognized option or missing or extra parameter(s) in [PUSH-OPTIONS]:3: block-outside-dns (2.4.4)

and

2018-05-26 20:03:17 /Applications/Tunnelblick.app/Contents/Resources/client.up.tunnelblick.sh -9 -d -f -m -w -ptADGNWradsgnw utun1 1500 1553 10.8.0.2 255.255.255.0 init
**********************************************
Start of output from client.up.tunnelblick.sh
Retrieved from OpenVPN: name server(s) [ 8.8.8.8 8.8.4.4 ], search domain(s) [ ] and SMB server(s) [ ] and using default domain name [ openvpn ]
WARNING: Ignoring ServerAddresses '8.8.8.8 8.8.4.4' because ServerAddresses was set manually and '-allowChangesToManuallySetNetworkSettings' was not specified
Setting search domains to 'openvpn' because running under OS X 10.6 or higher and the search domains were not set manually (or are allowed to be changed) and 'Prepend domain name to search domains' was not selected
Saved the DNS and SMB configurations so they can be restored
Did not change DNS ServerAddresses setting of '192.168.1.1 8.8.8.8 8.8.4.4' (but re-set it)
Changed DNS SearchDomains setting from '' to 'openvpn'
Changed DNS DomainName setting from 'home' to 'openvpn'
Did not change SMB NetBIOSName setting of ''
Did not change SMB Workgroup setting of ''
Did not change SMB WINSAddresses setting of ''
DNS servers '192.168.1.1 8.8.8.8 8.8.4.4' were set manually
DNS servers '192.168.1.1 8.8.8.8 8.8.4.4' will be used for DNS queries when the VPN is active

tiptongrange
Posts: 5
Joined: Wed May 23, 2018 2:51 am

Re: PiVPN ignoring DNS servers - how to change

Sun May 27, 2018 1:18 am

Just to update my last post, I have OpenVPN installed on a Netgear router using Gargoyle (a gui for OpenWRT), I got the same error messages but was able to connect to outside websites anyway. Any idea of why this is occurring?

Return to “Networking and servers”

Who is online

Users browsing this forum: Bing [Bot] and 18 guests