valve2000
Posts: 1
Joined: Tue Mar 13, 2018 9:08 pm

OpenMCU v4.8

Tue Mar 13, 2018 10:10 pm

I have tried to install OpenMCU v4.8 on a RPI with Raspbian Stretch (v9) GNU/Linux (29-Nov-17)

apt-get install build-essential flex bison autoconf automake pkg-config libtool -y
apt-get install libsofia-sip-ua-dev libssl-dev -y
apt-get install libavcodec-dev libavformat-dev libav-tools libavutil-dev libswscale-dev -y
apt-get install libfreetype6-dev libjpeg62-turbo libjpeg62-turbo-dev -y
apt-get install libx264-dev libvpx-dev libopus-dev libsamplerate0-dev -y

cd /usr/local/src
wget https://github.com/muggot/openmcu/archive/master.zip -O openmcu.zip
zipinfo openmcu.zip
mkdir /usr/local/openmcu
unzip -j opemncu.zip -d /usr/local/openmcu <A>

cd /usr/local/openmcu
./autogen.sh
./configure
make
make install


Upon running ./autogen.sh, many errors come up, like src/Makefile.in not found and include/Makefile.in not found. When running ./configure, it indicates that libspeex/speex.c is not available. I tried to fix this with:

apt-get install speex libspeex-dev libspeexdsp-dev -y
cd /usr/local/src
wget https://github.com/xiph/speex/archive/master.zip -O libspeex.zip
mkdir /usr/local/openmcu/libspeex
unzip -j libspeex.zip -d /usr/local/openmcu/libspeex


But it still comes up with the message cannot find input file 'src/Makefile.in' With installing speex from source already removed a lot of error messages. Any thoughts?
Thanks, Jeroen

Return to “Networking and servers”

Who is online

Users browsing this forum: No registered users and 4 guests