rubinstu
Posts: 4
Joined: Wed Aug 28, 2013 7:07 pm

OpenVPN AUTH_FAILED

Sun Dec 31, 2017 9:06 pm

I'm trying to get an OpenVPN client running on my Pi 3 w/ Jessie. Whenever I run OvenVPN, I get an "AUTH_FAILED" message. ie.

Code: Select all

[email protected]:/etc/openvpn $ sudo openvpn FreeVPN.me-TCP80.ovpn
Sun Dec 31 15:58:31 2017 OpenVPN 2.3.4 arm-unknown-linux-gnueabihf [SSL (OpenSSL)] [LZO] [EPOLL] [PKCS11] [MH] [IPv6] built on Jun 27 2017
Sun Dec 31 15:58:31 2017 library versions: OpenSSL 1.0.1k 8 Jan 2015, LZO 2.08
Sun Dec 31 15:58:31 2017 Socket Buffers: R=[87380->131072] S=[16384->131072]
Sun Dec 31 15:58:31 2017 Attempting to establish TCP connection with [AF_INET]51.15.151.165:80 [nonblock]
Sun Dec 31 15:58:32 2017 TCP connection established with [AF_INET]51.15.151.165:80
.......
Sun Dec 31 15:58:42 2017 SENT CONTROL [FreeVPN.me]: 'PUSH_REQUEST' (status=1)
Sun Dec 31 15:58:42 2017 AUTH: Received control message: AUTH_FAILED
Sun Dec 31 15:58:42 2017 SIGTERM[soft,auth-failure] received, process exiting
It looks everything is humming along fine until the "AUTH" command.

I've tried different OpenVPN servers with their respective login credentials. I've used both an auth-user-pass file and manually entering the username and password. They ALL give me the same error.

Any ideas? Thanks!

User avatar
DougieLawson
Posts: 33785
Joined: Sun Jun 16, 2013 11:19 pm
Location: Basingstoke, UK
Contact: Website

Re: OpenVPN AUTH_FAILED

Sun Dec 31, 2017 9:19 pm

Do you have the CA cert, user cert and user key as seperate files or are they embedded in your *.ovpn file?

Are you using the right certificate(s) and key for the service at: 51.15.151.165? Are you sure the VPN service is running on port 80 at that Parisian server?

Have you got the latest certificate bundle from https://freevpn.me/FreeVPN.me-OpenVPN-Bundle.zip
Microprocessor, Raspberry Pi & Arduino Hacker
Mainframe database troubleshooter
MQTT Evangelist
Twitter: @DougieLawson

2012-18: 1B*5, 2B*2, B+, A+, Z, ZW, 3Bs*3, 3B+

Any DMs sent on Twitter will be answered next month.

rubinstu
Posts: 4
Joined: Wed Aug 28, 2013 7:07 pm

Re: OpenVPN AUTH_FAILED

Sun Dec 31, 2017 10:03 pm

DougieLawson, thanks for the reply.
Do you have the CA cert, user cert and user key as seperate files or are they embedded in your *.ovpn file?
The CA, cert, and key are embedded in the .ovpn file.
Are you using the right certificate(s) and key for the service at: 51.15.151.165? Are you sure the VPN service is running on port 80 at that Parisian server?
Presumably I am since the certs are embedded in the file. I assume that the server and port combo are good since they're in the file. Still, I have tried other FreeVPNMe and other servers and I get the same error.
Have you got the latest certificate bundle from https://freevpn.me/FreeVPN.me-OpenVPN-Bundle.zip
Yes. I just re-downloaded them with the link you provided and they are the same.

Good questions, but do my answers give any more clues?

All comments welcome. Thanks again!

User avatar
DougieLawson
Posts: 33785
Joined: Sun Jun 16, 2013 11:19 pm
Location: Basingstoke, UK
Contact: Website

Re: OpenVPN AUTH_FAILED

Sun Dec 31, 2017 10:26 pm

You'll need to ask the very nice folks at FreeVPN.me for support.
Microprocessor, Raspberry Pi & Arduino Hacker
Mainframe database troubleshooter
MQTT Evangelist
Twitter: @DougieLawson

2012-18: 1B*5, 2B*2, B+, A+, Z, ZW, 3Bs*3, 3B+

Any DMs sent on Twitter will be answered next month.

rubinstu
Posts: 4
Joined: Wed Aug 28, 2013 7:07 pm

Re: OpenVPN AUTH_FAILED

Wed Jan 03, 2018 5:19 am

Well, maybe they were partying a little too much over New Years. I tried again and things are working fine... Thanks for the help, all.

Return to “Networking and servers”

Who is online

Users browsing this forum: No registered users and 16 guests