heatvent
Posts: 7
Joined: Sun Sep 14, 2014 2:49 pm

Re: SqueezePlug Version 7 available

Sun Sep 14, 2014 2:52 pm

Hi, I have a model B+ and having trouble getting squeezeplug v7 going. I hooked up to a TV as monitor via hdmi and keyboard. Seems to boot fine without errors to the login but: keypresses on the keyboard do nothing, ethernet connection doesn't seem to work, etc. Anything I can do to troubleshoot or get this going? Is there possible an issue with the model B+ Pi?

Thanks for any help.

fuzzweed
Posts: 10
Joined: Sun May 18, 2014 8:27 am

Re: SqueezePlug Version 7 available

Sun Sep 14, 2014 5:51 pm

Great that's got the file edited and the power saving off. Will post back if the original problem is solved.
A note from a noob: When editing /etc/network/interfaces you have to have the wireless profile activated (i.e. you can't log in with a wired connection to make these edits).

castalla
Posts: 558
Joined: Thu Jul 19, 2012 3:46 pm

Re: SqueezePlug Version 7 available

Mon Sep 15, 2014 1:20 pm

heatvent wrote:Hi, I have a model B+ and having trouble getting squeezeplug v7 going. I hooked up to a TV as monitor via hdmi and keyboard. Seems to boot fine without errors to the login but: keypresses on the keyboard do nothing, ethernet connection doesn't seem to work, etc. Anything I can do to troubleshoot or get this going? Is there possible an issue with the model B+ Pi?

Thanks for any help.
Squeezeplug v7 is not compatible unless you replace the /boot files. There are posts here about it - I can't recall the exact link.

EDIT: on your squeezeplug SD card - you need to replace all the files in /boot with the files listed here: https://github.com/raspberrypi/firmware ... aster/boot

fuzzweed
Posts: 10
Joined: Sun May 18, 2014 8:27 am

Re: SqueezePlug Version 7 available

Mon Sep 15, 2014 5:27 pm

fuzzweed wrote:Great that's got the file edited and the power saving off. Will post back if the original problem is solved.
A note from a noob: When editing /etc/network/interfaces you have to have the wireless profile activated (i.e. you can't log in with a wired connection to make these edits).
looks like problem is solved as rpi is still connected after 24 hrs. Maybe worth including power off as a default setting in squeezeplug???

heatvent
Posts: 7
Joined: Sun Sep 14, 2014 2:49 pm

Re: SqueezePlug Version 7 available

Tue Sep 16, 2014 12:22 am

castalla wrote:
heatvent wrote:Hi, I have a model B+ and having trouble getting squeezeplug v7 going. I hooked up to a TV as monitor via hdmi and keyboard. Seems to boot fine without errors to the login but: keypresses on the keyboard do nothing, ethernet connection doesn't seem to work, etc. Anything I can do to troubleshoot or get this going? Is there possible an issue with the model B+ Pi?

Thanks for any help.
Squeezeplug v7 is not compatible unless you replace the /boot files. There are posts here about it - I can't recall the exact link.

EDIT: on your squeezeplug SD card - you need to replace all the files in /boot with the files listed here: https://github.com/raspberrypi/firmware ... aster/boot
I don't see these files in /boot they are in the root directory. Is there something I am missing?

castalla
Posts: 558
Joined: Thu Jul 19, 2012 3:46 pm

Re: SqueezePlug Version 7 available

Tue Sep 16, 2014 8:22 am

heatvent wrote:
castalla wrote:
heatvent wrote:Hi, I have a model B+ and having trouble getting squeezeplug v7 going. I hooked up to a TV as monitor via hdmi and keyboard. Seems to boot fine without errors to the login but: keypresses on the keyboard do nothing, ethernet connection doesn't seem to work, etc. Anything I can do to troubleshoot or get this going? Is there possible an issue with the model B+ Pi?

Thanks for any help.
Squeezeplug v7 is not compatible unless you replace the /boot files. There are posts here about it - I can't recall the exact link.

EDIT: on your squeezeplug SD card - you need to replace all the files in /boot with the files listed here: https://github.com/raspberrypi/firmware ... aster/boot
I don't see these files in /boot they are in the root directory. Is there something I am missing?
As far as I know the replacement /boot files should go into /boot
Last edited by castalla on Fri Sep 19, 2014 11:34 am, edited 1 time in total.

heatvent
Posts: 7
Joined: Sun Sep 14, 2014 2:49 pm

Re: SqueezePlug Version 7 available

Wed Sep 17, 2014 12:44 am

Still doesn't seem to work. I copied all the files over the ones on the SD card and woudln't boot at all. Then I tried deleting all the files on the SD and copying over and wouldn't boot. Finally, tried restoring the sd card back to v7.07 of SP and copied all the files but kernel.img. Booted but have the same issues as before. Any other thoughts?

EDIT: I started over and now seems to work. I deleted all the files on the SD and then copied the firmware files over. Did I do this right or should I have kept the other files as well?

castalla
Posts: 558
Joined: Thu Jul 19, 2012 3:46 pm

Re: SqueezePlug Version 7 available

Wed Sep 17, 2014 1:31 pm

heatvent wrote:Still doesn't seem to work. I copied all the files over the ones on the SD card and woudln't boot at all. Then I tried deleting all the files on the SD and copying over and wouldn't boot. Finally, tried restoring the sd card back to v7.07 of SP and copied all the files but kernel.img. Booted but have the same issues as before. Any other thoughts?

EDIT: I started over and now seems to work. I deleted all the files on the SD and then copied the firmware files over. Did I do this right or should I have kept the other files as well?
No idea - I'll have to search to find the original postings on this.

heatvent
Posts: 7
Joined: Sun Sep 14, 2014 2:49 pm

Re: SqueezePlug Version 7 available

Wed Sep 17, 2014 1:47 pm

So I restarted again and left the files in the root directory and copied over the ones from the website. Most things seem to work although I am having trouble mounting to a windows share for the music and I couldn't get squeezelite to start. After debugging it looked like it couldn't find a sound device. I went back through the SP setup and no audio devices are listed. If I use the command squeezelite -l from cmd line I get:

null - Discard all samples (playback) or generate zero samples (capture)

So I am guessing I have an issue with sound card drives for my second issue. Maybe I will look at the files that I left on the root directory and see if there is anything there that gives any indication of a configuration issue. The only reason I went back to leaving the other files there is I noticed a config.txt file which has the rpi configuration settings in it.

Thanks for the help.

castalla
Posts: 558
Joined: Thu Jul 19, 2012 3:46 pm

Re: SqueezePlug Version 7 available

Thu Sep 18, 2014 1:03 am

I've no help to offer.

Looking at previous threads the files should replace the contents of the /boot directory.

I suggest you start again = create a new SD card with Squeezeplug 7.07. then simply delete the boot files (in windows). Copy the new files into /boot .

Once you get the setup menu - update to the latest Squeezeplug and then do a firmware update.

Beyond that, I'm out of options. Sorry.

heatvent
Posts: 7
Joined: Sun Sep 14, 2014 2:49 pm

Re: SqueezePlug Version 7 available

Thu Sep 18, 2014 1:59 am

Thanks again for the help. I did an apt-get update && apt-get upgrade and that seemed to fix my issues...network share now mounts, squeezelite is running.

Now I am trying to figure out if I can get Pandora working. Strange thing is Vortexbox uses squeezelite and somehow Pandora works fine. When I try on the pi it gives the subscriber error. Totally different issue but what I have now moved on to.

andsger
Posts: 2
Joined: Thu Sep 18, 2014 9:54 pm

Re: SqueezePlug Version 7 available

Thu Sep 18, 2014 10:09 pm

heatvent wrote: by heatvent » Thu Sep 18, 2014 1:59 am

Thanks again for the help. I did an apt-get update && apt-get upgrade and that seemed to fix my issues...network share now mounts, squeezelite is running.
Hi heatvent,
sitting here with my B+ model and having the same problems like you yesterday. I dont understand how you finally fixed it - what is an "apt-get update"? I´m an absolute beginner with raspberry ...
What I did until now:
- latest raspian on sd card -> connection with putty -> update of firmware (3.12.28+) --> worked fine
- squeezplug 7.07 on sd card + copying in the files form GitHub (directly in root directory) --> tried to establish connection with putty --> no response

Am I right that I should expect a login request (root) and a passwort request (nosoup4u) on the black putty screen? Or do i first have to login to the raspberry with login "pi" and pw "raspberry" to get the squeezeplug started???

Any basic information would help ...

castalla
Posts: 558
Joined: Thu Jul 19, 2012 3:46 pm

Re: SqueezePlug Version 7 available

Fri Sep 19, 2014 11:32 am

If your Raspi boots correctly, then you should be able to use PuTTY to login.


Copy the github files to /boot

Login with pi & nosoup4u

Use the squeezeplug setup menu to update, etc.

andsger
Posts: 2
Joined: Thu Sep 18, 2014 9:54 pm

Re: SqueezePlug Version 7 available

Fri Sep 19, 2014 10:21 pm

Hi. Here my experience from tonight:
1. I prepared a new SD Card with the original 7.07 Squeezeplug image. Raspberry connected by lan cable to the router - but it didn´t occure in the list of connected devices in the router
2. I copied over the files from github on the sd card and wrote over the existing files (1st I created an extra "\boot" folder - this didn´t work (same result as under 1.)). Again Rasberry connected by lan cable to the router - but it didn´occure in the list of connected devices agian
3. For testing I took the 2nd SD card with an restored image of rasbian. Rasberry connected to LAN, occured in list of connected devices! the hardware is definetly ok!
4. I copied a l l files on the rasbian SD card (they have the same names as the ones on github, the "copying.linux" file was missing ...) to the Squeezeplug SD card. Already existing files have been overwritten ... Connected to LAN, Rasberry occured as "Squeezeplug" in the list of connected devices in my router!
5. I started Putty and connected to the PI with login PI and password raspberry - worked! The promt in the console was "[email protected] ~ $" --> here I entered "setup" --> the squeezeplug configuration screen opened :)

I hope I get this done now ...

heatvent
Posts: 7
Joined: Sun Sep 14, 2014 2:49 pm

Re: SqueezePlug Version 7 available

Sat Sep 20, 2014 2:42 am

Sorry didn't see the posts. My process was:

1. Create 7.07 SD card.
2. Copy github files copying over the ones with the same name on the SD card but leaving the rest. This at least got the Pi B+ to boot.
3. Used SSH to get to the pi and logged in with pi and nosoup4u.
4. I ran "setup" at the command line and then updated to SP 7.09.
5. I exited to the command line and ran "apt-get update" this updates the repository list of packages.
6. Then at command line rat "apt-get upgrade" this installed 100+ packages.
7. Ran setup at the command line and proceeded to install Samba, LMS and SqueezeLite.

This got me up and running.

B. Marcelis
Posts: 5
Joined: Tue Sep 23, 2014 11:44 am
Location: Netherlands

Re: SqueezePlug Version 7 available

Tue Sep 23, 2014 12:04 pm

Hello squeezeplug fanatics,

My name is Bart and i'm from Holland and a newbie in the Squeezeplug / Raspberry world.

For a couple of weeks i have the Pi B+ model. My goal is to run the pi as a standalone musicplayer with Spotify Premium connected to my Marantz receiver with HDMI.

First i have tried the pimusicbox, but in my opinion ist a little to slow and not very stable. So i tried to run it with a player and server from Squeezeplug. At some point i had it running very wel with LMS installed on my laptop and with the PiCoreplayer 1.17a on the pi. Sound was pretty good en everything is running smoothly. But i don't want LMS running of my laptop, so i tried to instal LMS AND a player on the pi.

TnX to the guide of heatvent, i do run LMS with Squeezelite and is works !!! BUT..... (you feel it coming....)

In no way i was able to get the musicsignal through HDMI. I have no HDMI ouput at all! Only the 3,5 mm headphones jack is working. I have treid to deinstal, instal squeezelite, squeezeslave also doesn't work. If i run the commands aplay-l and squeezelite-l it give me this:
http://www.zelfbouwaudio.nl/forum/downl ... &mode=view

Does anyone here recognize this issue? And second what can i do to make it work.

PS; if i place an SD card with the PiCorePLayer 1.17a and run it with LMS on my computer it works perfect over HDMI.....

castalla
Posts: 558
Joined: Thu Jul 19, 2012 3:46 pm

Re: SqueezePlug Version 7 available

Wed Sep 24, 2014 10:55 am

B. Marcelis wrote:Hello squeezeplug fanatics,

My name is Bart and i'm from Holland and a newbie in the Squeezeplug / Raspberry world.

For a couple of weeks i have the Pi B+ model. My goal is to run the pi as a standalone musicplayer with Spotify Premium connected to my Marantz receiver with HDMI.

First i have tried the pimusicbox, but in my opinion ist a little to slow and not very stable. So i tried to run it with a player and server from Squeezeplug. At some point i had it running very wel with LMS installed on my laptop and with the PiCoreplayer 1.17a on the pi. Sound was pretty good en everything is running smoothly. But i don't want LMS running of my laptop, so i tried to instal LMS AND a player on the pi.

TnX to the guide of heatvent, i do run LMS with Squeezelite and is works !!! BUT..... (you feel it coming....)

In no way i was able to get the musicsignal through HDMI. I have no HDMI ouput at all! Only the 3,5 mm headphones jack is working. I have treid to deinstal, instal squeezelite, squeezeslave also doesn't work. If i run the commands aplay-l and squeezelite-l it give me this:
http://www.zelfbouwaudio.nl/forum/downl ... &mode=view

Does anyone here recognize this issue? And second what can i do to make it work.

PS; if i place an SD card with the PiCorePLayer 1.17a and run it with LMS on my computer it works perfect over HDMI.....
See this: http://www.raspberrypi.org/documentatio ... -config.md

tushma
Posts: 12
Joined: Wed Sep 24, 2014 5:35 am

Re: SqueezePlug Version 7 available

Wed Sep 24, 2014 12:24 pm

Hi to all! So if i understand, Squeezeplug is also server and player (squeezelite and pi player) for raspberry pi (in my case), right? It seems that i menage to install both on Pi, but is there some GUI for control it, or some client for it? Thnx in advance!

heatvent
Posts: 7
Joined: Sun Sep 14, 2014 2:49 pm

Re: SqueezePlug Version 7 available

Wed Sep 24, 2014 1:01 pm

If you go through the menu settings of squeezeplug there is an audio setup option that you can force audio out of HDMI. I am also pretty sure you could take the SD card and put it into your PC and edit the config.txt file which contains all of the Pi settings and there is a setting somewhere that does this as well. I would probably try the squeezeplug setup first:

Select Server_and_Player from main menu
Select Player
Select AudioSettings
Select Select_Sound_Output
Select HDMI

I would think this should work (haven't tried myself).

castalla
Posts: 558
Joined: Thu Jul 19, 2012 3:46 pm

Re: SqueezePlug Version 7 available

Wed Sep 24, 2014 9:36 pm

Good call !

castalla
Posts: 558
Joined: Thu Jul 19, 2012 3:46 pm

Re: SqueezePlug Version 7 available

Wed Sep 24, 2014 9:40 pm

tushma wrote:Hi to all! So if i understand, Squeezeplug is also server and player (squeezelite and pi player) for raspberry pi (in my case), right? It seems that i menage to install both on Pi, but is there some GUI for control it, or some client for it? Thnx in advance!
Squeezeplug is the modified menu system to install various programs. You need to install LMS as the server. Squeezelite is the player. You control squeezelite player via the LMS gui interface, or on Windows you can install Squeezeplay which will let you control the Squeezelite player. there are also a variety of android apps which can control the player.

tushma
Posts: 12
Joined: Wed Sep 24, 2014 5:35 am

Re: SqueezePlug Version 7 available

Thu Sep 25, 2014 5:49 am

Thnx on quick replay. Im trying hard to connect LMS with Popcorn hour c-200 as samba share HDD NAS with 300GB flacs on it. Tried various combinations of suggested naming IP server name, adress, mounpoints, musicshares without any success. My network file path looks like smb://pch-c200/share/Music, ( /run/user/1000/gvfs/smb-share:server=pch-c200,share=share/Music) but when i enter it, simply dont work. Im not so familliar with programing, and so, but i spoted reported error "cant locate adress of pch-c200" or something like that). Did anyone here experienced similar problems, and what would be easiest way to sove it? I would be gratfull on any advice, comment or suggestion! Thnx in advance! Sorry on my bad English!

castalla
Posts: 558
Joined: Thu Jul 19, 2012 3:46 pm

Re: SqueezePlug Version 7 available

Thu Sep 25, 2014 8:57 am

tushma wrote:Thnx on quick replay. Im trying hard to connect LMS with Popcorn hour c-200 as samba share HDD NAS with 300GB flacs on it. Tried various combinations of suggested naming IP server name, adress, mounpoints, musicshares without any success. My network file path looks like smb://pch-c200/share/Music, ( /run/user/1000/gvfs/smb-share:server=pch-c200,share=share/Music) but when i enter it, simply dont work. Im not so familliar with programing, and so, but i spoted reported error "cant locate adress of pch-c200" or something like that). Did anyone here experienced similar problems, and what would be easiest way to sove it? I would be gratfull on any advice, comment or suggestion! Thnx in advance! Sorry on my bad English!
Are you using the setup music library to do this?

You need to know

PCH ip address or network name
PCH user and password
file location - probably /Share (unless you have changed the location

B. Marcelis
Posts: 5
Joined: Tue Sep 23, 2014 11:44 am
Location: Netherlands

Re: SqueezePlug Version 7 available

Thu Sep 25, 2014 9:37 am

heatvent wrote:If you go through the menu settings of squeezeplug there is an audio setup option that you can force audio out of HDMI. I am also pretty sure you could take the SD card and put it into your PC and edit the config.txt file which contains all of the Pi settings and there is a setting somewhere that does this as well. I would probably try the squeezeplug setup first:

Select Server_and_Player from main menu
Select Player
Select AudioSettings
Select Select_Sound_Output
Select HDMI

I would think this should work (haven't tried myself).
Tnx the config.txt was the trick!! I changed the ouput in the config.txt files so it forces to HDMI for audio and now everything works great. TnX for the info and help ;)

RobertoRoberto
Posts: 2
Joined: Sun Sep 21, 2014 10:43 am

Re: SqueezePlug Version 7 available

Thu Sep 25, 2014 1:20 pm

Hi everyone,
I'd like to use my R Pi Model B as squeezebox player (not server).
I installed the latest squeezeplug Version and chose squeezelite as player.
My problem:
How can i access my Squeezebox server on my qnap and connect to it upon start of the pi automatically?
thanks a lot!
Cheers, Roberto

Return to “Media centres”