thebeatproducer
Posts: 5
Joined: Sun Sep 29, 2013 9:56 pm

XBMC sound HDMI on receiver

Sun Sep 29, 2013 10:05 pm

Hello forum!

Last week I bought a AV reciever and a Samsung Smart TV to go with my Raspberry Pi

The models are:

Pioneer VX 422
Samsung UE40F6670

I tried to get sound from the Rpi to the AV receiver, but with no succes. I can however get the sound to the TV through HDMI.

When I use the Command

Code: Select all

 /opt/vc/bin/tvservice -n
It's output is:

Code: Select all

device_name=SAM-SAMSUNG
And the

Code: Select all

 /opt/vc/bin/tvservice -a
gives:

Code: Select all

     PCM supported: Max channels: 8, Max samplerate: 192kHz, Max samplesize 24 bits.
     AC3 supported: Max channels: 6, Max samplerate:  48kHz, Max rate  640 kb/s.
     DTS supported: Max channels: 7, Max samplerate:  96kHz, Max rate 1536 kb/s.
  DTS_HD supported: Max channels: 8, Max samplerate: 192kHz, Max rate    8 kb/s.
The AV receiver is set on HDMI mode: AMP, which should prevent HDMI Passthrough...
Any ideas on how to fix the audio? (not by adding an extra cable from TV to AVR)

Thanks in advance!

Joost

masterluke
Posts: 200
Joined: Tue Apr 17, 2012 4:10 pm

Re: XBMC sound HDMI on receiver

Mon Sep 30, 2013 4:19 pm

Try adding hdmi_force_edid_audio=1 into your config.txt

It might get things working with your amp. You are connecting Pi->Amp->TV right?

thebeatproducer
Posts: 5
Joined: Sun Sep 29, 2013 9:56 pm

Re: XBMC sound HDMI on receiver

Mon Sep 30, 2013 6:48 pm

Yes indeed
Pi > VSX-422 > Samsung TV

But unfortunately the posted solution didn't work..

I believe the soud should be send as folows:

Pi -> Amp -> TV -> Amp
As that is the way my BD player does it. But sending sound back through ARC doesn't work.. Is it possible that ARC sends the sound back to the pi? An how should i check that?

Thanks

thebeatproducer
Posts: 5
Joined: Sun Sep 29, 2013 9:56 pm

Re: XBMC sound HDMI on receiver

Tue Oct 01, 2013 11:32 am

Hello Forum!

I had another look on the Rsapberry wiki, and tried this:
Sound does not work at all, or in some applications

Enter the command 'alsamixer' and use the control to check that the volume is up (arrow keys) and that the output is not muted (M key).

In Debian Squeeze, sound is disabled by default because the ALSA sound driver is still "alpha" (not fully tested) on the R-Pi. To install support for sound, type the following from a command line (from the command prompt before "startx" or in a terminal window)

sudo apt-get update
sudo apt-get upgrade
sudo apt-get install alsa-utils
sudo modprobe snd_bcm2835

On Debian Wheezy, snd_bm2835 is enabled by default, so the 'modprobe' step is not necessary. Next try:

aplay /usr/share/sounds/alsa/Front_Center.wav

By default output will be automatic (hdmi if hdmi supports audio, otherwise analogue). You can force it with:

amixer cset numid=3 <n>

where n is 0=auto, 1=headphones, 2=hdmi.
When executing
aplay /usr/share/sounds/alsa/Front_Center.wav

i can hear sound on my AV reciever!!
So i guess it is a configuration problem in ALSA?
Anyone got ideas on how to solve this?

Joost

dom
Raspberry Pi Engineer & Forum Moderator
Raspberry Pi Engineer & Forum Moderator
Posts: 5417
Joined: Wed Aug 17, 2011 7:41 pm
Location: Cambridge

Re: XBMC sound HDMI on receiver

Tue Oct 01, 2013 11:47 am

thebeatproducer wrote: The AV receiver is set on HDMI mode: AMP, which should prevent HDMI Passthrough...
Any ideas on how to fix the audio? (not by adding an extra cable from TV to AVR)
Have you tried disabling passthrough in settings/system/audio?

thebeatproducer
Posts: 5
Joined: Sun Sep 29, 2013 9:56 pm

Re: XBMC sound HDMI on receiver

Tue Oct 01, 2013 12:54 pm

Hi,

I can't find that option in my XBMC setup..
I have installed XBMC on Raspbian, could this be a problem?

omxplayer on the other hand does not work.. Could this be a problem of the AudioEngine xmbc uses?

Joost

thebeatproducer
Posts: 5
Joined: Sun Sep 29, 2013 9:56 pm

Re: XBMC sound HDMI on receiver

Tue Oct 01, 2013 1:28 pm

Hey all!

I found the solution to my problem! :D

I updated my RaspberryPi firmware using:

Code: Select all

sudo rpi-update
(only possible in Raspbian?)

Apparently that was outdated.
Thanks for all your help!

Joost

Return to “Media centres”