Page 1 of 1

XBMC (Openelec), Airplay and IPv6

Posted: Mon May 13, 2013 5:36 pm
by nommo
Hi all,

I managed to get Airplay working via the latest Openelec, but only intermittently (worked last night but not today) and only on Android and not iDevices (Airplay button not appearing, therefore XBMC not detected as Airplay device). After a bit of googling and forum reading I found a fix.

The trouble seems to be that Openelec (and possibly other RPi XBMC builds?) runs IPv6 as well as IPv4 which causes problems. The solution is to disable IPv6: http://wiki.openelec.tv/index.php?title ... v6_Support

Worked straight away. Hope that's useful to someone searching the forum using keywords!

I wish I knew why Openelec keeps disappearing from my media devices in Windows7 though... the only fix for that is to power cycle the router. Then EVERYTHING appears in 'Network' including SMB shares... :?

Re: XBMC (Openelec), Airplay and IPv6

Posted: Tue May 14, 2013 1:13 pm
by msmithy12
im gonna try this when i get home, this has been the main reason i haven't used my openELEC pi for a few weeks!