mouseclicker
Posts: 16
Joined: Sun Dec 23, 2012 6:35 pm

Bug: xbmc flickers with certain container formats

Sun Jan 27, 2013 12:23 pm

Hi all,

I have a strange issue with some specific files not playing properly on the Pi. Those files are recordings from German public TV stations in H.264 encoding 720p50. After trimming and cleaning those files play properly on the Raspberry PI in the .ts file format. Usually my last step in the processing chain is to convert them to a .mkv container (no re-encoding). Unfortunately this last step results in a heavy flickering on scenes with fast moving elements (e.g. running people). It happens reproducible when I use the gdsmux tool for changing the container but not when I use other converters. The mkv files play fine on many other video players but not on Raspberry PI using XBMC Frodo RC3. They play correctly on the same XBMC release under Windows, so I assume it is a Raspberry Pi specific issue. The same issue appears if I convert to .mp4 format instead of .mkv with gdsmux.

I have uploaded test files:
File not playing correctly (heavy flickering):
http://dl.dropbox.com/u/9790779/test_00 ... laying.mkv

Same file before conversion to .mkv and playing fine:
http://dl.dropbox.com/u/9790779/test_000.ts

Same file playing fine using mkvmerge instead of gdsmux for conversion:
http://dl.dropbox.com/u/9790779/test_000_mkvmerge.mkv

Debug log from XBMC playing the file with issues:
http://dl.dropbox.com/u/9790779/xbmc.log

Unfortunately I have a large collection of those files causing trouble... Perhaps someone can take a look into this issue. I have also created a ticket in XBMC (http://trac.xbmc.org/ticket/14021)

Thanks!

Return to “Media centres”