j.hawes
Posts: 1
Joined: Sun Feb 03, 2019 9:25 pm

Plex can't find movie files on RPI

Sun Feb 03, 2019 9:50 pm

Plex Server Version#: 3.77.4

I have been following the instructions to set up a Plex server on my 3B+ from thepi.io (https://thepi.io/how-to-set-up-a-raspbe ... ex-server/). I have it set up, and connected to the plex.tv/web site, so it a registered server. My media storage is SimpleTech 1TB external USB drive, formatted as NTFS, as per the setup instructions.

On the harddrive is a folder titles Movies, and within that are all my .mp4 movies. From the File Explorer, the OS can see the files, even if it can't play the files. When using ‘file’ to examine the movie files, they are coming up as H264 + AAC MPEG4 files.

The permissions on the external drive are set to world RWX (777) on the mounted drive, as well as all directories and files on the external drive. All of the above is owned by the PI user, as is the management and operation of the Plex server. (I changes the user the server starts under).

Per the instruction, I have all the movies in a single directory on the drive titled “Movies”. In adding the drive to Libraries, I had to add /media/pi/Simpletech1/Movies.

I don't believe it is a permissions issue, as the world readable files should be able to be read my the Plex server application. The application can see the drive, and can see the Media folder, just not the files in the folder.

Well, this one has me baffled. Any thoughts?

User avatar
default_user8
Posts: 644
Joined: Mon Nov 18, 2013 3:11 am

Re: Plex can't find movie files on RPI

Mon Feb 04, 2019 1:04 pm

I have found Plex to be extremely picky about video format. The only format that I've found that it picks up every time without fail is AVI.
Two heads are better than one, unless one's a goat head.

Return to “Media centres”