beastlee
Posts: 2
Joined: Thu Jan 03, 2019 6:52 pm

Help connecting external hard drive to Raspberry Pi 3

Thu Jan 03, 2019 7:14 pm

Hello all. I am rather new to using a Raspberry Pi or even Linux OS. I wanted to set up a Plex server on my Raspberry Pi 3, but when I connect my external hard drive I get this error:
Error mounting /dev/sda2 at /media/pi/Josh'sDrive: Command-line `mount -t "ntfs" -o "uhelper=udisks2,nodev,nosuid,uid=1000,gid=1000" "/dev/sda2" "/media/pi/Josh'sDrive"' exited with non-zero exit status 32: mount: wrong fs type, bad option, bad superblock on /dev/sda2,
missing codepage or helper program, or other error

In some cases useful info is found in syslog - try
dmesg | tail or so.

I have a 5TB Seagate Backup Plus as the hard drive.

I ran

Code: Select all

sudo dmesg
and got the following information:

Code: Select all

[330075.925326] sd 0:0:0:0: [sda] Very big device. Trying to use READ CAPACITY(16).
[330075.925510] sd 0:0:0:0: [sda] 9767541167 512-byte logical blocks: (5.00 TB/4.55 TiB)
[330075.925515] sd 0:0:0:0: [sda] 2048-byte physical blocks
[330075.931908] sd 0:0:0:0: [sda] Write Protect is off
[330075.931914] sd 0:0:0:0: [sda] Mode Sense: 4f 00 00 00
[330075.932239] sd 0:0:0:0: [sda] Write cache: enabled, read cache: enabled, doesn't support DPO or FUA
[330076.034468]  sda: sda1 sda2
[330076.037194] sd 0:0:0:0: [sda] Attached SCSI disk
[330076.763740] ntfs: driver 2.1.32 [Flags: R/W MODULE].
[330076.784922] ntfs: (device sda2): parse_ntfs_boot_sector(): Volume size (4TiB) is too large for this architecture.  Maximum supported is 2TiB.  Sorry.
[330076.784936] ntfs: (device sda2): ntfs_fill_super(): Unsupported NTFS filesystem.
[330134.540386] usb 1-1.2: USB disconnect, device number 9
[330134.553475] sd 0:0:0:0: [sda] Synchronizing SCSI cache
[330134.553749] sd 0:0:0:0: [sda] Synchronize Cache(10) failed: Result: hostbyte=0x01 driverbyte=0x00
[330138.810860] usb 1-1.4: reset full-speed USB device number 5 using dwc_otg
[330139.950801] usb 1-1.5: new high-speed USB device number 10 using dwc_otg
[330140.082398] usb 1-1.5: New USB device found, idVendor=0bc2, idProduct=ab28
[330140.082414] usb 1-1.5: New USB device strings: Mfr=2, Product=3, SerialNumber=1
[330140.082423] usb 1-1.5: Product: BUP BK
[330140.082431] usb 1-1.5: Manufacturer: Seagate
[330140.082439] usb 1-1.5: SerialNumber: NA9SMTBN
[330140.083228] usb-storage 1-1.5:1.0: USB Mass Storage device detected
[330140.086544] scsi host0: usb-storage 1-1.5:1.0
[330141.121604] scsi 0:0:0:0: Direct-Access     Seagate  BUP BK           0304 PQ: 0 ANSI: 6
So it appears that the hard drive is too big for my Raspberry Pi 3. Is there a way to get around this or do I just need to get a smaller hard drive? Thanks!

epoch1970
Posts: 2772
Joined: Thu May 05, 2016 9:33 am
Location: Paris, France

Re: Help connecting external hard drive to Raspberry Pi 3

Sat Jan 05, 2019 12:24 pm

Try with ntfs-3g?
viewtopic.php?f=28&t=206805
"S'il n'y a pas de solution, c'est qu'il n'y a pas de problème." Les Shadoks, J. Rouxel

beastlee
Posts: 2
Joined: Thu Jan 03, 2019 6:52 pm

Re: Help connecting external hard drive to Raspberry Pi 3

Mon Jan 07, 2019 12:05 am

That worked! Thanks!

Return to “Media centres”