jonshouse
Posts: 41
Joined: Sat Aug 11, 2012 7:10 pm

Firmware

Thu Nov 01, 2012 10:17 pm

The latest firmware update for 512mb support seems to break the correct playback of Hi-def H264 Mpeg/TS streams. This used to work with no problems ?

This clip played perfectly before the upgrade.

http://www.youtube.com/watch?v=JvZwCD3PGxM

User avatar
Dweeber
Posts: 606
Joined: Fri Aug 17, 2012 3:35 am
Location: Mesa, AZ
Contact: Website

Re: Firmware

Thu Nov 01, 2012 10:33 pm

What is the source of the video you are playing?
Dweeber A.K.A. Kevin...
My RPI Info Pages including Current Setup - http://rpi.tnet.com

jonshouse
Posts: 41
Joined: Sat Aug 11, 2012 7:10 pm

Re: Firmware

Thu Nov 01, 2012 10:48 pm

Before upgrade it was package
omxplayer_0.2.3~git20121013~fb1b02d8_armhf.deb

after upgrade I tried all these versions:

-rw-r--r-- 1 root root 5207774 Oct 31 03:55 omxplayer_0.2.1~git20120930~ff1a44ee_armhf.deb
-rw-r--r-- 1 root root 5207800 Oct 31 03:53 omxplayer_0.2.2~git20121011~ff1a44ee_armhf.deb
-rw-r--r-- 1 root root 5208028 Oct 13 20:29 omxplayer_0.2.3~git20121013~fb1b02d8_armhf.deb
-rw-r--r-- 1 root root 5208140 Oct 26 00:34 omxplayer_0.2.3~git20121023~8f6692d8_armhf.deb

All on Raspian.

The clip did play correctly pre firmware upgrade, now it does not.

Also xbmc on a different Pi board now fails to play these files, again it did play they pre firmware upgrade.

Sample of the video, sorry about the slow server.
http://www.jonshouse.co.uk/download/h26 ... _sample.ts

jonshouse
Posts: 41
Joined: Sat Aug 11, 2012 7:10 pm

Re: Firmware

Thu Nov 01, 2012 11:01 pm

Dweeber wrote:What is the source of the video you are playing?
Raw file capture of BBC HD from DVBS2 sat card.


jonshouse
Posts: 41
Joined: Sat Aug 11, 2012 7:10 pm

Re: Firmware

Fri Nov 02, 2012 12:16 am

Sounds similar, especially the stutter. Thanks.

MartenR
Posts: 46
Joined: Sat Mar 03, 2012 9:15 am

Re: Firmware

Sun Nov 04, 2012 3:30 pm

I am experiencing the same problem here. Also several DVB h264 ts streams at 1080i are affect the whole playback is stuttering or freezing.
I have test it with omxplayer and with vompclient, which I am currently porting.
I will try to contact the developer.

Marten

Return to “Media centres”

Who is online

Users browsing this forum: No registered users and 6 guests