Page 1 of 1

a2dp stuttering workaround, but not a solution

Posted: Wed Jul 11, 2018 7:28 am
by Azimoth

I want to stream audio from my phone and other devices to my RPi 3 B (the "old" version, not B+) using bluetooth.
To achieve this, I followed (more or less) this tutorial:

So far it works, BUT:
As I experienced some stuttering I further investigated and found out that many people seem to have the same problem and turning off wifi seems to be the solution preferred by most. But this is not an option for me.

I noticed that stuttering only occurs when I'm initiating the bluetooth connection from my phone, but not when I initiate it via bluetoothctl.


- Activate bluetooth on phone, tap my RPi (on the phone) to connect to it ---> stuttering audio

- Start bluetoothctl, connect <myPhonesMAC> ---> flawless audio (even after exiting bluetoothctl) with activated wifi

Does anyone have an explanation for this? Where's the difference between both ways?
And since it (apparently) CAN work just fine, how do I have to reconfigure bluetooth in a way that both ways of connecting work fine?

Re: a2dp stuttering workaround, but not a solution

Posted: Wed Jul 11, 2018 7:26 pm
by oss001
I think this is a known issue. Something to do with the hardware radio's when using bluetooth and Wifi at the same time. Luckily for me I had an old bluetooth dongle laying around so I disabled the onboard bluetooth and just use the usb dongle with the onboard wifi and that works perfectly.

I believe this has issue been addressed in the new 3B+. I am not sure why you are able to get the flawless audio when using bluetoothctl, I never had the audio work properly on my setup...

Re: a2dp stuttering workaround, but not a solution

Posted: Thu Jul 12, 2018 11:24 am
by Azimoth
For some reason it seems that bluetoothctl way only works as along as at least the ssh session I used to initiate the connection is kept alive. Quitting bluetoothctl has no impact on the audio, it remains stutter-free, but once I close the session stuttering comes back on...