TheD6Bel
Posts: 67
Joined: Tue Sep 11, 2012 11:18 am

Re: SqueezePlug Version 5 ready for download

Thu Nov 15, 2012 7:21 pm

truehl wrote: synstax should be: (change needed to your special setup)
./squeezeslave -o0 -m00:00:00:00:00:01 192.168.2.105 &
./squeezeslave -o1 -m00:00:00:00:00:02 192.168.2.105 &
./squeezeslave -o2 -m00:00:00:00:00:03 192.168.2.105 &
./squeezeslave -o3 -m00:00:00:00:00:04 192.168.2.105 &

I tested with 4 soundcards. One internal, one directly connected to the RPi, 2 connected with a usb-hub. One and two run fine, the usb-hub connected played awful sound! I have not investigated any deeper, cause I think this setup is a kind of strange! :lol: :lol: :lol:
thank you again for your help!!

Your sound cards are the same, in the rpi and in HUB?
I wanted to connect 4 USB sound cards on a HUB for connect on RPI
in the worst case, I buy two RPi and launches two slaves by RPi

Is it possible to run commands automatically at each boot, or do I need to create a script to do it?

User avatar
truehl
Posts: 642
Joined: Sun Mar 04, 2012 6:47 pm
Contact: Website

Re: SqueezePlug Version 5 ready for download

Thu Nov 15, 2012 7:33 pm

TheD6Bel wrote:
truehl wrote: synstax should be: (change needed to your special setup)
./squeezeslave -o0 -m00:00:00:00:00:01 192.168.2.105 &
./squeezeslave -o1 -m00:00:00:00:00:02 192.168.2.105 &
./squeezeslave -o2 -m00:00:00:00:00:03 192.168.2.105 &
./squeezeslave -o3 -m00:00:00:00:00:04 192.168.2.105 &

I tested with 4 soundcards. One internal, one directly connected to the RPi, 2 connected with a usb-hub. One and two run fine, the usb-hub connected played awful sound! I have not investigated any deeper, cause I think this setup is a kind of strange! :lol: :lol: :lol:
thank you again for your help!!

Your sound cards are the same, in the rpi and in HUB?
I wanted to connect 4 USB sound cards on a HUB for connect on RPI
in the worst case, I buy two RPi and launches two slaves by RPi

Is it possible to run commands automatically at each boot, or do I need to create a script to do it?
Sound cards are the same, yes.

You can place my code in a script, customize it and make the script executable with "chmod 777 myscript.sh". Save it e.g. in /sp/scripts. Edit /etc/rc.local before "exit 0" place "/sp/scripts/myscript.sh"
truehl
http://www.squeezeplug.de

TheD6Bel
Posts: 67
Joined: Tue Sep 11, 2012 11:18 am

Re: SqueezePlug Version 5 ready for download

Thu Nov 15, 2012 7:54 pm

truehl wrote:Sound cards are the same, yes.

You can place my code in a script, customize it and make the script executable with "chmod 777 myscript.sh". Save it e.g. in /sp/scripts. Edit /etc/rc.local before "exit 0" place "/sp/scripts/myscript.sh"
damage to the sound card, I'll try

and thank you for the script! I will be ordering two sound cards to start and if it works I would take two more

kaijoe
Posts: 8
Joined: Wed Nov 14, 2012 8:38 pm

Re: SqueezePlug Version 5 ready for download

Fri Nov 16, 2012 10:14 pm

Hi Thomas,

I did what you mentioned yesterday, but the scripts are not available. Any further ideas?

Kai

hestbank
Posts: 7
Joined: Fri Nov 16, 2012 10:48 pm

Re: SqueezePlug Version 5 ready for download

Fri Nov 16, 2012 10:56 pm

Hi Thomas,

I have tried updating my version 4 Squeezeplug (Raspberry Pi) but I get a "no patch available" error message. Do I have to reburn an SD card with the new version 5 image? (I have tried that but the current Squeezeplug card, 8GB, says that it has only 76MB free and won't allow me to Format it back to 8GB)

Thanks for the great work.

User avatar
truehl
Posts: 642
Joined: Sun Mar 04, 2012 6:47 pm
Contact: Website

Re: SqueezePlug Version 5 ready for download

Sat Nov 17, 2012 8:14 am

hestbank wrote:Hi Thomas,

I have tried updating my version 4 Squeezeplug (Raspberry Pi) but I get a "no patch available" error message. Do I have to reburn an SD card with the new version 5 image? (I have tried that but the current Squeezeplug card, 8GB, says that it has only 76MB free and won't allow me to Format it back to 8GB)

Thanks for the great work.
There is no update path from 4 to 5. Try to format the SD with this tool:
https://www.sdcard.org/downloads/formatter_3/ . Burn the new image and first thing you should do then is to update SqueezePlug and then to expand the file system.
truehl
http://www.squeezeplug.de

drgeoff
Posts: 9804
Joined: Wed Jan 25, 2012 6:39 pm

Re: SqueezePlug Version 5 ready for download

Sat Nov 17, 2012 11:08 am

hestbank wrote: (I have tried that but the current Squeezeplug card, 8GB, says that it has only 76MB free and won't allow me to Format it back to 8GB)
Some methods of writing the image (eg the command line 'sudo dd bs=1M if=/path/os.img of=/dev/sdx; sudo sync' type in Linux) do not require the card to be reformatted. If your writing tool does require it, see http://www.raspberrypi.org/phpBB3/viewt ... 20#p164620 for a couple of options.

User avatar
truehl
Posts: 642
Joined: Sun Mar 04, 2012 6:47 pm
Contact: Website

Re: SqueezePlug Version 5 ready for download

Sat Nov 17, 2012 1:37 pm

Hi all,
I've checked the 5.05 patch multiple times now and can't finds an error. After an 5.05 update the installation of LMS works fine for me and all the other scripts are working fine, as far as I could see.

So I think everything should work now, if not please tell me and I'll take a deeper look.

I made an other decision I like to let you know and I like to get your feedback! I like to reduce the complexity of SqueezePlug so I think I'll drop all SqueezePlug versions except the version for Raspberry Pi. I think Raspberry Pi is the best platform for SqueezePlug ever and we don't need versions for other device. So versions for SheevaPlug, Dockstar and GoFlex Net will be be discontinued.

There are some reasons for a Debian SoftFloat version, so I think it would be a good plan to provide 2 versions, one HardFloat and one SoftFloat.

What do you think?
truehl
http://www.squeezeplug.de

hestbank
Posts: 7
Joined: Fri Nov 16, 2012 10:48 pm

Re: SqueezePlug Version 5 ready for download

Sat Nov 17, 2012 4:20 pm

truehl wrote: There is no update path from 4 to 5. Try to format the SD with this tool:
https://www.sdcard.org/downloads/formatter_3/ . Burn the new image and first thing you should do then is to update SqueezePlug and then to expand the file system.
Thanks Thomas,

I think I will get hold of another SD card for version 5 and get that working before I re-use the version 4 card. Is there an optimum size?

Once again thanks for all your hard work with SqueezePlug.

User avatar
truehl
Posts: 642
Joined: Sun Mar 04, 2012 6:47 pm
Contact: Website

Re: SqueezePlug Version 5 ready for download

Sat Nov 17, 2012 4:35 pm

hestbank wrote:
truehl wrote: There is no update path from 4 to 5. Try to format the SD with this tool:
https://www.sdcard.org/downloads/formatter_3/ . Burn the new image and first thing you should do then is to update SqueezePlug and then to expand the file system.
Thanks Thomas,

I think I will get hold of another SD card for version 5 and get that working before I re-use the version 4 card. Is there an optimum size?

Once again thanks for all your hard work with SqueezePlug.
It depends ... I like 4 GB class 10 cards most. That's enough by far for the system but if you like to save music directly on the card, there is not much space left! I prefer to store the music on an extra HD, attached to the RPi!
truehl
http://www.squeezeplug.de

castalla
Posts: 558
Joined: Thu Jul 19, 2012 3:46 pm

Re: SqueezePlug Version 5 ready for download

Sat Nov 17, 2012 7:10 pm

truehl wrote:Hi all,
I've checked the 5.05 patch multiple times now and can't finds an error. After an 5.05 update the installation of LMS works fine for me and all the other scripts are working fine, as far as I could see.

So I think everything should work now, if not please tell me and I'll take a deeper look.

I made an other decision I like to let you know and I like to get your feedback! I like to reduce the complexity of SqueezePlug so I think I'll drop all SqueezePlug versions except the version for Raspberry Pi. I think Raspberry Pi is the best platform for SqueezePlug ever and we don't need versions for other device. So versions for SheevaPlug, Dockstar and GoFlex Net will be be discontinued.

There are some reasons for a Debian SoftFloat version, so I think it would be a good plan to provide 2 versions, one HardFloat and one SoftFloat.

What do you think?
Good idea.

kaijoe
Posts: 8
Joined: Wed Nov 14, 2012 8:38 pm

Re: SqueezePlug Version 5 ready for download

Sat Nov 17, 2012 8:39 pm

Hi Thomas,

I got the scripts for libs.sh and memory split.
After update from 500 to 505 I get the error message Logitech Media Server died. Restarting.
Debian ist update to date and Squeezeplug too.

Kai

kaijoe
Posts: 8
Joined: Wed Nov 14, 2012 8:38 pm

Re: SqueezePlug Version 5 ready for download

Sat Nov 17, 2012 10:51 pm

Hi again,

I always get the same error, that the server died and is restarting. I did a lot of things, nothing
worked.
I tried to start the squeezeboxserver in debug mode with the command squeezeboxserver --d_startup. When I did this I got several errors the squeezeboxserver could not load some modules. Enclosed the modules that could not be loaded:

The following modules failed to load: DBI EV XML::Parser::Expat HTML::Parser JSON::XS Digest::SHA1 YAML::XS Sub::Name

Does someone has an idea what's going wrong?

Kai

User avatar
truehl
Posts: 642
Joined: Sun Mar 04, 2012 6:47 pm
Contact: Website

Re: SqueezePlug Version 5 ready for download

Sat Nov 17, 2012 11:37 pm

kaijoe wrote:Hi again,

I always get the same error, that the server died and is restarting. I did a lot of things, nothing
worked.
I tried to start the squeezeboxserver in debug mode with the command squeezeboxserver --d_startup. When I did this I got several errors the squeezeboxserver could not load some modules. Enclosed the modules that could not be loaded:

The following modules failed to load: DBI EV XML::Parser::Expat HTML::Parser JSON::XS Digest::SHA1 YAML::XS Sub::Name

Does someone has an idea what's going wrong?

Kai
Hi Kai,
I thought LMS was working for you and you only have the missing script problem, so I'm wrong. I really don't know what's going on with your setup. I checked it several times and the LMS installation works perfect.

Did you try from scratch? Be sure you get a dialog at the first start an choose "Raspberry Pi". Then update from 5.00 to 5.05. Then install LMS. If this does not work, we should meet on Skype for further investigation.
truehl
http://www.squeezeplug.de

kaijoe
Posts: 8
Joined: Wed Nov 14, 2012 8:38 pm

Re: SqueezePlug Version 5 ready for download

Sun Nov 18, 2012 12:48 am

Hi Thomas,

I got. I found a link to a homepage where someone had the same problem.
He told that the version of the CPAN modules are the problem and they have to be
recompiled in a newer version. He created a new deb package with the new CPAN modules
and this works. So now I have all the scripts and a running Logitechserver but nevertheless we can Skype.

Kai

User avatar
truehl
Posts: 642
Joined: Sun Mar 04, 2012 6:47 pm
Contact: Website

Re: SqueezePlug Version 5 ready for download

Sun Nov 18, 2012 8:42 am

kaijoe wrote:Hi Thomas,

I got. I found a link to a homepage where someone had the same problem.
He told that the version of the CPAN modules are the problem and they have to be
recompiled in a newer version. He created a new deb package with the new CPAN modules
and this works. So now I have all the scripts and a running Logitechserver but nevertheless we can Skype.

Kai
Hi Kai,
yes, the CPAN modules are the problem, that's a long know issue with the Hard Float version. For that reason I've integrated a patch for the CPAN modules in the 5.00 version. That was the reason I've waited with the migration from the Soft Float to the Hard Float version till I got the missing patch for LMS.

I'm wondering why this patch is not installed with your installation! The only reason for that can be that a variable in /sp/scripts/sp.ini is not set or set to a false value. If the correct value is not set here, the normal LMS version will be installed, without the Hard Float patch.

Could some others here in the forum confirm that LMS installation with version 5.05 is running fine, or report the problem here?

Thanks a lot,
Thomas
truehl
http://www.squeezeplug.de

castalla
Posts: 558
Joined: Thu Jul 19, 2012 3:46 pm

Re: SqueezePlug Version 5 ready for download

Sun Nov 18, 2012 8:57 am

Updated to 5.05 - no problems with LMS

User avatar
Trixster
Posts: 261
Joined: Sat Jul 07, 2012 3:53 pm

Re: SqueezePlug Version 5 ready for download

Sun Nov 18, 2012 9:00 am

Version 5.05 seems to be running fine for me Thomas.

User avatar
.helge
Posts: 35
Joined: Wed Jul 25, 2012 9:14 pm

Re: SqueezePlug Version 5 ready for download

Sun Nov 18, 2012 9:42 pm

truehl wrote:Hi all,
I've checked the 5.05 patch multiple times now and can't finds an error. After an 5.05 update the installation of LMS works fine for me and all the other scripts are working fine, as far as I could see.

So I think everything should work now, if not please tell me and I'll take a deeper look.

I made an other decision I like to let you know and I like to get your feedback! I like to reduce the complexity of SqueezePlug so I think I'll drop all SqueezePlug versions except the version for Raspberry Pi. I think Raspberry Pi is the best platform for SqueezePlug ever and we don't need versions for other device. So versions for SheevaPlug, Dockstar and GoFlex Net will be be discontinued.

There are some reasons for a Debian SoftFloat version, so I think it would be a good plan to provide 2 versions, one HardFloat and one SoftFloat.

What do you think?
I totally aggree!
Regarding the softfloat (armel) version I think it's a good idea, because it will keep users to stick with LMS and thus keep it popular.
Is it possible to give the user the choice via the squeezeplug setup menu at startup?

Helge
p.s.: SP 5.05 runing smoothly via ethernet :)

hestbank
Posts: 7
Joined: Fri Nov 16, 2012 10:48 pm

Re: SqueezePlug Version 5 ready for download

Sun Nov 18, 2012 10:08 pm

truehl wrote: It depends ... I like 4 GB class 10 cards most. That's enough by far for the system but if you like to save music directly on the card, there is not much space left! I prefer to store the music on an extra HD, attached to the RPi!
Thanks, Thomas.

I see that Triode is working on a Squeezelite app which will decode many more formats than Squeezeslave, particularly I think it will enable using Spotify via Triode's Spotify app (which works brilliantly, but not with Squeezeslave).

Cheeky to ask I know, but any chance of including this in the Squeezeplug image? I know my way round Windows but trying to install Squeezelite on your Linux OS fills me with dread. Or can someone point me in the direction of some meaningful instructions.

Again, thanks,

David

User avatar
truehl
Posts: 642
Joined: Sun Mar 04, 2012 6:47 pm
Contact: Website

Re: SqueezePlug Version 5 ready for download

Sun Nov 18, 2012 10:11 pm

.helge wrote:Is it possible to give the user the choice via the squeezeplug setup menu at startup?
No, that's not possible, because the packages included in Raspbian are all hf and the normal Wheezy are sf. So I have to make two different versions. I'm already working on it and it seems to be a possible mission, but it's not as easy as you could imagine. I think it's worth doing this, because we become a bit more flexible. Debian for armel is very good supported, for armhf sometimes not. E.g. We can use all the standard .deb packages e.g the one for LMS, and we can use Spotify.

In my early testing I've seen, that the sf version of LMS will work with a very good performance if you use overclocking with 1 GHz. That runs very stable for me! I can not see any difference to the hf version so far, but I'll keep on testing. Right now I only own 256 MB RPi's so I'm expecting a performance boost with 512 MB. Hopefully I can checks this next week, cause RS-Online announced the delivery of my order half a year ago!
truehl
http://www.squeezeplug.de

User avatar
.helge
Posts: 35
Joined: Wed Jul 25, 2012 9:14 pm

Re: SqueezePlug Version 5 ready for download

Sun Nov 18, 2012 10:18 pm

truehl wrote:
.helge wrote: Hopefully I can checks this next week, cause RS-Online announced the delivery of my order half a year ago!
I did the same and ordered at RS in July! In september I ordered at farnell and that took only 6 weeks! so it's alreaddy here. RS does not seem to be the first choice for ordering RPIs

User avatar
.helge
Posts: 35
Joined: Wed Jul 25, 2012 9:14 pm

Re: SqueezePlug Version 5 ready for download

Sun Nov 18, 2012 11:05 pm

More Feedback:

I just tried the Clone feature in SP. It works fine for me, allthough I was a little frightend by the menu. It does not clearly tell the user what is source or destination!
I did it anyway after looking into the script. I successfully cloned an 8GB SD to a 32GB SD! :)

drgeoff
Posts: 9804
Joined: Wed Jan 25, 2012 6:39 pm

Re: SqueezePlug Version 5 ready for download

Mon Nov 19, 2012 9:15 am

hestbank wrote:..... trying to install Squeezelite on your Linux OS fills me with dread. Or can someone point me in the direction of some meaningful instructions.
You must be easily frightened. :lol:
You type 'setup' then follow the menus (cursor keys, Tab key, Enter key) and answer a few 'yes/no' questions. Simples!

ypout
Posts: 7
Joined: Tue Nov 13, 2012 8:14 am

Re: SqueezePlug Version 5 ready for download

Mon Nov 19, 2012 10:10 am

ypout wrote:Hi
I am experiencing an issue with playback of files (flac and mp3).
Everthing seems to run fie for the first 10 or so tracks then a track will play to about 2/3 of the way through, then stop and restart at the beginning again, soemtimes it does this over and over on te same track sometimes it finishes the track and goes to the next one.

I have updated squeezeplug to 5.04
running squeeze slave on the same R-PI as the server
Using a 2GB micro SD card (in an SDcard holder - not sure what class it is but wandering if they be part of the problem)
Music is on a 32GB USB stick connected via a powered USB hub mounted as /mnt/external/music
PI is powered from the HUB too
TOP shows no obvious loading issues

The tracks all play fine on my laptop using Banshee and Mplayer.

Any ideas?
Looks like this issue is something to do with the USB hub. When the USB stick is connected directly to the PI all is well :D

Return to “Media centres”