castalla
Posts: 558
Joined: Thu Jul 19, 2012 3:46 pm

Re: SqueezePlug Version 5 ready for download

Thu Nov 08, 2012 10:56 pm

Looks like the server directories it's trying to access have changed.

Not sure if the image updates take this into account - you've nothing to lose by installing the squeezeplug updates. Try that & then LMS install.

I could be totally off beam here - but until Truehl replies I think it's your best option.

castalla
Posts: 558
Joined: Thu Jul 19, 2012 3:46 pm

Re: SqueezePlug Version 5 ready for download

Thu Nov 08, 2012 10:57 pm

Okay! Scratch what I suggested!

mikebainbridge
Posts: 9
Joined: Tue Oct 30, 2012 5:20 pm

Re: SqueezePlug Version 5 ready for download

Thu Nov 08, 2012 11:54 pm

m4arky - have you come across ipeng ? It's a very fine LMS controller with an audiophile player available for in app purchase on iOS. I use an old iphone 3 plugged into my Onkyo 509 via USB as the player and control it through ipeng on ipad or through the web interface. I've been having some both with squeezslave and squeezelite through HDMI. Overnight or while I"m away for the day it seems to crash or at least both stop responding. I can play to an external player but not to the players on the 'Pi', More investigation for the weekend...

fortunegrey
Posts: 4
Joined: Sat Nov 03, 2012 10:13 am

Re: SqueezePlug Version 5 ready for download

Fri Nov 09, 2012 12:16 pm

This is so cool - but I'm a bit of a novice and having trouble connecting the dots.

I've updated to the latest Squeezeplug and I'm attempting to use a Go Flex drive attached to my router - the R Pi is linked by ethernet to the router. LMS is up and running, but can't make the connection to drive with music.

I'm getting the following error message:

[mntent]: line 50 in /etc/fstab is bad

Any ideas?

bobbydriver
Posts: 70
Joined: Thu Oct 18, 2012 9:06 am

Re: SqueezePlug Version 5 ready for download

Fri Nov 09, 2012 3:18 pm

sounds like something not right with your fstab

can you tell us what is on line 50 of the /etc/fstab file?

I have the almost identical setup to you (goflex net drive with my library on it) and I have it working fine

fortunegrey
Posts: 4
Joined: Sat Nov 03, 2012 10:13 am

Re: SqueezePlug Version 5 ready for download

Sat Nov 10, 2012 7:54 am

Thanks @bobbydriver - I've restarted the whole process, reloading image onto SD card, and starting from scratch. I'm not getting that same error. But I still can't connect to my music library - which is on a go flex drive attached to my router.

I configure the media library - as Samba, at the IP address of the Go Flex, to the itunes folder, and with a username/password on the Go Flex -

/goflex_home/GoFlex%20Home%20Personal/SharedMusic/ITunesMusicGoods

It almost immediately says the media library was successfully configured and mounted, and is now at /mnt/samba - but that directory just has a series of generic folders: backup data itunes media.

Any tips?

jojojojojojo
Posts: 27
Joined: Wed Apr 11, 2012 12:02 pm

Re: SqueezePlug Version 5 ready for download

Sat Nov 10, 2012 2:13 pm

Hi,
squeezeplug is running perfectly for me!
I only face a small problem with squeezeplug v5.02. When I switch it off with "shutdown -h now" and then a few days later switch it on, Internetradio-Option is gone.. I use LMS and squeezeslave on the same pi, controlled with Android Squeeze Commander. The Internetradio-Button just does not whow anymore in the Android menue. Installing the LMS again helps, and the button is back.
Anybody had the same problem?
Maybe it would be enough to restart the LMS server instead of reinstalling, but I dont know how to do that.. help on this would be very appreciated:)
REgards,
Johannes

PS Im just updating to v5.03

User avatar
.helge
Posts: 35
Joined: Wed Jul 25, 2012 9:14 pm

Re: SqueezePlug Version 5 ready for download

Sun Nov 11, 2012 6:38 pm

Hello everyone,

I've been running LMS successfully on SP V5.00. Then I updated to Version 5.03. Unfortunately since then LMS isn't starting anymore. I' did install other stuff (e.g. FHEM) on the Pi; so I thought that might be the problem and therefore decided to make a clean install.
Still LMS won't start. Here is what I did:
  • Flashed an 8GB SD card with the Version available on squeezeplug.de using the tools truehl recomends on his Homepage
    Logon via Putty (SSH)
    changed root PW
    then entered the Squeezeplug Setup
    changed the timezone
    installed samba
    chose Update SP from the advanced menu and let it do what's necessary
    waited ;)
    did a reboot
    installed LMS
    investigeted with "top"
    squeezeboxserver starts for a few seconds, then disapears over and over again (this seems to be a loop)
    LMS is not reachable via http://squeezeplug:9000"
That's it, nothing else. No expanding, no other SW installation or usage of apt-get in any way. Nothing!

Some coomand line outputs:

Code: Select all

[email protected]:~# tail -f /var/log/squeezeboxserver/server.log
2012-11-11 19:14:16 Logitech Media Server died. Restarting.
2012-11-11 19:14:21 Logitech Media Server died. Restarting.
2012-11-11 19:14:26 Logitech Media Server died. Restarting.
2012-11-11 19:14:31 Logitech Media Server died. Restarting.
2012-11-11 19:14:36 Logitech Media Server died. Restarting.
2012-11-11 19:14:41 Logitech Media Server died. Restarting.
2012-11-11 19:14:46 Logitech Media Server died. Restarting.
2012-11-11 19:14:51 Logitech Media Server died. Restarting.
2012-11-11 19:14:56 Logitech Media Server died. Restarting.
2012-11-11 19:15:01 Logitech Media Server died. Restarting.

Code: Select all

[email protected]:~# cat /proc/cpuinfo
Processor       : ARMv6-compatible processor rev 7 (v6l)
BogoMIPS        : 697.95
Features        : swp half thumb fastmult vfp edsp java tls
CPU implementer : 0x41
CPU architecture: 7
CPU variant     : 0x0
CPU part        : 0xb76
CPU revision    : 7

Hardware        : BCM2708
Revision        : 0002
Serial          : 00000000665a5efd
[email protected]:~#
Does anyone suffer the same issues?? Where else on the PI can I investigate to narrow down the cause of the Problem?

THX in advance for any hints,
Helge

User avatar
truehl
Posts: 642
Joined: Sun Mar 04, 2012 6:47 pm
Contact: Website

Re: SqueezePlug Version 5 ready for download

Sun Nov 11, 2012 6:59 pm

.helge wrote:Hello everyone,

I've been running LMS successfully on SP V5.00. Then I updated to Version 5.03. Unfortunately since then LMS isn't starting anymore. I' did install other stuff (e.g. FHEM) on the Pi; so I thought that might be the problem and therefore decided to make a clean install.
Still LMS won't start. Here is what I did:
  • Flashed an 8GB SD card with the Version available on squeezeplug.de using the tools truehl recomends on his Homepage
    Logon via Putty (SSH)
    changed root PW
    then entered the Squeezeplug Setup
    changed the timezone
    installed samba
    chose Update SP from the advanced menu and let it do what's necessary
    waited ;)
    did a reboot
    installed LMS
    investigeted with "top"
    squeezeboxserver starts for a few seconds, then disapears over and over again (this seems to be a loop)
    LMS is not reachable via http://squeezeplug:9000"
That's it, nothing else. No expanding, no other SW installation or usage of apt-get in any way. Nothing!

Some coomand line outputs:

Code: Select all

[email protected]:~# tail -f /var/log/squeezeboxserver/server.log
2012-11-11 19:14:16 Logitech Media Server died. Restarting.
2012-11-11 19:14:21 Logitech Media Server died. Restarting.
2012-11-11 19:14:26 Logitech Media Server died. Restarting.
2012-11-11 19:14:31 Logitech Media Server died. Restarting.
2012-11-11 19:14:36 Logitech Media Server died. Restarting.
2012-11-11 19:14:41 Logitech Media Server died. Restarting.
2012-11-11 19:14:46 Logitech Media Server died. Restarting.
2012-11-11 19:14:51 Logitech Media Server died. Restarting.
2012-11-11 19:14:56 Logitech Media Server died. Restarting.
2012-11-11 19:15:01 Logitech Media Server died. Restarting.

Code: Select all

[email protected]:~# cat /proc/cpuinfo
Processor       : ARMv6-compatible processor rev 7 (v6l)
BogoMIPS        : 697.95
Features        : swp half thumb fastmult vfp edsp java tls
CPU implementer : 0x41
CPU architecture: 7
CPU variant     : 0x0
CPU part        : 0xb76
CPU revision    : 7

Hardware        : BCM2708
Revision        : 0002
Serial          : 00000000665a5efd
[email protected]:~#
Does anyone suffer the same issues?? Where else on the PI can I investigate to narrow down the cause of the Problem?

THX in advance for any hints,
Helge
Hi Helge,
please run "df -h" and post the result! I think you maybe run out of space?!

If not, we have to search for a solution! I did a fresh install some minutes ago and everything runs fine!

Let me know!
truehl
http://www.squeezeplug.de

User avatar
.helge
Posts: 35
Joined: Wed Jul 25, 2012 9:14 pm

Re: SqueezePlug Version 5 ready for download

Sun Nov 11, 2012 7:03 pm

Hi Thomas,

thx for the quick reply. (Awesome :) )

Code: Select all

[email protected]:~# df -h
Filesystem      Size  Used Avail Use% Mounted on
rootfs          1.7G  1.3G  358M  78% /
/dev/root       1.7G  1.3G  358M  78% /
devtmpfs        117M     0  117M   0% /dev
tmpfs            24M  336K   23M   2% /run
tmpfs           5.0M     0  5.0M   0% /run/lock
tmpfs            47M     0   47M   0% /run/shm
/dev/mmcblk0p1   75M   17M   58M  23% /boot
[email protected]:~#

I will try the resizing now.

Helge

User avatar
truehl
Posts: 642
Joined: Sun Mar 04, 2012 6:47 pm
Contact: Website

Re: SqueezePlug Version 5 ready for download

Sun Nov 11, 2012 7:07 pm

.helge wrote:Hi Thomas,

thx for the quick reply. (Awesome :) )

Code: Select all

[email protected]:~# df -h
Filesystem      Size  Used Avail Use% Mounted on
rootfs          1.7G  1.3G  358M  78% /
/dev/root       1.7G  1.3G  358M  78% /
devtmpfs        117M     0  117M   0% /dev
tmpfs            24M  336K   23M   2% /run
tmpfs           5.0M     0  5.0M   0% /run/lock
tmpfs            47M     0   47M   0% /run/shm
/dev/mmcblk0p1   75M   17M   58M  23% /boot
[email protected]:~#

I will try the resizing now.

Helge
Hm, it looks there is enough space left! Try and tell me, if not, you should Skype ore something like that!
truehl
http://www.squeezeplug.de

User avatar
truehl
Posts: 642
Joined: Sun Mar 04, 2012 6:47 pm
Contact: Website

Re: SqueezePlug Version 5 ready for download

Sun Nov 11, 2012 7:45 pm

Hi folks,
I'm back again from business travel and will have more time the next days to fix some bugs with SqueezePlug. There is a bug in SqueezeLite, I'll fix the next days. I hope to present an init script for SqueezeLite, that will make thinks much more easy. I'll also update SqueezeLite to a newer version.

Some of you told me about problems with LMS. I installed a fresh RPi the last hours and could not find a problem. maybe I missed something.

Maybe I have overseen other bugs the last days, because I didn't stay at home. So please tell me again via PM or here in forum.

I'm also working on an other improvement. SqueezePlug will get the possibility to act as an access-point. Thats very cool, because you can use it as a stand alone and autonomy system. E.g if you own an iOS device you can run LMS and SqueezeSlave or SqueezeLite on RPi plus an access-point. You can than connect your iOS device to the access-point on RPi and remote control it from here. If you also use iPeng, you can use the iOS device for sound-output! If you power up your RPi with battery power, you will be ultra mobile!

Greetings,
Thomas
truehl
http://www.squeezeplug.de

triplettravel
Posts: 4
Joined: Sun Nov 11, 2012 7:57 pm

Re: SqueezePlug Version 5 ready for download

Sun Nov 11, 2012 8:08 pm

coswald wrote:Thomas
I don't know if you can help me. Sorry - I am new to Linux!
Brand new Raspberry Pi (new model) with tonight's download of SqueezePlug sp_rpi_500.img on an 8GB SD card and a USB hard drive attached with the music.
I can use PuTTY onto it and configure it wihtout problems, but nothing shows in the browser <ip address>:9000 - just a timeout.
Also, I get this error:
>>
[email protected]:~# squeezeboxserver
The following CPAN modules were found but cannot work with Logitech Media Server:
Image::Scale:
Can't load '/usr/share/squeezeboxserver/CPAN/arch/5.14/arm-linux-gnueabihf-thread-multi-64int/auto/Image/Scale/Scale.so' for module Image::Scale: libjpeg.so.8: cannot open shared object file: No such file or directory at /usr/lib/perl/5.14/DynaLoader.pm line 184.
at (eval 102) line 2
Compilation failed in require at (eval 102) line 2.
BEGIN failed--compilation aborted at (eval 102) line 2.


To fix this problem you have several options:
1. Install the latest version of the module(s) using CPAN: sudo cpan Some::Module
2. Update the module's package using apt-get, yum, etc.
3. Run the .tar.gz version of Logitech Media Server which includes all required CPAN modules.
<<

top shows it running as user squeezeb.
Any ideas?
Thanks
I can't help other than to say I see the same. Fresh install today taking the default LMS version. fails to start every time.

User avatar
.helge
Posts: 35
Joined: Wed Jul 25, 2012 9:14 pm

Re: SqueezePlug Version 5 ready for download

Sun Nov 11, 2012 8:59 pm

Hey guys,
just pushed my SD card from PI no.1 into a second one. The harware is different. The problem (see four posts above) is the same:

Code: Select all

[email protected]:~# cat /proc/cpuinfo
Processor       : ARMv6-compatible processor rev 7 (v6l)
BogoMIPS        : 697.95
Features        : swp half thumb fastmult vfp edsp java tls
CPU implementer : 0x41
CPU architecture: 7
CPU variant     : 0x0
CPU part        : 0xb76
CPU revision    : 7

Hardware        : BCM2708
Revision        : 0004
Serial          : 000000001f3b746a
[email protected]:~#
I guess HW is not the Problem, maybe the one in front of the Pi ;) :(

User avatar
truehl
Posts: 642
Joined: Sun Mar 04, 2012 6:47 pm
Contact: Website

Re: SqueezePlug Version 5 ready for download

Sun Nov 11, 2012 9:19 pm

.helge wrote:I guess HW is not the Problem, maybe the one in front of the Pi ;) :(
Hallo Helge,
ich versuche Dich "anzuskypen", leider ohne Erfolg!
truehl
http://www.squeezeplug.de

triplettravel
Posts: 4
Joined: Sun Nov 11, 2012 7:57 pm

Re: SqueezePlug Version 5 ready for download

Sun Nov 11, 2012 10:49 pm

coswald wrote:Thomas
I don't know if you can help me. Sorry - I am new to Linux!
Brand new Raspberry Pi (new model) with tonight's download of SqueezePlug sp_rpi_500.img on an 8GB SD card and a USB hard drive attached with the music.
I can use PuTTY onto it and configure it wihtout problems, but nothing shows in the browser <ip address>:9000 - just a timeout.
Also, I get this error:
>>
[email protected]:~# squeezeboxserver
The following CPAN modules were found but cannot work with Logitech Media Server:
Image::Scale:
Can't load '/usr/share/squeezeboxserver/CPAN/arch/5.14/arm-linux-gnueabihf-thread-multi-64int/auto/Image/Scale/Scale.so' for module Image::Scale: libjpeg.so.8: cannot open shared object file: No such file or directory at /usr/lib/perl/5.14/DynaLoader.pm line 184.
at (eval 102) line 2
Compilation failed in require at (eval 102) line 2.
BEGIN failed--compilation aborted at (eval 102) line 2.


To fix this problem you have several options:
1. Install the latest version of the module(s) using CPAN: sudo cpan Some::Module
2. Update the module's package using apt-get, yum, etc.
3. Run the .tar.gz version of Logitech Media Server which includes all required CPAN modules.
<<

top shows it running as user squeezeb.
Any ideas?
Thanks
I can't help other than to say I have exactly the same problem. Installed from scratch today taking default values.

User avatar
.helge
Posts: 35
Joined: Wed Jul 25, 2012 9:14 pm

Re: SqueezePlug Version 5 ready for download

Sun Nov 11, 2012 11:10 pm

Hello again dear squeezepluggers,

thanks to a quick chat with Thomas I finally found out what I was doing wrong and would like to share the results with you:
As described above I flashed my SD and after that logged in to the PI. But I used WinSCP!!. Then I klicked the button which hands the WinSCP session over to putty. Bad idea!!!
putty.png
putty.png (52.27 KiB) Viewed 4045 times
What happens then is, that
  • putty will open,
    the credetnials are automatically handed over to putty and
    logging in manually is not necessary.
But this also means that you do not get to see the initial one-time dialog from the squeezeplug setup (I guess first_start.sh) which pops up the first time you log in to your PI.
Since I allready did a login with WinSCP the session handed over to putty is the second session!! Because I did not get to see the initial menu from the one-time dialog I was not able to choose Raspbery Pi from the available options. Nevertheless this is crucial to set up LMS for armhf. All the time I was installing the soft-float version, which as we all know does not do the trick...
The next time you boot your device first_start.sh is named to first_start_no.sh and at the next login the lines in /root/.profile do not have the effect of displaying the initial one-time dialog. I was stuck without knowing.

So my lazyness, which was storing former sessions incl. password in WinSCP, lead to the problems above.
Conclusion: allways use putty the first time you log in to any freshly set up squeezeplug!

Sorry guys for the inconvenience. But maybe this may help someone else.
Last but not least I would like to thank Thomas for his great support and of course his work on SP!!

gn8

bobbydriver
Posts: 70
Joined: Thu Oct 18, 2012 9:06 am

Re: SqueezePlug Version 5 ready for download

Mon Nov 12, 2012 11:15 am

Quick question on the Squeezeplug image – how does LMS serve the web pages on port 9000? Does it have an embedded web server?

I just added the Apache2 package to my Squeezeplug image for another use, and Squeezebox seems to be a lot less stable (much more buffering and wireless disconnects) since I did that

Could be complete coincidence of course, but thought it was worth checking?

User avatar
.helge
Posts: 35
Joined: Wed Jul 25, 2012 9:14 pm

Re: SqueezePlug Version 5 ready for download

Mon Nov 12, 2012 12:43 pm

bobbydriver wrote:Quick question on the Squeezeplug image – how does LMS serve the web pages on port 9000? Does it have an embedded web server?

I just added the Apache2 package to my Squeezeplug image for another use, and Squeezebox seems to be a lot less stable (much more buffering and wireless disconnects) since I did that

Could be complete coincidence of course, but thought it was worth checking?
LMS brings it's own Webeserver. It is written in perl.
Maybe you can deliver some more information? such as CPU usage? Any hints in /var/log/messages or /var/log/syslog?

m4rky
Posts: 37
Joined: Wed Jul 04, 2012 8:57 pm

Re: SqueezePlug Version 5 ready for download

Mon Nov 12, 2012 1:15 pm

m4rky wrote:Thankys guys for the response.

The FLAC playback is most important to me so I can wait until Spotify is properly implemented.
But if you are planning to use SqueezeLite then that is a dissapointment for me as it doesn't have MPD support for iPhone/iPad control using MPoD.

Unless MPD has to be installed separately?

The idea is that I will package the R-Pi with a USB Dac in a little box and use it headless connected to my Hi-Fi. The only control I will have is with the iPhone/iPad.
Another update to my install.

I now have SqueezePlug playing FLAC files and internet radio through SqueezeLite on my wireless/headless Raspberry Pi controlled from my iPhone and iPad using the Logitech SqueezeBox App :D :D :D

So I don't have any need for MPD.
I got hold of the EdiMax Wireless USB device and it just worked.
I am going to see how much I use this device with my HiFi and whether I can cope with the sound quality from the Raspberry Pi 3.5" audio jack before I purchase a USB DAC. Unless I can get a good one cheap on eBay ;)

Now I have just two problems, both to do with Squeezebox synchornization between Squeezebox player on my Windows Media Center 7 PC and SqueezeLite on the R-Pi:
1) When I sync the playing of a FLAC file there is a delay between the playback of the two devices. One of them is a split second behind the other.
2) When I have sync on and Internet radio playing then the playback on the R-Pi is slower than on the WMC7 PC. It's as though playback is half the speed in the R-Pi.

Any ideas?

User avatar
truehl
Posts: 642
Joined: Sun Mar 04, 2012 6:47 pm
Contact: Website

Re: SqueezePlug Version 5 ready for download

Mon Nov 12, 2012 9:39 pm

Update to 5.04 available

A new update is available. This is an minor patch only for SqueezeLite.

You can easily update your RPi by:
"setup" <Advanced_Configuration> <Update_SP>

Newer patches already contains older ones! This means that the 5.04 Patch already includes the 5.01, 5.02 and 5.03 patch, so you have to run the update routine only once!

I like to make SqueezePlug better and better.

Patch History:
---------------------------------------------------------------------------------
500
initial version
---------------------------------------------------------------------------------
501
expand_rootfs_2.disabled: Hint included for the process is taking some time
lib.sh: Changed some text to make it more clear
---------------------------------------------------------------------------------
502
smb.default: Changed because of a wrong mount point for the media library
rpi_fw_update.sh: Changed some text for warnings
---------------------------------------------------------------------------------
503
System updated to the new stable version of raspbian including firmware support for the new 512 RAM boards
rpi_memory_split.sh: Changed because of the new memory-split mechanism
squeezeslave.armhf: SqueezeSlave new version squeezeslave-1.2-381-armhf-lnx32
update WiFi and other drivers for Debian HF (Raspbian)
update crashplan to fix a bug
install a new HQ LMS-Player, SqueezeLite
---------------------------------------------------------------------------------
504
provide a new version of SqueezeLite and an init-script for SqueezeLite
---------------------------------------------------------------------------------
truehl
http://www.squeezeplug.de

User avatar
truehl
Posts: 642
Joined: Sun Mar 04, 2012 6:47 pm
Contact: Website

Re: SqueezePlug Version 5 ready for download

Mon Nov 12, 2012 10:25 pm

triplettravel wrote:
coswald wrote:Thomas
I don't know if you can help me. Sorry - I am new to Linux!
Brand new Raspberry Pi (new model) with tonight's download of SqueezePlug sp_rpi_500.img on an 8GB SD card and a USB hard drive attached with the music.
I can use PuTTY onto it and configure it wihtout problems, but nothing shows in the browser <ip address>:9000 - just a timeout.
Also, I get this error:
>>
[email protected]eplug:~# squeezeboxserver
The following CPAN modules were found but cannot work with Logitech Media Server:
Image::Scale:
Can't load '/usr/share/squeezeboxserver/CPAN/arch/5.14/arm-linux-gnueabihf-thread-multi-64int/auto/Image/Scale/Scale.so' for module Image::Scale: libjpeg.so.8: cannot open shared object file: No such file or directory at /usr/lib/perl/5.14/DynaLoader.pm line 184.
at (eval 102) line 2
Compilation failed in require at (eval 102) line 2.
BEGIN failed--compilation aborted at (eval 102) line 2.


To fix this problem you have several options:
1. Install the latest version of the module(s) using CPAN: sudo cpan Some::Module
2. Update the module's package using apt-get, yum, etc.
3. Run the .tar.gz version of Logitech Media Server which includes all required CPAN modules.
<<

top shows it running as user squeezeb.
Any ideas?
Thanks
I can't help other than to say I have exactly the same problem. Installed from scratch today taking default values.
If you see these CPAN issues, it's a sign that the LMS patch for Debian hard float is not installed for some reason. I have integrated a patch (thanks to allthingspi) for Debian Hard Float. The patch will only be installed, if you have set your Pi to Raspberry during the first connection. You can check it by typing "cat /sp/scripts/sp.ini | grep DEVICE" if the result of this command is not equal "DEVICE=raspberry" then the install script will not install the patch and LMS won't work! Can you please check this?

Thanks,
Thomas
truehl
http://www.squeezeplug.de

TheD6Bel
Posts: 67
Joined: Tue Sep 11, 2012 11:18 am

Re: SqueezePlug Version 5 ready for download

Mon Nov 12, 2012 10:40 pm

Hello,

I use squeezeplug for 2-3 weeks and everything works fine.

but I want to do one multi room system with RPi, is it possible to install multiple squeezeslave the same RPi? Each squeezeslave that connects to a very specific sound card?
if so, how? :D

Or is what I require to buy 4 rpi for managing 4 rooms?

thank you

User avatar
truehl
Posts: 642
Joined: Sun Mar 04, 2012 6:47 pm
Contact: Website

Re: SqueezePlug Version 5 ready for download

Tue Nov 13, 2012 5:48 am

TheD6Bel wrote:Hello,

I use squeezeplug for 2-3 weeks and everything works fine.

but I want to do one multi room system with RPi, is it possible to install multiple squeezeslave the same RPi? Each squeezeslave that connects to a very specific sound card?
if so, how? :D

Or is what I require to buy 4 rpi for managing 4 rooms?

thank you
Yes, it is possible, but how are your plans to play to different sounds in different rooms with one piece of hardware. :D

You can run multiple instances of SqueezeSlave on one RPi each on different sound cards and multiple RPi's on one network!
truehl
http://www.squeezeplug.de

triplettravel
Posts: 4
Joined: Sun Nov 11, 2012 7:57 pm

Re: SqueezePlug Version 5 ready for download

Tue Nov 13, 2012 8:54 am

truehl wrote:
triplettravel wrote:
coswald wrote:Thomas
I don't know if you can help me. Sorry - I am new to Linux!
Brand new Raspberry Pi (new model) with tonight's download of SqueezePlug sp_rpi_500.img on an 8GB SD card and a USB hard drive attached with the music.
I can use PuTTY onto it and configure it wihtout problems, but nothing shows in the browser <ip address>:9000 - just a timeout.
Also, I get this error:
>>
[email protected]:~# squeezeboxserver
The following CPAN modules were found but cannot work with Logitech Media Server:
Image::Scale:
Can't load '/usr/share/squeezeboxserver/CPAN/arch/5.14/arm-linux-gnueabihf-thread-multi-64int/auto/Image/Scale/Scale.so' for module Image::Scale: libjpeg.so.8: cannot open shared object file: No such file or directory at /usr/lib/perl/5.14/DynaLoader.pm line 184.
at (eval 102) line 2
Compilation failed in require at (eval 102) line 2.
BEGIN failed--compilation aborted at (eval 102) line 2.


To fix this problem you have several options:
1. Install the latest version of the module(s) using CPAN: sudo cpan Some::Module
2. Update the module's package using apt-get, yum, etc.
3. Run the .tar.gz version of Logitech Media Server which includes all required CPAN modules.
<<

top shows it running as user squeezeb.
Any ideas?
Thanks
I can't help other than to say I have exactly the same problem. Installed from scratch today taking default values.
If you see these CPAN issues, it's a sign that the LMS patch for Debian hard float is not installed for some reason. I have integrated a patch (thanks to allthingspi) for Debian Hard Float. The patch will only be installed, if you have set your Pi to Raspberry during the first connection. You can check it by typing "cat /sp/scripts/sp.ini | grep DEVICE" if the result of this command is not equal "DEVICE=raspberry" then the install script will not install the patch and LMS won't work! Can you please check this?

Thanks,
Thomas
Thank you

This is what I get:

[email protected]:~# cat /sp/scripts/sp.ini | grep DEVICE
DEVICE raspberry
[email protected]:~#

should it be DEVICE=raspberry ?

Return to “Media centres”