bruno123
Posts: 3
Joined: Sat Sep 09, 2017 3:30 pm

Kodi does not start on PI 3

Sat Sep 09, 2017 3:45 pm

Hi
I have Kodi on a standard SD that I created for my PI Zero, no problem at all on PI Zero.
Now I bought a PI 3, and while the SD with RASPBIAN (previously on the Pi Zero) works wothout any troubles, the SD with Kodi does not work at all; at the beginning when the plug is connected, I see the green light but after a second it disappears and nothing happens, nothing on the screen, nothing on the wifi network, dead.
Any idea?
Thanks
Bruno

drgeoff
Posts: 8209
Joined: Wed Jan 25, 2012 6:39 pm

Re: Kodi does not start on PI 3

Sat Sep 09, 2017 10:46 pm

What Kodi?

LibreELEC
OpenELEC
OSMC
XBian
Raspbian with Kodi
RetroPie
Recalbox
Compiled from source

User avatar
mahjongg
Forum Moderator
Forum Moderator
Posts: 10655
Joined: Sun Mar 11, 2012 12:19 am
Location: South Holland, The Netherlands

Re: Kodi does not start on PI 3

Sun Sep 10, 2017 12:11 pm

Old OS versions created before a newer PI was launched do not boot on said newer PI, but the latest OS will also boot on all older PI's.

User avatar
Imperf3kt
Posts: 1021
Joined: Tue Jun 20, 2017 12:16 am
Location: Australia

Re: Kodi does not start on PI 3

Sun Sep 10, 2017 10:59 pm

You don't have the experimental video driver enabled, do you? I have noticed Kodi fails to work with that.
User experiencing technical difficulties.

bruno123
Posts: 3
Joined: Sat Sep 09, 2017 3:30 pm

Re: Kodi does not start on PI 3

Tue Sep 12, 2017 4:44 pm

drgeoff: It should be OSMC (directly installed on SD).
Imperf3kt: I don't think that I have the experimental video driver enabled, how can I check it ?

dom
Raspberry Pi Engineer & Forum Moderator
Raspberry Pi Engineer & Forum Moderator
Posts: 5141
Joined: Wed Aug 17, 2011 7:41 pm
Location: Cambridge

Re: Kodi does not start on PI 3

Tue Sep 12, 2017 5:25 pm

OSMC has separate images for Pi0/1 and Pi2/3. You need to run the correct image.

For help in transferring existing setup to the new Pi2/3 image you should ask here:
https://discourse.osmc.tv/

bruno123
Posts: 3
Joined: Sat Sep 09, 2017 3:30 pm

Re: Kodi does not start on PI 3

Tue Sep 12, 2017 6:27 pm

Thank you for your answer.
I am surprised that other application (eg Openhab) are compatible, while kodi no.
So I need two different SDs for changing the hardware.

Return to “Media centres”

Who is online

Users browsing this forum: No registered users and 2 guests