Zurafta
Posts: 1
Joined: Sun May 14, 2017 4:54 pm

Kodi video playback showing console/desktop in background

Sun May 14, 2017 5:23 pm

Hello!
I am currently building a Kodi setup with a Raspberry Pi 3 and the official 7" touchscreen for a car project. I already had problems with its shutdown process but I was able to solve those thanks to @rascas over on this thread. I installed the Raspbian Jessie with Pixel version from 2017-04-10 and installed Kodi via apt-get. The touchscreen itself does work and so does displaying the menus but when I start playing back a video that does not fit the screen like movies with cinema aspect ratio, instead of black borders I can see the desktop in the background, which does not look good. I also tried booting Raspbian up in console mode but then you can simply see that in the background. I also tried hooking the Pi up to an HDMI screen for testing purposes and there the movies play back just fine.
I would be very glad if someone could help me with fixing this issue and if you need more information skim my old thread or simply ask me and I will try to provide it!

Zurafta

ktb
Posts: 1447
Joined: Fri Dec 26, 2014 7:53 pm

Re: Kodi video playback showing console/desktop in backgroun

Sun May 14, 2017 7:44 pm

I've had the same issue with my Pi3B car project. My simple "fix" was to change the desktop and panel backgrounds to solid black, and set the panel to minimize when not in use:

Main Menu > Preferences > Appearance Settings:
Desktop tab:
Layout: No Image
Colour: #000000 (Black)
Disable (uncheck) Wastebasket

Right-click on LXPanel, Select Panel Settings:
Appearance tab:
Background: Select Solid color (with opacity)
Opacity: 255
Color name: #000000 (Black)

Advanced tab:
Enable (check) Minimize panel when not in use

The other approach I have tried is compiling a generic Linux build of Kodi 18 with X11 support on Raspbian Stretch and using the vc4-fkms-v3d overlay which can be a bit tricky and does increase Kodi CPU usage. That has worked alright for me, but I think I'm going to try sticking with the APT-installed Kodi 17.1 on Raspbian Jessie.

Ickam
Posts: 16
Joined: Sat May 13, 2017 10:16 am

Re: Kodi video playback showing console/desktop in backgroun

Fri Jan 19, 2018 2:02 pm

ktb wrote:
Sun May 14, 2017 7:44 pm
I've had the same issue with my Pi3B car project. My simple "fix" was to change the desktop and panel backgrounds to solid black, and set the panel to minimize when not in use:

Main Menu > Preferences > Appearance Settings:
Desktop tab:
Layout: No Image
Colour: #000000 (Black)
Disable (uncheck) Wastebasket

Right-click on LXPanel, Select Panel Settings:
Appearance tab:
Background: Select Solid color (with opacity)
Opacity: 255
Color name: #000000 (Black)

Advanced tab:
Enable (check) Minimize panel when not in use

The other approach I have tried is compiling a generic Linux build of Kodi 18 with X11 support on Raspbian Stretch and using the vc4-fkms-v3d overlay which can be a bit tricky and does increase Kodi CPU usage. That has worked alright for me, but I think I'm going to try sticking with the APT-installed Kodi 17.1 on Raspbian Jessie.
Can you expand on "using the vc4-fkms-v3d overlay"? how does one do that?

samsunix
Posts: 17
Joined: Thu Nov 23, 2017 5:56 am

Re: Kodi video playback showing console/desktop in background

Fri Jan 19, 2018 7:55 pm

Better solution would be to scale screen bigger. makes live overall much easyer

Code: Select all

sudo nano /boot/config.txt
Uncomment line
disable_overscan=1
Modify lines:
framebuffer_width=1280
framebuffer_height=720
I have most likely that same 7" screen.

Return to “Media centres”