Page 1 of 1

no sound over hdmi

Posted: Thu May 11, 2017 8:39 am
by bennetty
Hi, all,


i used RPi3 model and installed libreelec by noobs.
it has the kodi supported.
then, i play a mp4 file over hdmi interface.
the video is ok and audio has no sound.
my monitor model is aoc u2868pqu.

i am a RPi newbie.
how do i do more trouble shooting for this?

any suggestion or information is welcome.

thanks.

Re: no sound over hdmi

Posted: Thu May 11, 2017 8:41 am
by DougieLawson
Which mode is your HDMI running in? You only get sound with CEA.

run tvservice -s; tvservice -m CEA; tvservice -m DMT to see what you're getting.

Re: no sound over hdmi

Posted: Thu May 11, 2017 1:15 pm
by klricks
Is there no sound only when playing the MP4 video?
Is there sound at other times such as the clicking sound when navigating Kodi menus?
Is sound enabled for HDMI in your monitor OSD?

Re: no sound over hdmi

Posted: Thu May 11, 2017 6:57 pm
by RaspISteve
Guys,

Just got updated to Kodi 17.1 (May 2nd'17). I had no sound and it wasn't until I up'ed the TV volume to 55 (normally 10..14) that I could hear anything.

I'm sure the earlier version included a menu setting for default sound level but I'm stuffed if I can find it now or any other user volume adjust.

The only way I could correct this was to use my moby's remote application (Kore) and my moby's volume keys to take the Kodi default audio level up to normal.

Seems daft that I can find no way to routinely adjust the Kodi play sound level. Happy to take suggestions on this. The remote does produce a pop-up centre-top screen with rotary volume but I haven't found it using a mouse.

Re: no sound over hdmi

Posted: Mon May 15, 2017 9:13 am
by DarrenHill
If you play something, then open the on-screen display and select the settings (cog) icon, you can go to audio and subtitle settings (the top pop-up menu item) and there you can set both volume and amplification.

Put those values to something suitable for your system and then down at the bottom there's an option to set as default for all media. Select this and you should be in a good place.