1080p + DTS + no chattering -> which build??

8 posts
by Penetratore » Tue Aug 07, 2012 7:12 am

I saw on YT some movies being played without chattering on RPi.
I`ve been testing several releases (xbain, openelec, raspbmc) since 1,5 week and everywhere I have chattering on movies 720p and 1080p.

I`ve read that Openelec r10902 has no chattering on 1080p but I cannot find a r10902.img source to download it and check it.

Can somebody tell me which release should I take and how to set it up to be able to play 1080p without chattering?! PLEASE
Posts: 31
Joined: Thu Jul 26, 2012 8:33 pm
by RaTTuS » Tue Aug 07, 2012 7:38 am
what is chattering ?
you will need to make sure that the files are h264 and nothgin else
How To ask Questions :- http://www.catb.org/esr/faqs/smart-questions.html
WARNING - some parts of this post may be erroneous YMMV

User avatar
Posts: 9138
Joined: Tue Nov 29, 2011 11:12 am
Location: North West UK
by Tavalin » Tue Aug 07, 2012 7:44 am
Also need to ensure the Pi isn't trying to decode the DTS itself.
Posts: 59
Joined: Mon Apr 16, 2012 9:53 pm
by Penetratore » Tue Aug 07, 2012 10:26 am
I don`t experience audio problems. I experience every 5 to 10 second (depending if its openelec or Xbain) an 0,5-1 second stop in plaing a movie. It is with every film I test. This dosn`t happen when playing 700MB files.

I use SD card class 4 and a class 10

In audio options I have set up 2.0 not 5.1. The Samsung TV D6750 is a DTS pass thrue so the amplituner should handle the DTS.

how to force RPi not to decode DTS.
Posts: 31
Joined: Thu Jul 26, 2012 8:33 pm
by Tavalin » Tue Aug 07, 2012 10:58 am
If you go to Settings > System > Video there should be options to tell it that the receiver can decode DTS and AC3. If you select these options it will pass the audio stream off to the receiver instead of trying to decode these on the Pi.

The 1 second pause you're experiencing is probably because the CPU on the Pi is being maxed out trying to decode the audio. I had the same thing before I connected up my AV amp to it but now it runs pretty much flawlessly.
Posts: 59
Joined: Mon Apr 16, 2012 9:53 pm
by Penetratore » Tue Aug 07, 2012 9:38 pm
all options for dts and ac3 where checked in .. still 1 second brake
then I unchecked all options .. still 1 second brake
then changed the audio output from HDMI to analoge and still the 1s brake

hmm mayby its not the problem with audio decoding?

ps. not the amplituner is not connected to the TV or the RPi - can this be of matter
Posts: 31
Joined: Thu Jul 26, 2012 8:33 pm
by Terabitten » Tue Aug 07, 2012 11:48 pm
There is a lengthy discussion on the Raspbmc forums about the issues with DTS.


I am quite sceptical of anyone who says that they solved the problem using some random build X or nightly Y from two months ago.

The only thing that has worked for me is overclocking to 950MHz, this solves the stutter for 90% of my 1080p DTS files. Not every Pi will run happily at 950 though.
Posts: 5
Joined: Tue Aug 07, 2012 11:06 pm
by Shotmats » Tue Aug 14, 2012 8:30 pm

I have tried raspbian, openELEC and xbian but all of them stuttered every 5-10 second at 1920x1080. I tried overclock the RPI and tried both NFS and SMB file share but then i changed the refresh rate to 24 Hz and everything works fine. I first did this on xbian 0.5 and it works fine. Then i tried on xbian 0.6. whith refresh rate of 50 or 60 Hz it stops every 5-10 second but then changing the refresh rate to 24 or 25Hz it works perfect. I played for example Pirates of the Caribbean 4, a 1080p movie on 10.93 GB and it runs fine and the cpu is used around 80-85 % according to TOP.

With xbian 0.6 the CPU is overclocked to arm_freq=840 and core_freq=375 but even when running with arm_freq=750 it works fine as well. have not tried 700Mhz yet on xbian 0.6

Hope this might help some one more
Posts: 1
Joined: Tue Aug 14, 2012 8:08 pm