HalfEvilHomer
Posts: 2
Joined: Tue Jul 31, 2012 7:27 pm

How to get AirPlay working.....

Tue Jul 31, 2012 7:34 pm

Hi everyone,

Very new to all of this, my brother just bought a raspberry pi and has downloaded and installed open elec xbmc version 12.0 alpha3

I'm trying to get the airplay working from my iPad 2, the settings on the pi are set to allow AirPlay content but when I try to stream something from the iPad I don't get the airplay icon to appear.

Both are connected the same network, just wondered if anyone had the same problem and has any light to shed. Thanks for helping :)

Koenkk
Posts: 148
Joined: Sun Jul 29, 2012 10:22 pm
Location: Netherlands

Re: How to get AirPlay working.....

Wed Aug 01, 2012 9:25 am

Maybe you should try XBian (it has airplay support) http://xbian.blogspot.nl/

jasjeet
Posts: 90
Joined: Thu May 31, 2012 6:00 pm

Re: How to get AirPlay working.....

Wed Aug 01, 2012 6:27 pm

Koenkk wrote:Maybe you should try XBian (it has airplay support) http://xbian.blogspot.nl/
OpenELEC and RaspBMC have airplay (video (with audio) and pics only) since a long time ago so the distro is not the problem.

OP if Airplay is activated in the menus and the Webserver is enabled it should work out the box. However i did have one instance where it just stopped working, and the only fix was to reinstall. So maybe give that a try.

insanis
Posts: 2
Joined: Wed Aug 01, 2012 11:10 am

Re: How to get AirPlay working.....

Wed Aug 01, 2012 7:59 pm

Also struggling to make AirPlay work, i can connect to xbmc through airfoil on my Windows computer. But the xbmc screen goes black and says working for about 10sec before it returns to the usual front screen :/

HalfEvilHomer
Posts: 2
Joined: Tue Jul 31, 2012 7:27 pm

Re: How to get AirPlay working.....

Wed Aug 01, 2012 8:12 pm

Thanks, ive tried reinstalling it and still nothing worked, so my brother went back to a more stable build of the software and still no luck......i think he is going to change the OS anyway so ill see what the next one has instore!

Thanks for the help though, fingers x it works next time

migube
Posts: 29
Joined: Tue Jul 17, 2012 7:02 am

Re: How to get AirPlay working.....

Mon Aug 13, 2012 2:08 pm

hi guys,

I have issues too with Airfoil on Windows or synology to Airplay (it works to UPNP), it does not work with the ariplay on the Raspberry.
Webserver & Airplay are enabled & seen in airfoil

Did anyone get it to work?

tx

trouch
Posts: 310
Joined: Fri Aug 03, 2012 7:24 pm
Location: France
Contact: Website

Re: How to get AirPlay working.....

Mon Aug 13, 2012 2:33 pm

if you only need audio, you can install shairport on a vanilla Rabspian :
http://trouch.com/2012/08/03/airpi-airp ... raspberry/

WebIOPi - Raspberry Pi REST Framework to control your Pi from the web
http://store.raspberrypi.com/projects/webiopi
http://code.google.com/p/webiopi/
http://trouch.com

migube
Posts: 29
Joined: Tue Jul 17, 2012 7:02 am

Re: How to get AirPlay working.....

Mon Aug 13, 2012 4:06 pm

Aha, ok so I now understand xbmc is working only for Video ! (rather strange no ? :)
Will try your interesting link (as I'm now running raspbmc not the full debian one)!

Tx

trouch
Posts: 310
Joined: Fri Aug 03, 2012 7:24 pm
Location: France
Contact: Website

Re: How to get AirPlay working.....

Mon Aug 13, 2012 4:37 pm

some others users told there is an issue with sound drivers in RaspBMC/openELEC...

WebIOPi - Raspberry Pi REST Framework to control your Pi from the web
http://store.raspberrypi.com/projects/webiopi
http://code.google.com/p/webiopi/
http://trouch.com

tomi0529
Posts: 1
Joined: Thu Aug 16, 2012 4:26 pm

Re: How to get AirPlay working.....

Thu Aug 16, 2012 5:15 pm

Hi can someone help me? XBMC is Openelec.
I agreed but, unfortunately, the AirPlay did not want to go. What do I do?

ButWhy¿
Posts: 1
Joined: Wed Aug 29, 2012 9:21 am

Re: How to get AirPlay working.....

Wed Aug 29, 2012 9:31 am

Please help - cant figure out why my Airplay wont work, a am running Raspbmc RC4 XBMC 12.0Alpha5 Git2012084-f93511e compiled Aug 5 2012

I can connect to xbmc from my iphone (the icon appears) But when I select my Raspbmc as the Airplay source the xbmc screen goes black and says "working" for about 10sec before it returns to the usual front screen ... why? This only happens with Music and Video

However Youtube and Photos Airplay just fine?

Any Ideas?

dhead
Posts: 10
Joined: Fri Apr 06, 2012 4:31 am

Re: How to get AirPlay working.....

Wed Aug 29, 2012 2:53 pm

From the last time I checked XBMC Airplay feature is only enable on linux with the alsa sound driver.
Right now alsa driver for the SoC of the RPi isn't quite ready (but it is in development), so no Airplay on XBMC for the RPi, yet.

helander
Posts: 3
Joined: Sat Jul 28, 2012 9:33 am

Re: How to get AirPlay working.....

Wed Aug 29, 2012 5:24 pm

If you do not get the Pi to show up under the AirPlay icon on your client device, it could depend on your network. I have described the details and remedies on the Xbian forum (in the Bugs section).

Lars

brandscill
Posts: 1
Joined: Thu Aug 30, 2012 10:14 pm

Re: How to get AirPlay working.....

Thu Aug 30, 2012 10:15 pm

Got video working but not audio, any ideas?

TheTechnoTux
Posts: 2
Joined: Thu May 30, 2013 9:34 am

Re: How to get AirPlay working.....

Thu May 30, 2013 9:37 am

Similar issue here, but I can't even get video working.

AirPlay is turned on on the Pi, but when I try to stream it says "The operation could not be completed"

Any ideas? Maybe it just doesn't like Jeremy Clarkson (Top Gear).
Twitter: http://twitter.com/TheTechnoTux
YouTube: http://youtube/user/TheTechnoTux

In association with http://boffinbulletin.org.uk

Return to “Media centres”

Who is online

Users browsing this forum: No registered users and 10 guests