charlesanjos
Posts: 11
Joined: Tue Jul 03, 2012 4:14 am

Keyboard/Mouse not responding for Raspbmc and OpenELEC

Tue Jul 03, 2012 4:57 am

Hi, i've just tried to use Raspbmc on my R-Pi and it does not work properly. The problem is with the keyboard and mouse: everything works fine until few seconds after the XBMC is started. Then the mouse vanishes and the keyboard does not respond. Pressing numlock several times quickly makes the numlock light on and then much time later off then much time later on again and so forth until all my numlock key pressings were processed.

Have tried other distros with my Raspi and everything worked just fine. Only with this distro and OpenELEC this happens. Maybe some problem with XBMC.

Have also tried to start the Raspi without mouse, only keyboard, to see if this gets solved, but nothing.

Has anyone else seen this?

obarthelemy
Posts: 1399
Joined: Tue Aug 09, 2011 10:53 pm

Re: Keyboard/Mouse not responding for Raspbmc and OpenELEC

Tue Jul 03, 2012 5:50 am

This is often due to either (or both ^^) a bad power supply (power supplied much below advertised one),power cable (someone compared a lot of them to wet rope, not ideal for conducting electricity), keyboard (some have power requirements much higher than the 100mA the Pi can supply, this is never listed in their specs, and can vary by production batch for off-brands), or mouse (ditto). You've taken the mouse out of the equation, 3 more to go, if you have any way to switch these 3 around.
Just to be thorough, I'd also try another OS on another SD (Puppy looks like a good candidate), but that doesn't look like it.

Also, troubleshooting gide : http://elinux.org/R-Pi_Hub

charlesanjos
Posts: 11
Joined: Tue Jul 03, 2012 4:14 am

Re: Keyboard/Mouse not responding for Raspbmc and OpenELEC

Tue Jul 03, 2012 6:12 am

Yes, so long my research points to power source. Funny enough, the mouse/keyboard worked just fine with both archlinux and debian arm, both with LXDE.

I will try changing the power source nevertheless.

Thanks for the help!

charlesanjos
Posts: 11
Joined: Tue Jul 03, 2012 4:14 am

Re: Keyboard/Mouse not responding for Raspbmc and OpenELEC

Tue Jul 03, 2012 4:27 pm

Solved, it was my power source. Was using a 5v 500mA. Now switched to a 1A adapter, works just fine, thanks!

adi518
Posts: 27
Joined: Fri Jun 22, 2012 6:58 pm

Re: Keyboard/Mouse not responding for Raspbmc and OpenELEC

Fri Oct 05, 2012 6:57 pm

Sorry for bumping. I'm having the same issue. First few minutes I can use my keyboard.. all nice and dandy, then it suddenly stops responding. I tried a Dell usb keyboard which I believe is fully supported and two wireless keyboards that are known to be supported according to the Wiki.

My psu was bought from RS, along with the Pi. I read a lot of posts like this pointing the blame at the psu so I tried a Samsung micro usb charger, says 0.15A, outputs 5.0V. It works just like the original psu from RS and I get the same problem with the keyboards. I seriously think it's either my Pi that's faulty or the Raspbmc. I highly suspect it's the device being faulty as I can see the program is still running in the background while they keyboard is rendered useless.

metlos
Posts: 1
Joined: Mon Oct 15, 2012 10:27 pm

Re: Keyboard/Mouse not responding for Raspbmc and OpenELEC

Mon Oct 15, 2012 10:43 pm

I have the same problem as the above poster: The power supply from RS (5V and 1200mA) and Raspbmc looses keyboard and/or mouse after a varying period of time (but always less than 10minutes, usually just a couple of seconds).

max203
Posts: 1
Joined: Thu Nov 01, 2012 3:44 am

Re: Keyboard/Mouse not responding for Raspbmc and OpenELEC

Thu Nov 01, 2012 3:47 am

Same thing here. Keyboard and mouse works fine with Wizzy, no response on Raspbmc and hangs after 1 min on openelec.

I am using Apple charger which gives 5V 1A output.

Is there any way to debug/fix this issue?

chonsp
Posts: 1
Joined: Sun Nov 11, 2012 2:45 pm

Re: Keyboard/Mouse not responding for Raspbmc and OpenELEC

Sun Nov 11, 2012 3:36 pm

I think obarthelemey had it correct:
This is often due to either (or both ^^) a bad power supply (power supplied much below advertised one),power cable (someone compared a lot of them to wet rope, not ideal for conducting electricity), keyboard (some have power requirements much higher than the 100mA the Pi can supply, this is never listed in their specs, and can vary by production batch for off-brands), or mouse (ditto).
I also purchased only recommended peripherals from Elements14, and keyboard and mouse were working correctly in other distros.
To get OpenElec working again, I moved the wireless keyboard/mouse transmitter to the pi's motherboard and removed some unneeded devices from my 4 port usb hub.
Simplify first and then add devices back one by one.

User avatar
trib
Posts: 29
Joined: Tue Jul 17, 2012 9:32 am
Location: Krefeld, Germany

Re: Keyboard/Mouse not responding for Raspbmc and OpenELEC

Tue Nov 20, 2012 9:05 am

Hello,

as everybody before has mentioned, I´ve got the same issue.
Raspbian Wheezy workes like a charm and OpenElec or RaspBmc disconnect Mouse & Keyboard.
The AC got 1000m/Ah on 5Volts, so it shouldn´t be the point.
The difference must be in the derivative.
So my suggestion was the overclocking from XBMC. But the latest Raspbian version is overclocked, too. (It is even offically allowed)
So what causes this bad habit?

Greetings, Thomas

kevindsingleton
Posts: 1
Joined: Sat Dec 01, 2012 3:17 pm

Re: Keyboard/Mouse not responding for Raspbmc and OpenELEC

Sat Dec 15, 2012 10:20 pm

I get the same thing. The RasPi works fine, with Wheezy, but with OpenELEC or RaspBMC, I lose the display, the keyboard, and the mouse. There is one light illuminated (the red power light) on the board, and it takes a reboot to restore function. However, it could go down, again, in just a few minutes after rebooting the system. The distributions are not modified in any way. They are box-stock, and the board is hanging in free air, so there shouldn't be any heat problems. I've tried two keyboards, and two mouses, but the problem occurs (lost display, only one light) even if no keyboard, mouse, or display is attached. This is on a wired ethernet connection, and I've tried the setup both with, and without, a self-powered USB hub for the keyboard and mouse.

Also, just to make it more fun, I bought another RasPi, and it performs in exactly the same fashion, using the same SD cards for OpenELEC and RaspBMC systems. I wrote Wheezy to one of the cards, just to confirm, and it's been up for two days, without a hitch.

What gives?

djebrail
Posts: 3
Joined: Mon Dec 17, 2012 1:33 pm

Re: Keyboard/Mouse not responding for Raspbmc and OpenELEC

Mon Dec 17, 2012 1:42 pm

I'm also facing these kinds of problems. All I found out untill now is that with exactly the same hardware setup OpenELEC 2.95.5 worked for me with an 2gb SD card but not with an 1gb microSD with an Sandisk SDadapter ... even though it booted correctly, almost instantly after the system is up the mouse refuses to work, then the keyboaerd, it feels like as the system hangs ... have to check with network connection as well.

Dilligaf
Posts: 283
Joined: Wed May 23, 2012 6:48 pm

Re: Keyboard/Mouse not responding for Raspbmc and OpenELEC

Mon Dec 17, 2012 2:01 pm

11 posts and no one has bothered to check voltage? Surely at least a couple of you have a voltmeter, check voltage from TP1 to TP2 while the PI is booted and running, what does it read as your keyboard/mouse goes out? Are these all new PI or have they been in service for a while? There seems to have been a recent surge in defective PI

djebrail
Posts: 3
Joined: Mon Dec 17, 2012 1:33 pm

Re: Keyboard/Mouse not responding for Raspbmc and OpenELEC

Mon Dec 17, 2012 2:25 pm

4.7V with and without mouse/hdmi. variates during boot.

djebrail
Posts: 3
Joined: Mon Dec 17, 2012 1:33 pm

Re: Keyboard/Mouse not responding for Raspbmc and OpenELEC

Wed Dec 19, 2012 1:05 am

Oh well, after connecting via ssh I found out that the mouse was some sort of incompatible with the pi. A different one did it for me with OpenELEC-RPi.arm-devel-20121124031454-r12577.tar.bz2.

cheers.

Dilligaf
Posts: 283
Joined: Wed May 23, 2012 6:48 pm

Re: Keyboard/Mouse not responding for Raspbmc and OpenELEC

Wed Dec 19, 2012 1:33 am

4.7 is too low, usb spec calls for 4.75 minimum, get a stronger power supply

crh23
Posts: 8
Joined: Thu Jan 26, 2012 7:20 pm

Re: Keyboard/Mouse not responding for Raspbmc and OpenELEC

Wed Dec 26, 2012 3:55 pm

I get the same problem: Mouse disappears after a few seconds, no response from mouse or keyboard. They are both going through a Logitech unifying adaptor. I have used many other operating systems and my mouse/keyboard are fine with them.

I loaded up in raspian, got the CPU up to 100% load and measured the voltage across the test points: a stable 4.85v. I could ssh in and I tried workarounds found in a few other threads (reloading hid-logitech-dj and restarting xbmc and somthing else I can't remember).

I can't work out the problem.

LinusvanPelt
Posts: 4
Joined: Tue Oct 02, 2012 10:00 am

Re: Keyboard/Mouse not responding for Raspbmc and OpenELEC

Fri Jan 04, 2013 5:07 pm

I can install raspbmc but neither mouse nor keyboard function. I am using an Apple keyboard and have tried several mice. The power supply should be supplying the correct amount but am willing to swap out all of these peripherals to test. Can anyone recommend a known good keyboard, mouse and power supply?

heshanh
Posts: 1
Joined: Tue Mar 19, 2013 8:58 am

Re: Keyboard/Mouse not responding for Raspbmc and OpenELEC

Tue Mar 19, 2013 11:42 am

I have a similar issue.

I'm using the latest rspbmc and openelec.
keyboard is k400.
TV is samsung 42in tv


- When i plug the hdmi cable to my spare LG 24in lcd screen the keyword works fine.

- When i plug the hdmi to my Yamaha receiver/amp I can see the mouse cursor when the xmbx home screen loads, but as soon as the rest of the UI loads it disappears and the keyboard stops from working.
(rasp HDMI out goes to the amp -> amp sends the HDMI to the TV)

- When i plug the hdmi output directly to the TV the screen starts flickering from boot (big red raspberry logo shows us) and still not keyboard controls.


This is what i tried.
-mix of 3 different HDMI cables
-2 different SD cards
-2 different power adapters (5v 1a & 5v 1.2a)
-disabling the CEC addon (on the first few attempts mouse cursor disappeared right after "pulse eight cec" notification)

psjr
Posts: 1
Joined: Sun May 05, 2013 3:09 am

Re: Keyboard/Mouse not responding for Raspbmc and OpenELEC

Sun May 05, 2013 3:11 am

Having same issues. I thought a powered USB hub might fix it but it has not.

pearlmam
Posts: 2
Joined: Sat Mar 23, 2013 4:13 pm

Re: Keyboard/Mouse not responding for Raspbmc and OpenELEC

Tue May 07, 2013 7:16 am

I am having the unresponsive keyboard issue with Raspbmc as well. I am using a unifying receiver with the Logitech Mini. Most of the time it works but occasionally it wont. My current solution is to ssh in and restart XBMC. After this, it will work, but it is still a toss up if it will work on a reboot.

I have checked the power. No lower than 4.92V. I have a hub as well, with nothing plugged into the Pi, the same issue occurs. I wish it was a power issue, but i really don't think that is the case here. Raspbian works 100% of the time.

Raspbmc loads the keyboard correctly, but the error is either with xbmc or the startup priorities. XBMC does not auto detect, it only detects usb on startup. Either there is an error loading the keyboad on startup, or the mouse isn't loaded yet when xbmc is started. This is my working theory. I dont know how xbmc gets started in raspbmc. I am familiar with rc.d services and startup priorities, but xbmc is not there. Where else would it be? How is it started? A workaround may be just to either restart xbmc every time on startup (lame), or pausing the startup of xbmc for a little bit.

Any Ideas

pearlmam
Posts: 2
Joined: Sat Mar 23, 2013 4:13 pm

Re: Keyboard/Mouse not responding for Raspbmc and OpenELEC

Wed May 15, 2013 5:43 am

Ok, I think I solved the issue. The problem is that the keyboard doesn't always load correctly upon startup. By sshing in, the keyboard loads for some reason, and that's why sshing in and restarting xbmc works. I confirmed this by looking at dmesg before and after sshing in (I think, its been a long night).

The work around:
Raspbmc uses upstart to start the xbmc service. The upstart daemons are located in /etc/init/. The .conf files are all services. The workaround is to create a dummy service to restart the logictek driver, and then have xbmc service start after the dummy service is done.

Start up the pi, and ssh in if you can, default password is "raspberry" I think. If you can't ssh in and your keyboard doesn't work then you have a problem. You might want to put the sd card into a reader on another computer, and modify the files from there.

Code: Select all

ssh pi@192.168.0.2
create new service

Code: Select all

sudo nano /etc/init/dummy.conf
enter the following:

Code: Select all

start on (started dbus and started mountall)
task
script
  #restart the keyboard
  modprobe -r hid_logitech_dj
  sleep 2
  modprobe hid_logitech_dj
  sleep 2
end script
edit the xbmc.conf

Code: Select all

sudo nano /etc/init/xbmc.conf
replace the line

Code: Select all

start on (started dbus and started mountall)
with

Code: Select all

start on (started dbus and started mountall and stopped dummy)
now reboot

Code: Select all

sudo reboot
I think that will do it, only time will tell. I've only restarted it a few times.

wrietvel
Posts: 1
Joined: Fri Jun 14, 2013 1:33 pm

Re: Keyboard/Mouse not responding for Raspbmc and OpenELEC

Fri Jun 14, 2013 1:41 pm

I changed the method a bit: I took the script part of your solution and embedded it just before the 'end script' at the end of the xbmc.conf file. Now everything works fine, also with much faster keyboard reaction.
In my configuration it was definitely NOT a power problem, with 2000mA power supply and a powered keyboard through a powered usb-hub. I tried all sorts of set-ups and nothing worked, until now. Brilliant approach, love it!!!

redneck
Posts: 1
Joined: Fri Sep 06, 2013 6:39 am

Re: Keyboard/Mouse not responding for Raspbmc and OpenELEC

Fri Sep 06, 2013 6:45 am

@pearlman: Two days ago I bought a RPi, went into this troubles and have now registered here to thank you for your solution.

Yellrag
Posts: 1
Joined: Wed Mar 05, 2014 2:17 pm

Re: Keyboard/Mouse not responding for Raspbmc and OpenELEC

Wed Mar 05, 2014 2:51 pm

Hello peeps,

After some reading and understanding this power issue,
I'd like to add that another source of problem is the sophistication of your peripherals :
My Steelseries Apex keyboard requires way too much power to even be detected by the RPi
My Logitech G300 and G600 mouses are detected, there is a cursor that I can move (laggily), but clicks are not working :D
Had to borrow my neighbors' 10€ Microsoft mouse to test it out a minimum.

NessyBomber
Posts: 1
Joined: Tue Oct 07, 2014 3:31 am

Re: Keyboard/Mouse not responding for Raspbmc and OpenELEC

Tue Oct 07, 2014 3:35 am

I am having this problem too. I know that the problem is not the keyboard or mouse because it worked perfectly when using raspian. And i also know its not power, because i am using a stable 5v power supply. When i put openELEC on it and turned it on, everything was fine, and then it seemed that all the usb ports stopped working.

Return to “Media centres”

Who is online

Users browsing this forum: No registered users and 4 guests