WhyNine
Posts: 39
Joined: Thu May 30, 2019 7:00 pm

TVheadend as SAT>IP server not working

Fri Feb 07, 2020 6:10 pm

I am trying to get tvheadend to work as a SAT>IP server with the TV Hat on an RPi3.

After installing tvheadend, I can find the local Freeview channels using the TV Hat, so everything is basically working. I then set the SAT>IP source number for the network to 1, the number of exported DVB-T tuners to 1 and the RTSP port to 554 (also tried 9983 with same result). The log reports:

Code: Select all

2020-02-07 17:19:28.664 satips: RTSP port 554 specified but no root perms, using 9983
2020-02-07 17:19:28.664 satips: SAT>IP Server reinitialized
2020-02-07 17:19:28.664 satips:   HTTP 192.168.1.142:9981, RTSP 192.168.1.142:9983
2020-02-07 17:19:28.664 satips:   descramble 1, muxcnf 0
2020-02-07 17:19:28.664 satips:   tuner[fe=1]: DVB-T #1
Using tvheadend on another RPi, I can't disover the first RPi3. I have also tried VLC and DVBViewer, neither of which can discover it either.

What am I doing wrong?

my-pi-x
Posts: 23
Joined: Thu May 28, 2020 8:22 pm

Re: TVheadend as SAT>IP server not working

Wed Aug 05, 2020 5:12 pm

Still not working as "SAT>IP Server" ...

Code: Select all

Device:		cat /sys/firmware/devicetree/base/model
				Raspberry Pi 3 Model B Plus Rev 1.3
				

Code: Select all

OS: 		cat /etc/*release
				PRETTY_NAME="Raspbian GNU/Linux 10 (buster)"
				

Code: Select all

Kernel:		uname -a 
				Linux ... 5.4.51-v7+ #1327 SMP Thu Jul 23 10:58:46 BST 2020 armv7l GNU/Linux

Code: Select all

TVheadend:	tvheadend --version
				tvheadend: version 4.2.8-34~g24a2f59e9
First SAT>IP Server: Panasonic-TV (Second SAT-Tuner/Astra 19° and Hotbird 13° East via Diseqc)

First SAT>IP Client: TVHeadend

Working fine. All Programms and all Epg-Data ... All these I can grep with Kodi with the HTS-Plugin on another PI with Kodi.

And here is my Problem:

Second SAT>IP Server: TVHeadend

Not working - TVHeadend is not showing an UUID.

Also on this Pi with Rasbpian I deleted/purged sudo.

TVHeadend was configured with root.

TVHeadend is running in a local network only (no internet)

Code: Select all

Listen Services: netstat -tulpen

	tcp        0      0 0.0.0.0:9981		0	... 	432/tvheadend
	tcp        0      0 0.0.0.0:9982		0	... 	432/tvheadend
	udp        0      0 239.255.255.250:1900	109	... 	432/tvheadend
	udp        0      0 0.0.0.0:51018		109	... 	432/tvheadend

Code: Select all

User:		hts:x:109:114::/home/hts:/bin/bash
group:		hts:x:114:
Is this maybe my problem?

My intention was/is to offer other "SAT>IP"-Clients, for exp. via HLS, VOD or nearly-VOD.

Thanks for help!

Btw.:

https://tvheadend.org/boards/5/topics/40569

Ogoshi
Posts: 46
Joined: Wed Dec 28, 2011 5:13 pm
Location: Southend-on-Sea, Essex, England

Re: TVheadend as SAT>IP server not working

Fri Aug 28, 2020 2:34 pm

Have you restarted tvheadend service after enabling it as a sat>ip server? That's all I needed to do

Return to “Media centres”