User avatar
Goldylocks
Posts: 2
Joined: Wed Sep 13, 2017 10:24 am
Location: The Netherlands

LCD Screen colour problem

Wed Sep 13, 2017 10:43 am

Hello,

I'm new to the raspberry scene, so I'm hoping this is rookie mistake somewhere in the settings, but I'm not too sure. Hence I'm here and asking for a second opinion.

My set up is the following:
  • Raspberry Pi 3 Model B
  • New LCD Controller board kit for 15"6-screens
  • New laptop screen (15"6 inch)
  • HDMI Connected
The problem is when I boot up, the text looks good. The colors on the raspberry on the top are already "off".
When I'm on the homescreen and anything else, all the colors look off. I'm not sure if this is due to a faulty setting or that there is a problem within my controller board or perhaps a faulty wire/cable. And before I start buying new parts (and wait a couple of week on shipping) I would like to make sure I'm replacing the good parts, instead of ending up with two of everything and still the same issue.

I've already tried the HDMI_Boost setting, framebuffer_depth = 24, update and upgrade the entire raspberry through console, but nothing seems to do the trick.

I've attached a few pictures to better show my problem.
So basically my question is: what is causing this problem?
Wrong/faulty lcd-board, wrong cable, or perhaps a wrong voltage/ampere?

Image
Image
Image
Image

Hope someone can help,
Thanks in advance,

G.
Last edited by Goldylocks on Wed Sep 13, 2017 4:42 pm, edited 1 time in total.

fa001
Posts: 80
Joined: Wed Jan 02, 2013 8:25 pm

Re: Screen problem

Wed Sep 13, 2017 3:59 pm

You say that it is HDMI connected. So you can eliminate possible pi issues by connecting some other "good" HDMI source such as video. If another source shows the same issues than it is most likely the controller board setup.

jamesh
Raspberry Pi Engineer & Forum Moderator
Raspberry Pi Engineer & Forum Moderator
Posts: 18036
Joined: Sat Jul 30, 2011 7:41 pm

Re: LCD Screen colour problem

Wed Sep 13, 2017 4:25 pm

For some reason, malwarebytes is rejecting the links to images in the OP. You might wish to relocate them somewhere that doesn't fire off a malware checker.

EDIT: Apparently, preview.ibb.co, the problem site, has been found to contain ransomware etc, so probably best not to use it.
Principal Software Engineer at Raspberry Pi (Trading) Ltd.
Please direct all questions to the forum, I do not do support via PM.

User avatar
Goldylocks
Posts: 2
Joined: Wed Sep 13, 2017 10:24 am
Location: The Netherlands

Re: Screen problem

Wed Sep 13, 2017 4:48 pm

jamesh wrote: For some reason, malwarebytes is rejecting the links to images in the OP. You might wish to relocate them somewhere that doesn't fire off a malware checker.

EDIT: Apparently, preview.ibb.co, the problem site, has been found to contain ransomware etc, so probably best not to use it.
Oh, sorry bout that. Didn't know it had ransomware. Tried uploading them as attachments but the file sizes are too big, so instead I used LightShot, hope that is better. -- edited original post --
fa001 wrote:
Wed Sep 13, 2017 3:59 pm
You say that it is HDMI connected. So you can eliminate possible pi issues by connecting some other "good" HDMI source such as video. If another source shows the same issues than it is most likely the controller board setup.
Oh wow, not sure why I didn't think of this solution yet. Got it hooked up to my laptop as we speak and unfortunately it does still show the same problem. So that atleast rules out the Raspberry Pi and its settings/configuration.

Is there any way to determine if it's faulty wires or do I just have to order a new LCD Board? Or is it possible to find the issue and solve it? Cause the LCD Board kit was newly ordered and unused.

Thanks for the help thusfar!
Hope I am still allowed to get help here eventhough the Pi got ruled out.

G.

aBUGSworstnightmare
Posts: 573
Joined: Tue Jun 30, 2015 1:35 pm

Re: LCD Screen colour problem

Thu Sep 14, 2017 4:58 am

Are you sure your LCD controller is configured correctly? Which resolution do you use btw. and what are your config.txt settings?

Return to “Media centres”

Who is online

Users browsing this forum: No registered users and 6 guests