Heater
Posts: 14459
Joined: Tue Jul 17, 2012 3:02 pm

Re: Need a Mono upgrade

Wed Sep 07, 2016 7:07 am

I would advise against the instructions in the above post unless you are still running the old wheezy version of Raspbian.

Also note that it is fetching Ubuntu packages. I would advise against adding "foreign" repositories to ones Raspbian apt sources.

Such actions have a habit of messing up the package dependencies of your system.

Of course it may well work in this case.Just be careful and prepared for getting your system hosed when you do this kind of thing.
Last edited by Heater on Fri Apr 21, 2017 3:07 pm, edited 1 time in total.
Memory in C++ is a leaky abstraction .

mb99
Posts: 13
Joined: Mon Jun 13, 2016 3:47 am

Re: Need a Mono upgrade

Fri Sep 16, 2016 11:08 pm

I am using the https://www.raspberrypi.org/downloads/raspbian/ and follow the instructions in http://www.mono-project.com/docs/gettin ... erivatives. I get the latest version of mono without any problems.

hakanl
Posts: 15
Joined: Tue Jun 26, 2012 4:53 am

Re: Need a Mono upgrade

Tue Oct 04, 2016 10:14 pm

Be careful when you read the replies to this topic, some applies to Raspberry Pi 1, some to 2+. The instructions are different and if you use the mono-project repo on your RPi1 then it will crash mono completely (illegal instruction exception). The only way to get mono on a RPi1 is to build it yourself, or use the plugwash raspbian repo. I just confirmed that again today on latest Raspbian Jessie.

Ponunu
Posts: 2
Joined: Fri Oct 07, 2016 4:13 pm

Re: Need a Mono upgrade

Fri Oct 14, 2016 4:17 pm

Here's also a post on Wine Mono on RPi:
https://eltechs.com/mono-raspberry-pi/

dslocum
Posts: 5
Joined: Sat Oct 22, 2016 7:13 pm

Re: Need a Mono upgrade

Fri Nov 04, 2016 2:08 pm

asandford wrote:
gurabli wrote: Sorry for the noob question, but how do I install Mono4 using the above? I also don't know if I need wheezy or jessie, as I tend to use both. I'm using Minibian latest atm.

Can you please guide me a little? I added wheezy to source, and installed but the version I got is 3.2.8

Thanks!
Try this

Code: Select all

sudo su -
echo "deb http://plugwash.raspbian.org/mono4 wheezy-mono4 main" >> /etc/apt/sources.list
apt-get update
apt-cache search mono-4
mono-4.0-gac - Mono GAC tool (for CLI 4.0)
mono-4.0-service - Mono service manager for CLI 4.0
[email protected]:~#

I've done this (I'm a super Noob) and it didn't fix the textbox issue. Any other suggestions are VERY welcome.

Thanks!

raspdealer
Posts: 9
Joined: Tue Jun 09, 2015 8:28 pm

Re: Need a Mono upgrade

Wed Nov 16, 2016 1:20 pm

Hi guys,

Thanks for ALL these advises and information. As it's pretty old, can someone tell me what is the best way to get the latest stable Mono version on Pi1 and to keep it up to date?

Same question for Pi2.

Regards,

R

xfx
Posts: 24
Joined: Thu Dec 06, 2012 10:09 pm

Re: Need a Mono upgrade

Fri Nov 25, 2016 5:24 am

Thank you so much for all the effort!

One question though: any chance to support mono-vbnc?

When trying to install it I get:

Code: Select all

The following packages have unmet dependencies:
 mono-vbnc : Depends: libmono-microsoft-visualbasic11.0-cil (= 3.8-1) but it is not going to be installed
             Depends: libmono-corlib2.0-cil (>= 3.2.8) but it is not going to be installed
             Depends: libmono-microsoft-visualbasic8.0-cil (>= 2.99) but it is not going to be installed
E: Unable to correct problems, you have held broken packages.

sgtpepper
Posts: 12
Joined: Tue Apr 05, 2016 8:55 pm

Re: Need a Mono upgrade

Fri Dec 16, 2016 7:25 pm

Hey,

Just wanted to let people know I've successfully managed to install Mono 4.4.2.11 on a Raspberry Pi 1 Model B. Due to Mono needing to be bootstrapped during the MCS process, I believe you'll need to install the version provided by plugwash (Mono 4) initially as the version currently in the stable repository has an outdated version of MCS. Following this you'll be able to install a later version.

I grabbed the 4.4.2.11 tarball from https://download.mono-project.com/sources/mono/ using wget and then followed the build instructions here http://www.mono-project.com/docs/compiling-mono/linux/.

I installed the new version in /opt/mono. Following install, I followed the instructions here: http://www.mono-project.com/docs/compil ... ironments/ but as I didn't have a desktop environment installed, I stripped out the parts mentioning $GNOME_PREFIX.

Seems to be working a treat so far, and is a viable alternative until a later version is pushed into the stable repository.

hakanl
Posts: 15
Joined: Tue Jun 26, 2012 4:53 am

Re: Need a Mono upgrade

Fri Dec 16, 2016 8:45 pm

I think you can build mono4 on RPi1 with mono 3.x from the official repos though, but other than that yes that's the way to get it done, takes hours though :)

loupiz
Posts: 2
Joined: Tue Apr 18, 2017 8:33 am

Re: Need a Mono upgrade

Tue Apr 18, 2017 9:09 am

Hi,

I'm trying to install mono on my new resperry zero. I 'm using the latest raspian lite. I have followed these steps :

Code: Select all

1. sudo apt-key adv --keyserver hkp://keyserver.ubuntu.com:80 --recv-keys 3FA7E0328081BFF6A14DA29AA6A19B38D3D831EF
2. echo "deb http://plugwash.raspbian.org/mono4 jessie-mono4 main" >> /etc/apt/sources.list
3. sudo apt-get update 
4. sudo apt-get install mono-complete
The following error immediatelly shows up :

Code: Select all

The following packages have unmet dependencies:
 mono-complete : Depends: mono-devel (= 4.8.1.0-0xamarin1) but it is not going to be installed
                 Depends: mono-4.0-service (= 4.8.1.0-0xamarin1) but it is not going to be installed
                 Depends: monodoc-manual (= 4.8.1.0-0xamarin1) but it is not going to be installed
                 Depends: libmono-cil-dev (= 4.8.1.0-0xamarin1) but it is not going to be installed
E: Unable to correct problems, you have held broken packages.
Does anyone can help me with that ?

Thanks

loupiz
Posts: 2
Joined: Tue Apr 18, 2017 8:33 am

Re: Need a Mono upgrade

Tue Apr 18, 2017 12:56 pm

I solved my problem removing all sources from sources.list except

Code: Select all

deb http://plugwash.raspbian.org/mono4 jessie-mono4 main
Then running

Code: Select all

sudo apt-get install mono-runtime
instead of

Code: Select all

sudo apt-get install mono-complete

Return to “Other programming languages”