mob-i-l
Posts: 266
Joined: Sat Dec 29, 2012 2:45 am
Location: Lund, Skåne/Scania, Sweden
Contact: Website Facebook Google+ Twitter YouTube

RPi::WiringPi is not found despite being linked to

Sat Jun 22, 2019 6:38 pm

RPi::WiringPi is not found despite being linked to:
https://metacpan.org/pod/RPi::WiringPi

This exists: https://metacpan.org/release/RPi-WiringPi
but should the POD not exist?
Have Pi0&1A&1B&1B+&2B&3B&4B w/ Raspbian. Started w/ BASIC on ABC80&ZX81 then Forth, Z80… https://scratch.mit.edu/users/mobluse/ https://github.com/mobluse/ https://twitter.com/mobluse/ https://YouTube.com/MOBiL4u/

stevieb9
Posts: 15
Joined: Fri Jan 13, 2017 2:40 pm

Re: RPi::WiringPi is not found despite being linked to

Sun Jun 23, 2019 4:41 pm

I'm the author of RPi::WiringPi.

Can you please explain by what you mean by "not found"? What's not found, the actual module? How did you install it? Can you share the script you're using that fails?

User avatar
John_Spikowski
Posts: 1334
Joined: Wed Apr 03, 2019 5:53 pm
Location: Anacortes, WA USA
Contact: Website Twitter

Re: RPi::WiringPi is not found despite being linked to

Sun Jun 23, 2019 5:15 pm

I'm the author of RPi::WiringPi.
I though Gordon was the author of WiringPi.

stevieb9
Posts: 15
Joined: Fri Jan 13, 2017 2:40 pm

Re: RPi::WiringPi is not found despite being linked to

Sun Jun 23, 2019 5:17 pm

ScriptBasic wrote:
Sun Jun 23, 2019 5:15 pm
I though Gordon was the author of WiringPi.
*RPi::WiringPi*. It's a high level Perl distribution that uses my WiringPi::API, another Perl distribution which directly wraps Gordon's wiringPi.

User avatar
John_Spikowski
Posts: 1334
Joined: Wed Apr 03, 2019 5:53 pm
Location: Anacortes, WA USA
Contact: Website Twitter

Re: RPi::WiringPi is not found despite being linked to

Sun Jun 23, 2019 5:28 pm

Okay. Thanks for the clarification. I wrapped Gordon's library as well for ScriptBasic as an extension module.

That is some serious indirection going on.

Return to “Other programming languages”