clomas
Posts: 1
Joined: Wed Jan 17, 2018 11:05 pm

pi web server - phpmyadmin (IIS) perfomance issues

Wed Jan 17, 2018 11:41 pm

Hello, I have a web server on my Raspberry pi 3, running php 5.6, and an IIS server that has a phpmyadmin database. I query the SQL database to retrieve data and that works instantaneously, but when I query the database to create databases/tables, it can sometimes take longer than 10 minutes, some queries don't make it to the database. it's the strangest issue.

The database is not locked, there are no previous connections, they are all dealt with appropriately and closed. Both servers are on the same VLAN.I can still use mysql from the command line on the raspberry pi with no issues.

Does anyone have any idea what could be the issue? It seems to be something related to the raspberry pi.

Web server (copied from phpmyadmin):
Microsoft-IIS/8.0
Database client version: libmysql - mysqlnd 5.0.12-dev - 20150407
PHP version: 7.0.21

Heater
Posts: 9826
Joined: Tue Jul 17, 2012 3:02 pm

Re: pi web server - phpmyadmin (IIS) perfomance issues

Fri Jan 19, 2018 11:00 pm

clomas,
I have a web server on my Raspberry pi 3...
What web server? Apache? Nginx? Other?
...and an IIS server...
That is on a Windows PC I guess. This is not the right place to ask about Windows software. MS has a big enough help site of it's own.
...I query the SQL database...
What SQL database? On the Pi or on the Windows machine? Is it MySql, MariaDb, Postgresql, other ?
Does anyone have any idea what could be the issue?
Not me. You do not describe what you are doing sufficiently.

10 minutes to get a response from a database is crazy. But we have no idea what you are doing there.

Return to “Other programming languages”

Who is online

Users browsing this forum: No registered users and 6 guests