Cenbe
Posts: 2
Joined: Fri Jul 20, 2012 9:50 pm

ejre-7u4 and Raspbian

Fri Jul 20, 2012 10:02 pm

I had Oracle's ejre-7u4 working under the Wheezy beta, but when I switched to Raspbian, I get this when I call "java -version":

java: error while loading shared libraries: libjli.so: cannot open shared object file: No such file or directory

Anybody have any ideas? The JRE extracted correctly, and libjli.so exists within the extracted directory.

neaso
Posts: 5
Joined: Sat Jul 21, 2012 8:54 pm

Re: ejre-7u4 and Raspbian

Sat Jul 21, 2012 8:55 pm

I just hit this same problem, using the ejre-6. Will keep you informed of my progress.

neaso

neaso
Posts: 5
Joined: Sat Jul 21, 2012 8:54 pm

Re: ejre-7u4 and Raspbian

Sat Jul 21, 2012 9:33 pm

I am having the same issue on Raspbian. Trying out a debian image. When I ran `strace java` after symlinking the lib into /usr/lib/ it would read it be still abort. Weird

Gibble
Posts: 56
Joined: Wed May 09, 2012 9:52 am

Re: ejre-7u4 and Raspbian

Sat Jul 21, 2012 9:55 pm

I know nothing of Java, but I think the Rasp based images are compiled differently (due to hard vs soft float ?), so my guess would be that .so files downloaded may not work, and may need to be compiled for Raspbian.

I may be wrong, but in the absence of a differently reply, it may be worth looking into seeing if thats an option (any different compiled version available for example ?).

neaso
Posts: 5
Joined: Sat Jul 21, 2012 8:54 pm

Re: ejre-7u4 and Raspbian

Sat Jul 21, 2012 10:22 pm

There is a discussion over here http://www.raspberrypi.org/phpBB3/viewt ... 66&t=11671 and at http://ac31004.blogspot.com/2012/07/jav ... ebian.html

It looks like the hard float settings on Raspian are preventing the ejre from loading. There should be a way to load soft float code on a hard float system

Cenbe
Posts: 2
Joined: Fri Jul 20, 2012 9:50 pm

Re: ejre-7u4 and Raspbian

Sun Jul 22, 2012 12:58 am

Yes, I found that first link right after posting. If ejre isn't going to run on Raspbian, then I'm not going to be running Raspbian. I went back to the Wheezy beta that had been in the download section previously. Does anyone know if that version is still going to be worked on?

neaso
Posts: 5
Joined: Sat Jul 21, 2012 8:54 pm

Re: ejre-7u4 and Raspbian

Sun Jul 22, 2012 4:22 am

I am currently running ejre 1.6 on archlinux. It is working ok.

Return to “Other programming languages”