realtebo
Posts: 37
Joined: Tue Apr 30, 2013 11:56 am

I need php55-openssl. How to install?

Mon Feb 23, 2015 2:53 pm

I needed php55 so I upgraded to jessie.

But when I find I need also php55-openssl I got a problem

Code: Select all

pi@raspberrypi ~ $ sudo apt-get install php55-openssl
Lettura elenco dei pacchetti... Fatto
Generazione albero delle dipendenze
Lettura informazioni sullo stato... Fatto
E: Impossibile trovare il pacchetto php55-openssl
There is no a php55-openssl package... Oh... no .. and now?

realtebo
Posts: 37
Joined: Tue Apr 30, 2013 11:56 am

I need php55-openssl. How to install?

Mon Feb 23, 2015 3:00 pm

In the repo there isn't my needed php55-openssl package.

... how can I get it installed?

Also, I've already tried dist-upgrade to jessie, and php55-openssl is not found in the repo

User avatar
abishur
Posts: 4477
Joined: Thu Jul 28, 2011 4:10 am
Location: USA
Contact: Website

Re: I need php55-openssl. How to install?

Mon Feb 23, 2015 3:10 pm

Mod edit: Merged duplicate topics
Dear forum: Play nice ;-)

-rst-
Posts: 1316
Joined: Thu Nov 01, 2012 12:12 pm
Location: Dublin, Ireland

Re: I need php55-openssl. How to install?

Tue Feb 24, 2015 5:03 pm

http://raspberrycompote.blogspot.com/ - Low-level graphics and 'Coding Gold Dust'

realtebo
Posts: 37
Joined: Tue Apr 30, 2013 11:56 am

Re: I need php55-openssl. How to install?

Wed Feb 25, 2015 6:35 pm

So, if it's ot builtin the php, we cannot use openssl.. right?

-rst-
Posts: 1316
Joined: Thu Nov 01, 2012 12:12 pm
Location: Dublin, Ireland

Re: I need php55-openssl. How to install?

Thu Feb 26, 2015 4:15 pm

Is OpenSLL not part of the Apache (or whatever web server) you run PHP on?

http://www.debianadmin.com/install-and- ... -etch.html ...or is PHP5.5 somehow different?
http://raspberrycompote.blogspot.com/ - Low-level graphics and 'Coding Gold Dust'

User avatar
rpdom
Posts: 17402
Joined: Sun May 06, 2012 5:17 am
Location: Chelmsford, Essex, UK

Re: I need php55-openssl. How to install?

Thu Feb 26, 2015 4:23 pm

OpenSSL support seems to be built in to the PHP used on Rasbian. There isn't a separate package for it.

Code: Select all

pi@raspi3 ~ $ echo "<?php phpinfo();?>" | php | grep -i ssl
Registered Stream Socket Transports => tcp, udp, unix, udg, ssl, sslv3, tls, tlsv1.0, tlsv1.1, tlsv1.2
openssl
OpenSSL support => enabled
OpenSSL Library Version => OpenSSL 1.0.1k 8 Jan 2015
OpenSSL Header Version => OpenSSL 1.0.1k 8 Jan 2015
openssl.cafile => no value => no value
openssl.capath => no value => no value
OpenSSL support => enabled

Return to “Other programming languages”