126 posts   Page 3 of 6   1, 2, 3, 4, 5, 6
by mpthompson » Wed Aug 29, 2012 6:12 am
I looked into creating a new Gambas3 Debian package for version 3.2.1, but it's more involved than I have the time or experience to deal with. If someone interested in Gambas3 is motivated to help out, I would suggest sending an email to the Debian maintainer for the Gambas3 and ask them if a Debian package based on version 3.2.1 is already created (ideally for armhf) or if one can be created soon. The email address is:

The web page for the Debian Gambas3 package is here:

This may have some other information to help with getting a new package created. Once there is a Debian package for Gamebas3 version 3.2.1, please let me know and I'll make sure it gets into the Raspbian repository.

Sorry I couldn't get the package done myself, but I hope this helps someone who can help nudge the Debian folks to create an updated Gambas3 package.
User avatar
Posts: 620
Joined: Fri Feb 03, 2012 7:18 pm
Location: San Carlos, CA
by kru64 » Sat Sep 22, 2012 8:52 pm
Hi g4eml
Please upload your file again.
The link now is empty
Thank You
Posts: 23
Joined: Tue Aug 28, 2012 8:57 am
by g4eml » Wed Sep 26, 2012 11:44 am
Hi kru64..

I have uploaded the Gambas 3.2.1 update files to wikisend

As mentioned before, first install the raspbian version of Gambas3 from the repositiory (which won't run) then overwrite the installed files with those in this download.

Posts: 56
Joined: Wed Oct 05, 2011 1:50 pm
by kru64 » Fri Sep 28, 2012 7:00 pm
Hi g4eml.
Your method works well.
First I installed Synaptic. Then with the help of Synaptic I installed Gambas3. Then I copied Your files and voila! Gambas run!
Posts: 23
Joined: Tue Aug 28, 2012 8:57 am
by g4eml » Fri Sep 28, 2012 10:27 pm
I'm glad it worked for you. Gambas3 works quite well on the Pi. I have used it for several projects so far.
Posts: 56
Joined: Wed Oct 05, 2011 1:50 pm
by NickE » Sun Sep 30, 2012 9:20 pm
Has anyone gotten this to work using the 9-18 Wheezy update by "sudo apt-get install gambas3" and then overwriting the files that g4eml has posted? I am getting Error #2 saying the "bytecode is too recent" and to update Gambas3.

Any help would be appreciated.
Posts: 3
Joined: Sun Sep 09, 2012 5:50 pm
by g4eml » Mon Oct 01, 2012 10:32 pm
Hi NickE

I have had it working on the 18-09 raspbian image with no problem. But I did overwrite using my
original files and did not try downloading them again. I am not near my Pi again until the weekend
I will try it with the downloaded files then.

If I get the time I will try to write a script to automate the updating of the files.

Posts: 56
Joined: Wed Oct 05, 2011 1:50 pm
by g4eml » Sat Oct 06, 2012 8:39 pm
Hi NickE

I have just downloaded and tested the Gambas 3.2.1 patch on a fresh install of Raspbian 18-09-12 and it worked fine.

However, to simplify the procedure a little I have uploaded the same files with a small script file to to the overwriting. The following procedure should give you a working Gambas 3.

This was done on a fresh install of Raspbian 18-09-12 with the file system expanded to the whole SD card.

log in as pi
start the LXDE Desktop (startx)
then use midori to download and save the patch file from
(I tried to do this using wget from the command line but couldn't get it to work)

Logout from LXDE to get back to the command line then enter the following commands....

Code: Select all
sudo apt-get update
sudo apt-get install gambas3
tar -xvf Gambas_3-2-1_Patch.tar.bz2
cd Gambas_3-2-1_Patch

Having done this you should be able to restart the desktop and run Gambas3 from the Programming section of the start menu.

.... Colin
Posts: 56
Joined: Wed Oct 05, 2011 1:50 pm
by wally » Wed Oct 10, 2012 1:00 pm
i think the patch-approach is not the real thing because it does not allow
updates. Gambas3 is updated daily and interesting changes occur.
I did not met unsolvable problems to use svn on RPI.
Maybe this is helpful:

Code: Select all
sudo apt-get update
sudo apt-get upgrade

sudo apt-get install subversion

sudo apt-get install gcc g++ automake autoconf libtool libffi-dev

sudo apt-get install libgnome-keyring-dev libxtst-dev libgtk2.0-dev libsvga1-dev libgtkglext1-dev

sudo apt-get install libcairo2 libcairo2-dev libbz2-dev unixodbc-dev libgsl0-dev librsvg2-dev

sudo apt-get install libgtk2.0-dev libsvga1-dev   libgtkglext1-dev libimlib2-dev libcurl4-gnutls-dev
sudo apt-get install libqtcore4 libqtgui4 libqxt-core0 libqt4-dev libqt4-opengl-dev libv4l-dev libjpeg8-dev libpng12-dev

sudo apt-get install libsdl-ttf2.0-dev libsdl-sound1.2-dev libsdl-mixer1.2-dev libsdl-image1.2-dev libsdl1.2-dev libdirectfb-dev libimlib2-dev libtiff4-dev

sudo apt-get install libpoppler-dev libpoppler-cpp-dev libpoppler-glib-dev libpoppler-private-dev libpoppler-qt4-dev                                 

sudo apt-get install libgstreamer0.10-dev libqtgstreamer-dev libgstreamer-ocaml-dev

sudo apt-get install libgmime-2.6-dev

sudo apt-get install libglew-dev libxslt1-dev libsqlite3-dev libpq-dev libmysqlclient-dev

of course you can put all packages in a single apt-get command
not sure about 'libgstreamer-ocaml-dev' , needs gstreamer-interfaces, do not know the package name (perl ?)
Code: Select all
mkdir [your working folder]
cd [your working folder]

// first time only
Code: Select all
svn checkout

Code: Select all
> cd trunk

// for updating
Code: Select all
svn update
// or simple
svn up

Code: Select all
./configure -C

reconf-all needs about 1.5 h

|| - gb.db.sqlite2
|| - gb.jit
// i do not really know what's about JIT, its available from repo in version 3.1
but gambas does not like it , hm (?)

Code: Select all

sudo make install

to start Gambas
Code: Select all
Posts: 45
Joined: Mon Aug 06, 2012 12:07 pm
by Grant » Sun Oct 28, 2012 11:05 am
Hi all,

This is what I did: sudo apt-get install gambas3
No matter what I try here all I get is 100% CPU load and nothing happens.

When I try to do sudo dpkg -i to install, I get this message:
package architecture (armel) does not match system (armhf)

Another thing I have tried to do is to install *.deb files that I have written in Gambas3 under Ubuntu 12.04. Still no luck, I see them in the desktop menu but nothing happens when I try to run them. What do I need to do to run *.deb files under the Pi desktop? do I need to have Gambas3 install first or some extra files to run Gambas3 applications?
Posts: 2
Joined: Sat Oct 27, 2012 3:52 am
by g4eml » Sun Oct 28, 2012 5:35 pm
Hi Grant...

Please read my previous post in this thread. As you have found, the Repository version of Gambas3 does not work. My post gives details of a work-around to get it going.

Posts: 56
Joined: Wed Oct 05, 2011 1:50 pm
by goos » Sat Nov 03, 2012 11:48 am

I have installed Gambas 3 and have it working now. The question i have is how to set up graphic. I did it before in Gambas 2 but Gambas 3 does it different and i can't get my mind to it. Could someone please give me a short example how to setup a simple "Line" in Gambas 3. The next i can figure out myself.
Posts: 1
Joined: Sat Nov 03, 2012 11:41 am
by wally » Sun Nov 04, 2012 7:09 am

I'm not sure what do you mean by "setup a simple "Line" in Gambas 3".
but Gambas3 contains some examples.
e.g. Menu -> Open Example -> Drawing -> Painitng

Public Sub Example20()

Dim eWidth As Float
Dim Y As Float

Y = 20.5
For eWidth = 0 To 5 Step 0.25
Paint.LineWidth = eWidth
Paint.MoveTo(50, Y)
Paint.RelLineTo(200, 0)
Paint.Text(eWidth, 0, Y - 10, 40, 20, Align.Right)
Y += 20
lines.png (51.11 KiB) Viewed 7873 times
Posts: 45
Joined: Mon Aug 06, 2012 12:07 pm
by peba » Sun Nov 04, 2012 5:28 pm
Today I installed Gambas 3.3.90 from svn which needed some hours, but
the result is worth it. Gambas from svn compiles on the raspberry pi without
any problem and runs fine.
User avatar
Posts: 56
Joined: Tue Jun 12, 2012 8:16 pm
Location: Austria Korneuburg
by johnaaronrose » Tue Jan 22, 2013 1:53 pm

The link for the patch file no longer points to it. Could you reinstate it?
Posts: 49
Joined: Fri Apr 27, 2012 8:15 pm
by johnaaronrose » Tue Jan 22, 2013 4:03 pm
I've just uploaded the patch file to The link to it is:
Posts: 49
Joined: Fri Apr 27, 2012 8:15 pm
by smching » Thu Jan 24, 2013 11:33 am
Hi johnaaronrose,
This link seems cannot be download the file
Posts: 2
Joined: Thu Jan 24, 2013 11:29 am
by johnaaronrose » Fri Jan 25, 2013 10:34 am
Gambas (and other apps such as Synaptic) don't show all of their windows (due to their being too tall for the screen area used by X). Has anybody else had this problem?

I suspect that this might be due to my using a composite video (yellow) cable (connected to the 'Composite Video to Older TVs socket on the Pi) to connect to the LCD TV: this results in a black bar at the top & bottom of the screen. I'll see what happens when I get an HDMI - VGA converter as my LCD TV is too old to have an HDMI connection but does have a VGA connection.
Posts: 49
Joined: Fri Apr 27, 2012 8:15 pm
by johnaaronrose » Fri Jan 25, 2013 11:28 am

The link (labelled just Download) on the middle of the webpage does not seem to do anything but the link (labelled Download 19.4MB) on the top right of the webpage works OK. I don't know why this is. I assume that it's an error with
Posts: 49
Joined: Fri Apr 27, 2012 8:15 pm
by johnaaronrose » Fri Jan 25, 2013 1:56 pm
Posts: 49
Joined: Fri Apr 27, 2012 8:15 pm
by smching » Sun Jan 27, 2013 3:25 am
johnaaronrose wrote:Link to the Patch file is now also at:

I had downloaded the file. Thank You.
Posts: 2
Joined: Thu Jan 24, 2013 11:29 am
by jelanier » Tue Feb 05, 2013 2:45 pm
After installing the patch to overwrite files, I thought all was well until I got deeper into an application I was writing. As soon as I added a menu from menu-editor, and ran the app.,it crashed. You don't even have to add code for the menu for it to fail. (Gambas3 is not crashing, the app is crashing) You can write a simple program with maybe 2 buttons and 2 textboxes. Have the buttons write "hello" to the textboxes. It will run fine. Then add a menu to the form. Run it again and it will not work.

Is anyone else having this problem?

Posts: 3
Joined: Tue Feb 05, 2013 11:40 am
by jelanier » Wed Feb 06, 2013 2:03 pm
The Gambas site gives lib/module requirements, but not the correct names. How do you know the correct names to install for the pi?


Posts: 3
Joined: Tue Feb 05, 2013 11:40 am
by IRQ » Sun Feb 10, 2013 7:35 pm
Gambas 3.4 has been released!
Code: Select all
This new release fixes about 240 bugs and adds about 270 new features.

Here are some main changes:
* A custom terminal font is now provided with the IDE.
* Better subversion support in the IDE.
* Patch support in the IDE.
* A new gb.args component that replaces gb.option.
* A new gb.maps component for displaying Google Maps, OpenStreetMap...
inside your application.
* Support for the freedesktop shared MIME database.
* The old drawing API has been deprecated. Now everything is based on
Cairo for GTK+.
* Many controls are now implemented in Gambas and shared between GUI
* A new fast blur method in the Image class.
* The webkit component now has full support for DOM parsing and editing.

See the Release Notes for the list of all new features and bug fixes.

(Grabbed from Benoît Minisini post on Gambas3 mailing list)
Posts: 35
Joined: Thu Aug 09, 2012 4:56 pm
by jelanier » Mon Feb 11, 2013 11:03 pm
IRQ wrote: Gambas 3.4 has been released!

Yes. I have already compiled and installed it. It takes a long time. ./reconfig-all took over 2 hours! Anyway, it works.

Posts: 3
Joined: Tue Feb 05, 2013 11:40 am