honey
Posts: 42
Joined: Sun Jan 04, 2015 10:10 am

Solved installing vscode apt is for pi4

Thu Jul 22, 2021 4:04 pm

Im install the vscode in my raspaberry pi b+ using apt , but the it give an error
Invalid instrution , im undering if its possible to rebuild the pack vbcode from this side
https://github.com/microsoft/vscode wat is the executable under debian?
Thanks :)
Last edited by honey on Wed Aug 04, 2021 12:26 pm, edited 1 time in total.

fruitoftheloom
Posts: 27226
Joined: Tue Mar 25, 2014 12:40 pm

Re: Installing vscode apt is for pi4

Thu Jul 22, 2021 4:19 pm

removed response not helpful....
Last edited by fruitoftheloom on Tue Jul 27, 2021 10:22 am, edited 1 time in total.
Take what I advise as advice not the utopian holy grail, and it is gratis !!

honey
Posts: 42
Joined: Sun Jan 04, 2015 10:10 am

Re: Installing vscode apt is for pi4

Mon Jul 26, 2021 5:55 pm

Thanks any way

User avatar
craigevil
Posts: 253
Joined: Wed Jan 27, 2021 5:22 am
Location: OZ

Re: Installing vscode apt is for pi4

Mon Jul 26, 2021 9:35 pm

https://code.visualstudio.com/docs/setup/raspberry-pi
System requirements#
VS Code is supported on these Raspberry Pi models running a 32-bit or 64-bit version of Raspberry Pi OS:

Raspberry Pi 3 Model B/B+
Raspberry Pi 4 Model B
Raspberry Pi 400
While 1 GB of memory (RAM) meets the minimum system requirements, users will benefit from installing VS Code on a Raspberry Pi 4 with more memory.

First-generation Raspberry Pi modules and Raspberry Pi Zero are not supported as they only include an ARMv6 CPU.
Raspberry PI 400 Raspberry Pi OS (Debian Bookworm/sid) Kernel: 5.10.63-v8+ aarch64 DE: MATE Ram 4GB
Debian - "If you can't apt install something, it isn't useful or doesn't exist"

honey
Posts: 42
Joined: Sun Jan 04, 2015 10:10 am

Re: Installing vscode apt is for pi4

Sun Aug 01, 2021 9:24 pm

Im as hope you help me to compile from the zero all the code ;to bypass the out of instrution is miss out :)
Im see is not possible thanks any way :)
Im give up im waiting microsoft build a more advencing code :)

ejolson
Posts: 8103
Joined: Tue Mar 18, 2014 11:47 am

Re: Installing vscode apt is for pi4

Sun Aug 01, 2021 11:49 pm

honey wrote:
Sun Aug 01, 2021 9:24 pm
Im as hope you help me to compile from the zero all the code ;to bypass the out of instrution is miss out :)
Im see is not possible thanks any way :)
Im give up im waiting microsoft build a more advencing code :)
The vscode source repository

https://github.com/Microsoft/vscode/wik ... Contribute

recommends node-js 14.x while the last stable ARMv6 binaries at

https://nodejs.org/dist/

are for node-js 10.x, see also

https://nodejs.org/en/about/releases/

This suggests recent versions of node-js are too fashionable to run on the Pi Zero. As a result, it appears the needed tools for vscode are not available.

While one might have thought open source that once ran on a particular architecture would continue to do so, the fact that it often doesn't is sometimes called bit rot. If developing a program to run on the Pi Zero, my recommendation would be to use the full version of vim

$ sudo apt-get install vim

and write the program in C. In my opinion, the C development tool chain for the Zero is unlikely to rot anytime soon.

There may be a way to use vscode on the Zero. I just don't know how. It would be nice to hear if someone else managed.

honey
Posts: 42
Joined: Sun Jan 04, 2015 10:10 am

Re: Installing vscode apt is for pi4

Wed Aug 04, 2021 10:35 am

Thanks

Return to “Other programming languages”