Page 1 of 1

Issues with Qt5 apps

Posted: Mon Sep 08, 2014 4:40 pm
by gmas
Good morning,

I am an almost beginner with RPi (I have just bough my first RPi B+), and I am using Raspbian Jessie as dist (mainly, to get compiled Qt5 libs).

Everything works fine with some exceptions. Whatever Qt app I run, I get:
  1. using -platform xcb (desktop environment), the app works fine but I get the following warnings each time a click on the gui:

    Code: Select all

    Cant find EGLConfig, returning null config
    Unable to find an X11 visual which matches EGL config 0
    Could not initialize OpenGL for RasterGLSurface, reverting to RasterSurface.
    
  2. using -platform eglfs (desktop enviroment), the app does not work:

    Code: Select all

    Aborted
    
  3. using -platform xcb (command-line enviroment), the app does not work:

    Code: Select all

    QXcbConnection: Could not connect to display
    Aborted
    
  4. using -platform eglfs (command-line enviroment), the app does not work:

    Code: Select all

    Aborted
    
  5. using -platform linuxfb -plugin EvdevMouse -plugin EvdevKeyboard (command-line enviroment),
    the app works fine
1: How can I fix the first warning? No hint from googling around..

2,4: Could the eglfs abortions be related to not opening a 'full-screen' application?

3: Is the 'xcb' plugin not running expected?

Do you have comments or suggestions on these outputs? Any help is very appreciated!

Re: Issues with Qt5 apps

Posted: Wed Jul 29, 2015 8:16 am
by zehfernandes
Same issue.

Using qt-webkit-kiosk

"Could not initiliaze egl display"

Some idea why this happen?

Re: Issues with Qt5 apps

Posted: Tue Sep 08, 2015 12:02 pm
by john75
Hello, there,

When building with Qt on Linux I found installing the following packages was useful:

sudo apt-get install build-essential
sudo apt-get install mesa-common-dev
sudo apt-get install libglu1-mesa-dev -y

I was intrigued to note that Qt5 libs are available on pi. I've been looking all over for this. I know that Qt4 is available through apt-get but I thought you had to compile Qt5 from sources....

Re: Issues with Qt5 apps

Posted: Wed Sep 09, 2015 11:27 am
by topguy
> 1: How can I fix the first warning? No hint from googling around..

Removing any reference to OpenGL in your code might be useful.

> 2,4: Could the eglfs abortions be related to not opening a 'full-screen' application?

Could be a GPU-memory problem also, what is your mem split.

> 3: Is the 'xcb' plugin not running expected?

xcb-plugin can not run without X-windows running, so I would say its expected.