mmkw43
Posts: 699
Joined: Tue Dec 24, 2013 6:18 pm

Python3.7 -- imagetk

Sun Dec 06, 2020 10:14 pm

My script runs fine in python 3.4. Thought I'd try it on the latest rpi os and get the error "can't import ImageTk from PIL".
?
And -- should I even be attempting to run a script I wrote with 3.4 in 3.7.1 ? Are they backwards compatible or am I asking for trouble? Changed the shebag line to 3.7 -- first attempt and I got the ImageTk error.

mmkw43
Posts: 699
Joined: Tue Dec 24, 2013 6:18 pm

Re: Python3.7 -- imagetk

Sun Dec 06, 2020 11:49 pm

DISREGARD --- PROBLEM SOLVED. python3 image tk isn't installed with python 3.7

Return to “Python”