Destroyer_
Posts: 7
Joined: Wed Nov 14, 2018 4:46 pm

python3-ws4py on Buster

Mon Dec 09, 2019 7:57 am

Log:

Code: Select all

sudo apt install python3-ws4py
Reading package lists... Done
Building dependency tree
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
python3-ws4py : Depends: python3:any (>= 3.3.2-2~)
E: Unable to correct problems, you have held broken packages.
I really need python3-ws4py for my project, but it is broken on buster.
-Does somebody know if python3-ws4py will be pached for Buster?
-Is there a way to downgrade to a version of raspbian that is working?

mattmiller
Posts: 2233
Joined: Thu Feb 05, 2015 11:25 pm

Re: python3-ws4py on Buster

Mon Dec 09, 2019 8:33 am

According to the github repositry - its not being actively maintained so your prob going to be out of luck :(

https://github.com/Lawouach/WebSocket-for-Python

Prob best to try and find another library that does what your after

Return to “Python”