Page 1 of 1

scipy.signals import issue

Posted: Thu Jun 20, 2019 7:10 am
by rmunny
Hello,
I am having an issue importing find_peaks from scipy.
Following are the things I'm importing:
import numpy as np
import pywt
import pathlib
#import scipy.signal as signal
from scipy.signal import butter, lfilter
from scipy.signal import find_peaks

And that's the error I am getting in the attachment. Anyone can help me how to fix it?

Thanks!

Re: scipy.signals import issue

Posted: Thu Jun 20, 2019 8:56 am
by saltydog
What version scipy are you using?

Re: scipy.signals import issue

Posted: Thu Jun 20, 2019 6:44 pm
by rmunny
Hi,
I am new on this platform. Not sure if that's the right way to check the version. Attached the snapshot
Capture.JPG
Capture.JPG (16.85 KiB) Viewed 421 times
I understand I have to upgrade the version to use find_peaks. But I don't know how to do it. I am using raspberry pi 3 B+. Any suggestion?

Re: scipy.signals import issue

Posted: Thu Jun 20, 2019 11:35 pm
by saltydog
The debian repo's are going to be a long way behind. You would need to build from source. I wasn't successful last time I tried.
Others have been. See:
https://raspberrypi.stackexchange.com/q ... spberry-pi

Chris